Bug 159211 - lbxproxy noisily dies with ipv6 disabled
lbxproxy noisily dies with ipv6 disabled
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
https://bugs.freedesktop.org/show_bug...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-31 12:26 EDT by Frank Ch. Eigler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 04:21:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 3565 None None None Never

  None (edit)
Description Frank Ch. Eigler 2005-05-31 12:26:58 EDT
Description of problem:

If the ipv6 protocol is disabled, for example by adding "alias net-pf-10 off"
into /etc/modprobe.conf, lbxproxy gets into an endless initialization loop.
It prints lines about being unable to open companion ipv6 listening sockets,
then tries again at port N+1, and so on, ad infinitum.  It doesn't get to
actually starting to work, even on the existing ipv4 socket.  (Actually,
it's *sockets*, since it creates hundreds of ipv4 ones in the loop.)

Version-Release number of selected component (if applicable):

xorg-x11-6.8.2-1.FC3.13

To reproduce:

Turn off ipv6.  Reboot machine.  Start X session.  Run "lbxproxy".  It may
spew a lot of text instead of being nice and quiet, and actually working.
Comment 1 Mike A. Harris 2005-06-17 13:13:06 EDT
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO", awaiting X.Org bug URL for tracking.
Comment 2 Frank Ch. Eigler 2005-06-17 15:41:26 EDT
As requested, the bz 3565 @ opendesktop.  It's disappointing that you force bug
reporters to do this work twice.  I know of no other RH software packager /
maintainer that imposes this requirement.
Comment 3 Frank Ch. Eigler 2006-02-19 11:33:38 EST
Can you explain how "CLOSED UPSTREAM" relates to a fix to this problem?  The
upstream bug is still in the NEW state, so is there any reason that a later
fedora snapshot has received a fix?
Comment 4 Mike A. Harris 2006-02-21 04:21:20 EST
"UPSTREAM" status reflects that the issue is being tracked in the upstream
bug tracker, and once a patch or solution is available from upstream, we
will review it and consider including it in a future release.

The "CLOSED" part is a misnomer.  Technically it is OPEN->UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.