Bug 159253 - Evolution IMAP auto-check never turns off.
Evolution IMAP auto-check never turns off.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-31 17:26 EDT by Ali-Reza Anghaie
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-18 06:14:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali-Reza Anghaie 2005-05-31 17:26:33 EDT
Description of problem:

Evolution IMAP receiving options never ~doesn't~ check for email at intervals.
Regardless of whether automatically check or autosync are on-of-off, it checks.
The only difference is when it's explicitely checked it does seem to repsect the
time limit. Problem here is that it'll fail a lot of times with a 'error
pinging' when there is no network connectivity and I've intentionally turned off
the autocheck.

Version-Release number of selected component (if applicable):

evolution-2.0.2-16

How reproducible:

Always.

Steps to Reproduce:
1. Setup an Evolution profile for an IMAP server.
2. Check auto-check and set your time interval. Wait until it works once.
3. Un-check auto-check and wait a while. It goes ahead and checks.
  
Actual results:

Keeps checking and syncing even if you don't want it to.

Expected results:

Want it to be completely manual.

Additional info:

I've already tried removing the profile and adding it fresh and that didn't
help. I've tried various combinations with no luck. Other evo. packages
installed are:

evolution-data-server-1.0.2-4
evolution-webcal-1.0.10-1
evolution-connector-2.0.2-3
Comment 1 Dave Malcolm 2005-06-01 16:40:11 EDT
Thanks for the bug report; I'm looking into it.
Comment 5 Ali-Reza Anghaie 2005-06-21 08:43:42 EDT
There is something else to consider, a lot of sites are dropping ICMP at their
border (perhaps naively) but that's life. So the ping check is just a bad idea
in those cases and should be optional. More importantly though, the auto-check
feature needs to work.

I'm also going to enter this in the RHEL support system. Cheers, -Ali
Comment 7 Dave Malcolm 2005-08-18 01:07:07 EDT
I've been looking at this but have been unable to reproduce the problem
described in the initial report; Evolution appears to be honouring the settings
of the account, in my test setup, at least.

I can supply a test build of Evolution with more extensive debug logging of the
autocheck code if that would be helpful.

I'll continue to look into this; the code in question is messy, alas, and I may
have missed something.
Comment 8 Ali-Reza Anghaie 2005-08-18 06:14:58 EDT
Since originally submitting this I also got bounced around in RHEL support. A
few things:

- It's not really an ICMP ping. And that problem goes away if you break your
folders out in such a way that none are too large. It was weird but I can make
it happen if I filter in Evo but if I filter on the server size it opens new
IMAP folders and the problem goes away. If I filter into one big folder on the
server side the problem comes back.

- The other problem, for polling, still exists. However it appears to be an
issue of once you ever set it to poll, it realy doesn't stop polling on that
profile again. Time changes take affect. However with the first problem somewhat
fixed or worked-around this issue isn't as big because the polling no longer
fails 80% of the time. Now it rarely, if ever, fails.

Since I forgot I had this ticket here I never updated. I'll close at this point.
-Ali
Comment 9 Dave Malcolm 2005-08-18 14:28:05 EDT
Thanks for the feedback.  I hope that Evolution in RHEL 4 is working well for
you now.  If this bug becomes an issue for you, please reopen this bug.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.