Bug 159256 - SFTP subsystem doesn't work.
SFTP subsystem doesn't work.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-31 17:40 EDT by Ali-Reza Anghaie
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-25 22:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali-Reza Anghaie 2005-05-31 17:40:24 EDT
Description of problem:

SFTP subsystem doesn't work. Fails silently while SCP works fine.

Version-Release number of selected component (if applicable):

openssh-3.9p1-8.RHEL4.1

How reproducible:

Always.

Steps to Reproduce:
1. Just try inbound SFTP on a stock RHEL 4 machine.
2.
3.
  
Actual results:

SFTP inbound fails.

Expected results:

SFTP inbound should work.

Additional info:

All it does is create nice secure log entries like:

May ## ##:##:## hostname sshd[11537]: subsystem request for sftp

And nothing else. The client fails to connect regardless of client. SCP works
fine. No process I can see via ps or top seems to actually be launched on the
server side. Haven't tried tracing or debug mode yet, will update with debug
after I get these mass migrations done via SCP first.
Comment 4 Tomas Mraz 2005-06-06 09:28:25 EDT
I couldn't reproduce this problem here do you have more information? F. E. exact
commands which fail, architecture of the HW, the debugging logs and so on.
Comment 5 Ali-Reza Anghaie 2005-06-25 22:02:48 EDT
The problem seems to be unique to when I'm using a WinSCP client. The logging
shows nothing useful, it just drops. Verbose doesn't help either.... just
*poof*. I haven't captured a session via Ethereal but I'm unsure that's going to
be fruitful. Since it's unique to the WinSCP client (tried various versions
too), I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.