Bug 15926 - changing user id with usermod breaks gnome
Summary: changing user id with usermod breaks gnome
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-10 15:21 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-19 22:26:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-10 15:21:38 UTC
I had to change user id. I typed usermod -u id# user_name
ID was succesfully changed (I checked it ). I log out and log in again,
gnome did not start ( black screen with cursor on  it ).
FIX:  kill.gnome-session from other machine, cd /tmp; rm -rf
orbit-user_name, then logout and login again.

                   Irina Kaliman, System Administrator, University
                       of Miami

Comment 1 Dale Lovelace 2000-08-19 19:33:14 UTC
  Looks like usermod should scan the filesystem for files that belong to a user
if his uid is changed. Moving this bug to shadow-utils (usermod)

Comment 2 Bill Nottingham 2000-08-19 22:26:00 UTC
Oh, that's excessively painful. I'd be inclined to just leave
it as a wontfix.

Comment 3 Bernhard Rosenkraenzer 2000-08-23 18:40:13 UTC
Agreed - it would probably cause more trouble than it's worth.


Note You need to log in before you can comment on or make changes to this bug.