Bug 159334 - [RHEL4] gftp crashes when file download attempt is made
[RHEL4] gftp crashes when file download attempt is made
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gftp (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
Mike McLean
Depends On:
Blocks: 181409
  Show dependency treegraph
Reported: 2005-06-01 14:23 EDT by David Lehman
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2006-0468
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-10 17:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
gftp-64-bit-fixes.patch (4.70 KB, patch)
2005-11-04 05:08 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description David Lehman 2005-06-01 14:23:13 EDT
+++ This bug was initially created as a clone of Bug #140567 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
I attempted a file transfer from a remote ftp to my system.  I
selected the folder I wanted the file to go in the left pane of the
program, and selected the file I wanted to transfer on the right.  I
clicked the right arrow signifying the transfer and the program crashed.

I tried this again but instead dragged the fil from the right pane to
the left, with the same results.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Login to a FTP
2. Click a file on the right pane to download
3. Click the bottom arrow pointing left or drag the file to left pane

Actual Results:  Gftp crashed.

Expected Results:  For the file to transfer to the specified folder.

Additional info:
I started looking for the relevant patch by looking at 2.0.18 but it occurs to
me you may be able to do it much faster. Let me know if you need me to try
tracking it down and I'll post the patch here.
Comment 2 Caner Baydemir 2005-06-09 04:44:15 EDT
it's not a bug actually, it has to be x86_64 but redhat gives just i386 version
that's why... just get the gftp source rpm and rebuild with "--target x86_64"
option like this:

rpmbuild --rebuild gftp-foo.src.rpm --target x86_64

and then, remove i386 one and install new x86_64 package...
Comment 3 Dani Gleser 2005-08-31 12:47:11 EDT
I have the same issue and I tried your sollution and it still does not work. 
x86_64 platform, Dell, REL 4 WS.  Every time I try and download it crashes.
Comment 4 Bastien Nocera 2005-11-04 05:08:20 EST
Created attachment 120719 [details]

Fix backported from upstream
Comment 11 William D. Hamblen 2006-04-20 10:04:32 EDT
I'm seeing this same behaviour in gftp-2.0.17-5.x86_64.  I tried several ftp
sites (including the bookmark to RH Updates) and while it connects okay, every
time I try a transfer (in either direction) gftp immediately segfaults after
creating an empty file.  I can however rename and delete files without problem
(locally and remotely) - just transfers are a problem.  

Building from the source RPM (I tried both 2.0.17-3 and 2.0.17-5) made no
difference.  This is RHEL WS 4, fully patched as of 4/20/2006.
Comment 12 Bert Heise 2006-04-20 17:11:23 EDT
I can confirm this bug -  I also see it on our RHEL WS 4 x86_64 using even the
updated 2.0.17-5 version. Are we supposed to do anything with the
"gftp-64-bit-fixes.patch" attachment of Bastien and if so, what?
Comment 13 Bert Heise 2006-04-20 17:52:22 EDT
After a bit more digging, I found that the guys at Fedora (actually the gftp
programmer) solved it with version 2.0.18 of gftp (see www.gftp.org): 


I downloaded and built it from the source - runs fine! Curiously enough, that
version 2.0.18 dates from January 2005 - before this RHEL bug appeared... %-)
Comment 14 Matthias Clasen 2006-04-28 12:53:58 EDT
Patch has been included in gftp-2.0.17-6
Comment 19 Red Hat Bugzilla 2006-08-10 17:40:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.