Bug 159365 - ldapserver fails to build with gcc4
ldapserver fails to build with gcc4
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Database - General (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-01 19:08 EDT by Brian Stevens
Modified: 2015-12-07 12:15 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:15:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for gcc4 (2.11 KB, text/plain)
2005-06-01 19:08 EDT, Christopher Blizzard
no flags Details

  None (edit)
Description Christopher Blizzard 2005-06-01 19:08:52 EDT
Very minor problems, patch attached.  Don't know how to test for an older gcc
that does accept -fwritable-strings, though.
Comment 1 Christopher Blizzard 2005-06-01 19:08:52 EDT
Created attachment 115069 [details]
patch for gcc4
Comment 3 Rich Megginson 2005-12-01 12:02:15 EST
We have patch files for the components that need them.  The instructions on the
building page have been updated - http://directory.fedora.redhat.com/Building
In addition, if you use the dsbuild script, it applies the patches automatically
- http://directory.fedora.redhat.com/sources/dsbuild-fds10.tar.gz

Builds and runs on Fedora Core 4 using gcc4.
Comment 4 Red Hat Bugzilla 2007-10-21 20:43:27 EDT
User blizzard@redhat.com's account has been closed
Comment 5 Anh Nguyen 2007-11-27 12:15:05 EST
Reviewed and changed QA Whiteboard to to_be_verified_by_del
Comment 6 Nathan Kinder 2007-11-27 12:38:12 EST
We are building regularly on platforms that use gcc4.  Marking as verified.

Note You need to log in before you can comment on or make changes to this bug.