Bug 159389 - HP 1100C does not work with (recommended) hpijs driver
HP 1100C does not work with (recommended) hpijs driver
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: hpijs (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-02 07:24 EDT by Andrew Gormanly
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 12:01:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Gormanly 2005-06-02 07:24:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.7.8-1.1.3.1

Description of problem:
When using the recommended driver, hpijs, for an HP DeskJet 1100C, no output is produced and the paper feed light just flashes.

This driver worked perfectly with this printer on RHEL3.

The gimp-print-ijs driver works fine.

Version-Release number of selected component (if applicable):
hpijs-1.6-2

How reproducible:
Always

Steps to Reproduce:
1. Start system-config-printer
2. Choose printer model and recommended driver
3. Print test page
  

Actual Results:  Paper feed light flashes a few time, but no output is produced.

Expected Results:  The Red Hat printer test page appears.

Additional info:

hpijs-1.3-32.1.9 on RHEL3 works fine for this model.
Comment 2 Tim Waugh 2005-06-02 12:00:05 EDT
Please attach the output of 'printconf-tui --Xexport', making sure to replace
any passwords it may contain with '*'s.  Thanks.
Comment 3 Andrew Gormanly 2006-02-23 10:44:29 EST
Ok, it works now with the "Deskjet 1100C" model and "hpijs" driver selected in
the system-config-printer gui, but does not work when "DeskJet 1100C hpijs
(PPD)" model and "ppd" driver are selected.

I think this might be a hpijs-1.6-2 vs. cups-1.1.22-0.rc1.9.10 issue, but at
least I can print now.

(I've been printing on another machine for months - sorry for not getting back
to this bug for ages!)
Comment 4 Tim Waugh 2006-02-23 10:50:48 EST
The names "DeskJet 1100C hpijs (PPD)" for model and "ppd" for driver suggest
that you imported a PPD for this printer using "Action->Import PPD...".  Was
that a PPD from www.linuxprinting.org, or somewhere else?

The correct values should be "Deskjet 1100C" for model and "hpijs" for driver.
Comment 5 Andrew Gormanly 2006-02-23 11:37:38 EST
It seems that I did, about 15 minutes after submitting this bug, in an attempt
to get this working last year.  In any case, it works now with those values you
list as of yesterday when I tried re-setting it up, so I guess it's not worth
wasting your time on.

If nothing relevant has changed in cups since June, I'll chalk it up as random
annoyance (as it worked until then on a RHEL3 box, and I've been without a
desktop printer for almost 9 months) and leave it at that.

Thanks for your time though!
Comment 6 Tim Waugh 2006-02-23 12:01:59 EST
I suspect it's that the hpijs we ship is different to the one linuxprinting.org
knows about (different version).

Note You need to log in before you can comment on or make changes to this bug.