Bug 159400 - Introduce "-e trace=desc"
Introduce "-e trace=desc"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
: FutureFeature
Depends On: 159340
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-02 09:31 EDT by Dmitry V. Levin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-04 23:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace-4.5.11-alt-TD.patch (154.32 KB, patch)
2005-06-02 09:33 EDT, Dmitry V. Levin
no flags Details | Diff
strace-20050607-alt-TD.patch (154.57 KB, patch)
2005-06-08 06:27 EDT, Dmitry V. Levin
no flags Details | Diff
strace-20050607-alt-TD.patch (154.57 KB, patch)
2005-06-08 06:27 EDT, Dmitry V. Levin
no flags Details | Diff

  None (edit)
Description Dmitry V. Levin 2005-06-02 09:31:05 EDT
I find useful to add one more trace class: file descriptors.
It could be defined as set of syscalls which take a file descriptor as an argument or return a file descriptor,
except network related syscalls (since all of them either take a file descriptor as an argument or return a file descriptor anyway).
Comment 1 Dmitry V. Levin 2005-06-02 09:33:44 EDT
Created attachment 115083 [details]
strace-4.5.11-alt-TD.patch

Proposed patch, to be applied on top of strace-4.5.11-alt-TF.patch
Comment 2 Dmitry V. Levin 2005-06-08 06:27:40 EDT
Created attachment 115215 [details]
strace-20050607-alt-TD.patch

Rediffed for cvs snapshot 20050607.
Comment 3 Dmitry V. Levin 2005-06-08 06:27:55 EDT
Created attachment 115216 [details]
strace-20050607-alt-TD.patch

Rediffed for cvs snapshot 20050607.
Comment 4 Roland McGrath 2005-07-04 23:25:58 EDT
Applied upstream.  Thanks for the patch.

Note You need to log in before you can comment on or make changes to this bug.