Bug 159407 - OOPS at mb_update_sb (0xb2) when fail SATA drives
OOPS at mb_update_sb (0xb2) when fail SATA drives
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-02 10:15 EDT by Joe Keller
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:01:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Keller 2005-06-02 10:15:46 EDT
Description of problem:

When attempting to remove several devices from a md group using mdadm I get an 
OOPS.  The problem only appears on systems with SATA drives and not IDE 
drives.  Using the latest 2.4.21-32.0.1 kernel doesn't fix the problem.  If I 
do a sleep(5) in my script after "mdadm --remove" then the problem goes away.


Version-Release number of selected component (if applicable):

kernel-2.4.21-27.0.2

How reproducible:

Always

Steps to Reproduce:
1. Run script shown below
2.
3.
  
Actual results:

Oops: 0000
CPU:    2
EIP:    0060:[<c0214fb2>]    Tainted: P 
EFLAGS: 00010202

EIP is at md_update_sb [kernel] 0xb2 (2.4.21-27.0.2.EL/i686)
eax: 00000f80   ebx: f716c600   ecx: 00000000   edx: f716c600
esi: f7138194   edi: f7138180   ebp: 00000000   esp: f712bf38
ds: 0068   es: 0068   ss: 0068
Process raid1d (pid: 29, stackpage=f712b000)
Stack: f48bdd00 00000002 c868e000 00000064 f712a000 00000001 f712bfb4 f7138180 
       f8855daa f7138180 c878fe88 f712a000 c043c680 f712bf7c f712bf7c 00000000 
       00000002 f712a000 c878fe80 f712bfb4 c878fe88 c021816d f713a000 f8857644 
Call Trace:   [<f8855daa>] raid1d [raid1] 0x38a (0xf712bf58)
[<c021816d>] md_thread [kernel] 0x14d (0xf712bf8c)
[<f8857644>] .rodata.str1.1 [raid1] 0x75 (0xf712bf94)
[<c0218020>] md_thread [kernel] 0x0 (0xf712bfe0)
[<c01095ad>] kernel_thread_helper [kernel] 0x5 (0xf712bff0)

Code: f6 40 10 01 75 04 85 c9 74 3a 89 da 8b 1b 39 73 04 75 db 85

Kernel panic: Fatal exception


Expected results:

No OOPS

Additional info:

The script to reproduce the problem is:
#!/bin/bash
/sbin/mdadm /dev/md7 --fail /dev/sdb7
/sbin/mdadm /dev/md7 --remove /dev/sdb7
/sbin/mdadm /dev/md12 --fail /dev/sdb12
/sbin/mdadm /dev/md12 --remove /dev/sdb12
/sbin/mdadm /dev/md3 --fail /dev/sdb3
/sbin/mdadm /dev/md3 --remove /dev/sdb3
/sbin/mdadm /dev/md8 --fail /dev/sdb8
/sbin/mdadm /dev/md8 --remove /dev/sdb8
/sbin/mdadm /dev/md10 --fail /dev/sdb10
/sbin/mdadm /dev/md10 --remove /dev/sdb10
/sbin/mdadm /dev/md2 --fail /dev/sdb2
/sbin/mdadm /dev/md2 --remove /dev/sdb2
/sbin/mdadm /dev/md9 --fail /dev/sdb9
/sbin/mdadm /dev/md9 --remove /dev/sdb9
/sbin/mdadm /dev/md1 --fail /dev/sdb1
/sbin/mdadm /dev/md1 --remove /dev/sdb1
/sbin/mdadm /dev/md5 --fail /dev/sdb5
/sbin/mdadm /dev/md5 --remove /dev/sdb5
/sbin/mdadm /dev/md11 --fail /dev/sdb11
/sbin/mdadm /dev/md11 --remove /dev/sdb11
/sbin/mdadm /dev/md6 --fail /dev/sdb6
/sbin/mdadm /dev/md6 --remove /dev/sdb6
Comment 1 RHEL Product and Program Management 2007-10-19 15:01:07 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.