Bug 15941 - pump doesn't get DNS server address or set default route
pump doesn't get DNS server address or set default route
Status: CLOSED DUPLICATE of bug 15942
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-10 15:20 EDT by Matt Domsch
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-10 17:54:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2000-08-10 15:20:03 EDT
pump appears broken in RC1 during bootnet NFS installs.  It claims it 
didn't receive a DNS server address from DHCP, so prompted me for that.  
OK, but then it still couldn't mount the NFS directory.  Using static IP 
addresses, it continued fine.  I know pump can see my DHCP server and get 
the DNS server address, this worked in beta5 installed yesterday on the 
same system.

-----Original Message-----
From: Erik Troan [mailto:ewt@redhat.com]
Sent: Thursday, August 10, 2000 1:15 PM
To: Matt_Domsch@exchange.dell.com
Cc: msw@redhat.com
Subject: Re: RC1: bootnet NFS install, pump doesn't work, static IP does

Oh yeah, does pump work after install or is the default gateway missing?

Erik

-----Original Message-----
From: Domsch, Matt 
Sent: Thursday, August 10, 2000 1:21 PM
To: 'Erik Troan'
Cc: msw@redhat.com
Subject: RE: RC1: bootnet NFS install, pump doesn't work, static IP does

pump worked for pinstripe install just fine.
pump worked after install of pinstripe too.  my RC1 box is 
still installing using static IPs, I'll tell you shortly if 
that worked.  Didn't try pinging, but it insmod'd the 
eepro100 driver properly.
No, the NFS server is on 10.xx.xx.xx (same machine as my 
DNS server), but my DHCP address is 143.166.xxx.xxx.
-Matt

-----Original Message-----
From: Erik Troan [mailto:ewt@redhat.com]
Sent: Thursday, August 10, 2000 1:38 PM
To: Matt_Domsch@exchange.dell.com
Cc: msw@redhat.com; Trond Eivind Glomsrod
Subject: RE: RC1: bootnet NFS install, pump doesn't work, static IP does

Somehow someone (ahem, not me, I um, assure you, yeah, that's it) has
managed to get pump to not always setup a default route 
properly. That's biting you :-(
 
Any details would help! Esp why pumpSetupDefaultRoute() 
doesn't seem to be gettting called.
Erik
Comment 1 Michael Fulbright 2000-08-10 17:53:24 EDT

*** This bug has been marked as a duplicate of 15942 ***

Note You need to log in before you can comment on or make changes to this bug.