Bug 15947 - procmail delivery to an address (with '!') doesn't work in procmail 3.14!
Summary: procmail delivery to an address (with '!') doesn't work in procmail 3.14!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procmail   
(Show other bugs)
Version: 6.2
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-10 20:10 UTC by Jonathan Kamens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-10 20:11:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to put a space before addresses in address delivery (348 bytes, patch)
2000-08-10 20:11 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2000-08-10 20:10:37 UTC
With procmail 3.14, to which Red Hat updated in 6.2, any delivery rule
which says to deliver to an E-mail address using the '!' action line will
fail to deliver the mail properly.

The problem is that the code sets the delivery command to

	$SENDMAIL $SENDMAILFLAGSaddress

where "address" is the address to which to deliver.  Since it doesn't put a
space between the $SENDMAILFLAGS variable reference and the address, the
whole thing, including the address, is interpreted as the variable name,
and of course that variable doesn't exist, so the expansion fails and
procmail delivers the message to "/usr/sbin/sendmail".  Since sendmail
isn't given any recipients, it simply drops the message on the floor.

The fix is trivial.  I will attach a patch.

Comment 1 Jonathan Kamens 2000-08-10 20:11:30 UTC
Created attachment 2375 [details]
patch to put a space before addresses in address delivery

Comment 2 Jeff Johnson 2000-08-11 15:39:10 UTC
Fixed in procmail-3.14-5. Thanks for reporting.


Note You need to log in before you can comment on or make changes to this bug.