Bug 159494 - IBM ACPI ultrabay eject crashes machine
IBM ACPI ultrabay eject crashes machine
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-02 18:40 EDT by Derek Atkins
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-04 10:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Atkins 2005-06-02 18:40:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I've got a Thinkpad T42p 2379-DYU running up-to-date FC3.  Whenever I try to eject the DVD from the Ultrabay the system crashes.  This happens regardless of whether I try to eject it by hand using the acpi scripts, or just following the ibm_acpi instructions and executing:

echo eject > /proc/acpi/ibm/bay

Whenever it crashes I get the following IDE/hdc errors in the log:

Jun  2 18:26:21 cliodev kernel: hdc: status error: status=0x00 { }
Jun  2 18:26:21 cliodev kernel: ide: failed opcode was: unknown
Jun  2 18:26:21 cliodev kernel: hdc: status error: status=0x00 { }
Jun  2 18:26:21 cliodev kernel: ide: failed opcode was: unknown
Jun  2 18:26:21 cliodev kernel: hdc: status error: status=0x00 { }
Jun  2 18:26:21 cliodev kernel: ide: failed opcode was: unknown
Jun  2 18:26:21 cliodev kernel: hdc: status error: status=0x00 { }
Jun  2 18:26:21 cliodev kernel: ide: failed opcode was: unknown
Jun  2 18:26:21 cliodev kernel: hdc: DMA disabled
Jun  2 18:26:22 cliodev kernel: hdc: ATAPI reset complete
Jun  2 18:26:22 cliodev kernel: hdc: status error: status=0x00 { }
Jun  2 18:26:22 cliodev kernel: ide: failed opcode was: unknown
Jun  2 18:26:22 cliodev kernel: hdc: status error: status=0x00 { }
Jun  2 18:26:22 cliodev kernel: ide: failed opcode was: unknown
Jun  2 18:26:22 cliodev kernel: hdc: status error: status=0x00 { }
Jun  2 18:26:22 cliodev kernel: ide: failed opcode was: unknown
Jun  2 18:26:22 cliodev kernel: hdc: status error: status=0x00 { }
Jun  2 18:26:22 cliodev kernel: ide: failed opcode was: unknown
Jun  2 18:26:22 cliodev kernel: hdc: ATAPI reset complete
[snip]

If I run from a VT console instead of X the machine will continually spew these messages to the console ad infinitum, so the machine really isn't crashed, per se, it's just spewing so many IDE failures that it's never doing anything else.

Version-Release number of selected component (if applicable):
All FC3 kernels from 2.6.10-1.770 through 2.6.11-1.27

How reproducible:
Always

Steps to Reproduce:
1. boot into FC3
2. echo eject > /proc/acpi/ibm/bay
3. lather, rinse, repeat.

Actual Results:  The system crashed.

Expected Results:  It should have soft-ejected the DVD drive without crashing the machine.  I want to hot-swap my drives.

Additional info:

see Documentation/ibm-acpi.txt in the kernel sources.
Comment 1 Alan Cox 2005-06-04 06:14:18 EDT
Drive hotplug is not supported in 2.6 only 2.4
Comment 2 Derek Atkins 2005-06-04 09:08:36 EDT
Um, where in the documentation does it say this?  Everywhere I can read it seems
to imply that Ultrabay Hotswap *IS* supported.

From http://ibm-acpi.sourceforge.net/ ...

he features currently supported are the following (see the README for detailed
description):
 ...
  o UltraBay eject (bay)
 ...

The site goes on to say:

  The ibm-acpi driver is part of kernel 2.6.10 and later (option
CONFIG_ACPI_IBM). The version included in the kernel may be older than the
latest release available from this web site.

Moreover, the 2.6.11 FC3 kernel DOES have ibm_acpi installed and turned on, and
my laptop DOES have the module loaded.

SO...  Drive hotplug SHOULD be supported, and I've definitely had reports from
Debian users that they could hotswap their ultrabay drives from a 2.6.10 kernel.
 So pardon me, Alan, when I don't believe you when you say that IBM Ultrabay
hotplug isn't supported in 2.6.  Could you please show a reference that states that?

I've already shown you two references that show that it SHOULD be supported (the
first one, Docuementation/ibm-acpi.txt in the 2.6 source tree) was pointed out
in the original bug report, the second just now).  I've also seen ACPI scripts
from another user running a different distro that had hotplug scripts for 2.6.x
(x > 10), which further shows evidence that it SHOULD work...  For example, see:
http://theorie.physik.uni-wuerzburg.de/~arwagner/computer/T41p/#HotSwap

<quote>
With the ibm_acpi module from kernel 2.6.10 there is also the possibility for
hotswapping of UltraBay-Devices, if you own several of them. I don't but at
least I was able to safely remove my DVD and reattache it without any problems. 
</quote>

My initial guess as to the problem is that cdrom subsystem is built into the
kernel instead of built as a driver, but that's why I've opened this bug report.
Comment 3 Alan Cox 2005-06-04 10:53:01 EDT
Drive hotplug for IDE has never been supported in 2.6. The ACPI layer may
support controlling the ultra bay devices. The user you quote was just extremely
lucky. 

I wrote and submitted patches long ago for IDE drive hotplug but the current
maintainer has not only rejected them but since then has removed the basic
support neccessary for their re-integration too.  Please take this matter
upstream with the IDE maintainer therefore.


Note You need to log in before you can comment on or make changes to this bug.