Bug 15956 - sndconfig has to run twice on NeoMagic MagicMedia 256 ZX
sndconfig has to run twice on NeoMagic MagicMedia 256 ZX
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-10 17:54 EDT by Dan Taylor
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-11 12:21:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsmod before (631 bytes, text/plain)
2000-08-11 10:49 EDT, Dan Taylor
no flags Details
lsmod after 1 (791 bytes, text/plain)
2000-08-11 10:52 EDT, Dan Taylor
no flags Details
lsmod after 2 (800 bytes, text/plain)
2000-08-11 10:53 EDT, Dan Taylor
no flags Details

  None (edit)
Description Dan Taylor 2000-08-10 17:54:36 EDT
Dell Latitude CSx 
(using the NeoMagic MagicMedia 256 ZX chipset)

After installing by booting to the CD, sndconfig has to be run twice for 
the sound to work (this error was duplicated on multiple installs).

After installing by booting from a floppy(bbot.img), sndconfig only has to 
be run once to get sound working.
Comment 1 Bill Nottingham 2000-08-10 23:04:30 EDT
Odd. What's in /etc/modules.conf after an install
but *before* you run sndconfig?

In the cases where you have to run it twice, what's
the error you get the first time?
Comment 2 Dan Taylor 2000-08-11 10:49:17 EDT
Created attachment 2396 [details]
lsmod before
Comment 3 Dan Taylor 2000-08-11 10:50:15 EDT
In the cases where I have to run the sndconfig twice, there are no error 
messages.  I am able to hear the test sound the first time it is run, but 
afterwards when attempting to #play a sound, it pauses for a second & acts like 
it is playing, but no sound is emitted.  In addition, on this last test case, 
after I ran sndconfig the second time & accepted the changes, the system hard 
locked.  I am including the lsmod data & the /etc/modules.conf data for 
the 'before sndconfig', the 'after 1st sndconfig', & 'after 2nd sndconfig'.  
Note that some of the lsmod data on the last one is different due to the lockup 
& the fact we had to hard boot the machine.

Comment 4 Dan Taylor 2000-08-11 10:52:16 EDT
Created attachment 2397 [details]
lsmod after 1
Comment 5 Dan Taylor 2000-08-11 10:53:45 EDT
Created attachment 2398 [details]
lsmod after 2
Comment 6 Dan Taylor 2000-08-11 11:00:11 EDT
***modules.conf-before***
alias parport_lowlevel parport_pc
alias usb-controller usb-uhci

***modules.conf-after-1***
alias parport_lowlevel parport_pc
alias usb-controller usb-uhci
alias sound-slot-0 nm256

***modules.conf-after-2***
alias parport_lowlevel parport_pc
alias usb-controller usb-uhci
alias sound-slot-0 nm256

Comment 7 Bill Nottingham 2000-08-11 12:21:09 EDT
Ugly. Alan, are you aware of any issues with the nm256 driver?

Note You need to log in before you can comment on or make changes to this bug.