Bug 159561 - left hand service selection menue will not be saved
left hand service selection menue will not be saved
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-04 05:21 EDT by Bernd Sowislo
Modified: 2008-02-16 11:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-16 11:06:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Sowislo 2005-06-04 05:21:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:
when I select additional services (like telnet) the service
will be marked. When I store the new settings, the
new settings are lost (in every RT level) the next time
 I start this GUI all the old values are displayed
I did not succeed in starting any service. Sometimes
it happenes the my interface eth0 will be deactivated
In the messages log there is an entry that my interface
is marked as fixed IP address, but there is no information
about a static address or router. In the hardware configuration
GUI for eth0 are all entries available and I can simply
reactivateeth0 from there. But the new selected services
are never available.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1286_FC4

How reproducible:
Always

Steps to Reproduce:
1.start system-services-config from root
2.select any service from the left hand menue and store this configuration 
3.exit the program an start new, no menue is like 1. 
  

Actual Results:  no changes , no service is started nothing has happened

Expected Results:  The service should run, the marked service should be marked
after the restart of system-services-configuration

Additional info:

sometimes eth0 is deactivated. Even a reboot does not change this state
(the harddisk is heavily working after reboot). The interface eth0 has
to be reconfigured.
Comment 1 Nils Philippsen 2005-06-06 03:55:55 EDT
Congratulations,

you have spotted something nobody else did in the entire testing period
(including yours truly) ;-): Changing xinetd based services like telnet, talk,
etc. doesn't work [NB: version 0.8.25]. This is likely due to a patch introduced
to be able to change all runlevels at once for a service.

Some things to note though:
- Please open a separate bug for your networking problem, it is unlikely that
the two are related.
- Provide the version of the component against which you report the bug (i.e.
system-config-services, not the kernel in this instance).
- Provide more precise reproduction instructions, I tried what you described on
standalone (not xinetd based) services and that works fine, hadn't I tried it
with telnet as well (after reading a second time through the bug report) I'd
have dismissed this as CLOSED/WORKSFORME.
Comment 2 John William 2005-06-17 16:35:36 EDT
Using ctrl-R to refresh the list (correctly) shows that the changes have not 
been saved and is a lot faster than restarting the service control manager.
Comment 3 Nils Philippsen 2006-04-07 06:53:43 EDT
FC5 contains a heavily (hopefully ;-) improved version of
system-config-services, which was revamped at many places, some concerning the
area of your problem. Can you try whether your problem persists on FC5? Thanks!
Comment 4 Nils Philippsen 2006-06-07 08:53:40 EDT
Ping?
Comment 6 Matthew Miller 2007-04-06 11:07:34 EDT
Fedora Core 3 and Fedora Core 4 are no longer supported. If you could retest
this issue on a current release or on the latest development / test version, we
would appreciate that. Otherwise, this bug will be marked as CANTFIX one month
from now. Thanks for your help and for your patience.
Comment 7 petrosyan 2008-02-16 11:06:24 EST
Fedora Core 4 is no longer maintained.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.

Note You need to log in before you can comment on or make changes to this bug.