This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 159562 - xterm fails to start properly - ioctl() failed on TIOCSETP
xterm fails to start properly - ioctl() failed on TIOCSETP
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
4
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On: 101472
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-04 05:22 EDT by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 20:54:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-06-04 05:22:32 EDT
+++ This bug was initially created as a clone of Bug #101472 +++

Please fill in each of the sections below.

Hardware Environment: iSeries 64bit

Software Environment: RHEL 3 Beta 1


Steps to Reproduce:
1. Attempt to start an xterm on a RHEL 3 Beta 1 system.

Actual Results:
The following error is reported:

[root@rchlp530 mnt]# xterm
xterm: Error 23, errno 22: Invalid argument
Reason: spawn: ioctl() failed on TIOCSETP
[root@rchlp530 mnt]# 

Expected Results:
I expected xterm to start.

Additional Information:
I have recreated this same result when trying to export the display, with the
display forwarded over an ssh connection and within a VNC session running on the
partition.
Comment 1 David Woodhouse 2005-06-04 05:24:40 EDT
The original bug was fixed long ago but the patch was recently removed from
Fedora's xterm package -- with a comment about testing to see whether it was
still necessary, but evidently without any such testing.
Comment 2 Mike A. Harris 2005-06-17 13:36:50 EDT
(In reply to comment #1)
> The original bug was fixed long ago but the patch was recently removed from
> Fedora's xterm package -- with a comment about testing to see whether it was
> still necessary, but evidently without any such testing.

You misunderstood the comment.  I removed the patch because it no longer
applied, and it wasn't clear if it was still necessary or not.  The
"testing" was not manual testing by myself, but testing by the community.
Nobody reported a problem until now, so the "testing" so far done by
the community did not yield results showing that it was still a problem
for PPC users.

This underscores the importance of end users testing things earlier, and
then reporting any bugs found directly to the upstream maintainers and
projects, so that fixes get incorporated directly into the official
sources, and do not need to be custom ported forward to each new
software release.

Comment 3 Mike A. Harris 2005-06-17 13:40:05 EDT
Once a patch that fixes this problem has been incorporated into upstream
xterm, and the new xterm released, we will add the patch to a future FC4
xterm update after it's had testing in rawhide for a while.

Thanks in advance.
Comment 4 Thomas E. Dickey 2005-07-07 14:37:28 EDT
see http://invisible-island.net/xterm/xterm.log.html#xterm_201
ignore error in the I/O initialization that tries to set the tty to 7-bit input 
for the case where eightBitInput resource is false (Debian #298551).
Comment 5 Jason Vas Dias 2005-10-12 20:54:53 EDT
According to upstream maintainer, this bug is fixed by this code in main.c,
@line 3624:
	/* ignore errors here - some platforms don't work */
		tio.c_cflag &= ~CSIZE;
		if (screen->input_eight_bits)
		    tio.c_cflag |= CS8;
		else
		    tio.c_cflag |= CS7;
		(void) ttySetAttr(ttyfd, &tio);

Which is in xterm-205 submitted to rawhide-20051013. I cannot reproduce this
bug with this version. After a week or so of testing in rawhide, I'll submit
xterm-205 to FC-4 .

Comment 6 Fedora Update System 2005-11-07 14:32:53 EST
From User-Agent: XML-RPC

xterm-205-1.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 7 Fedora Update System 2005-11-14 13:03:44 EST
From User-Agent: XML-RPC

xterm-205-1.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.