Bug 1595994 - Since the introduction of kernel 4.17.2, team network interface has stopped working.
Summary: Since the introduction of kernel 4.17.2, team network interface has stopped w...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-28 01:54 UTC by Dmitry Burstein
Modified: 2018-10-18 13:56 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-18 13:56:41 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dmitry Burstein 2018-06-28 01:54:05 UTC
Description of problem:
I have a 'team0' interface comprised of two on-board NICs. When booting into 4.17.2, the machine has no network connection. When booting back into 4.16.16 or earlier - there is absolutely no problem with it.
Trying to bring it up in 4.17.2 with 'nmcli' command succeeds only partially, as the network remains very slow and virtually unusable. Bringing up the individual NICs - not as parts of the team0 - gets the regular network performance back.

Version-Release number of selected component (if applicable):
kernel-4.17.2-200

How reproducible:
Every time I'm trying to boot into this kernel version.

Steps to Reproduce:
1. Choose kernel-4.17.2-200 as a boot option.
2. Wait for the machine to boot up.
3. Run 'nmcli c s' to see the network is down.

Actual results:
The network is down.

Expected results:
Working networking.

Additional info:
Unfortunately I have no idea how to make any future diagnostics, but I'm willing to perform it if instructed.

Comment 1 Dmitry Burstein 2018-07-01 14:10:59 UTC
The same behavior observed also in 4.17.3.

Comment 2 Dmitry Burstein 2018-07-12 08:28:17 UTC
The same behavior observed also in 4.17.4.

Comment 3 Dmitry Burstein 2018-07-18 12:56:38 UTC
The same behavior observed also in 4.17.5.

Comment 4 Keith Distin 2018-07-20 12:52:33 UTC
This is still broken for me on 4.17.6

Comment 5 Laura Abbott 2018-10-01 21:14:20 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.
 
Fedora 28 has now been rebased to 4.18.10-300.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 29, and are still experiencing this issue, please change the version to Fedora 29.
 
If you experience different issues, please open a new bug report for those.

Comment 6 Dmitry Burstein 2018-10-17 14:38:34 UTC
I'm currently on 4.18.13, and the issue seems to be resolved completely. The team interface works as it did before the 4.17.

Comment 7 Jeremy Cline 2018-10-18 13:56:41 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.