Bug 159609 - lm_sensors doesn't work properly
lm_sensors doesn't work properly
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 160491 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-05 17:19 EDT by Laurent Wandrebeck
Modified: 2015-01-04 17:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 16:51:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurent Wandrebeck 2005-06-05 17:19:55 EDT
Description of problem:
lm_sensors used to detect properly my chips up to 2.6.11-1.1290. Every kernel
update brings:
"Starting lm_sensors: No sensors found!"
Chips are:
MODULE_0=i2c-isa
MODULE_1=w83627hf
Either selinux enabled or not, same behaviour.
box is a64 2800+,s754, running on a asrock k8s8x.
Bios is 1.9, lastest revision (2.0) just updates cpu ids, nothing related to
sensors.

Version-Release number of selected component (if applicable):
every kernel newer than kernel 2.6.11-1.1290.

How reproducible:
Just boots with a kernel newer than 2.6.11-1.1290.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
sensors aren't detected.

Expected results:
should be detected and work fine as in 1290 and previous versions.

Additional info:
Comment 1 Phil Knirsch 2005-06-06 06:46:27 EDT
That sounds more like a kernel bug to me as there might be missing a i2c module.

Reassigning.

Read ya, Phil
Comment 2 Laurent Wandrebeck 2005-06-06 13:24:55 EDT
here is the list of i2c related modules loaded:
w83627hf               38633  0
i2c_sensor              4033  1 w83627hf
i2c_isa                 3009  0
i2c_dev                14657  0
i2c_core               27329  4 w83627hf,i2c_sensor,i2c_isa,i2c_dev
Hope that helps.
Comment 3 Dave Jones 2005-06-06 19:57:37 EDT
Can you try something a more recent kernel ? 1290 is quite old..
Comment 4 Laurent Wandrebeck 2005-06-07 02:35:57 EDT
I must not have been clear enough. i've tested every version from the one in
fc4t2 to now (1366). lm_sensors used to run ok up to 1290, and fail in every
release after that one.
Comment 5 Laurent Wandrebeck 2005-06-07 18:04:51 EDT
just a little update: tried with 1369, same behaviour.
Comment 6 Rik Burt 2005-06-23 14:11:27 EDT
Using Tyan S2881 motherboard I get the same thing.

alias char-major-89 i2c-dev is in modprobe.conf

Have i2c-amd8111, i2c-amd756, i2c-isa, lm85, w83627hf in /etc/sysconfig/lm_sensors.

The /etc/sensors.conf is from www.tyan.com.

This exact setup works fine in FC3.  But in FC4 I get "No sensors found"

I have also tried with updated lm_sensors (2.9.1) from atrpms.

All the modules seem to exist but i2c-amd756.
Comment 7 Rik Burt 2005-06-23 15:20:22 EDT
Building and installing the i2c-amd756 fixed my problem.
Comment 8 Michal Jaegermann 2005-06-24 13:30:27 EDT
i2c-amd756 is still missing from released FC4 kernels, which makes lm_sensors
to fail on boards which worked fine with FC3, and also from the current
(i.e. 2.6.12-1.1395_FC5) rawhide kernels.  A support for that chip is
explicitely configured out in config files.  Any deep reason for that or
just a slip of a finger in config cleanups?  Adding this module back makes
things work again but forces board owners to mess with modules after every kernel
release.
Comment 9 Michal Jaegermann 2005-06-24 13:44:09 EDT
BTW - just released kernel-2.6.11-1.35_FC3 update sports

/lib/modules/2.6.11-1.35_FC3/kernel/drivers/i2c/busses/i2c-amd756-s4882.ko
/lib/modules/2.6.11-1.35_FC3/kernel/drivers/i2c/busses/i2c-amd756.ko

so it does not seem to be any issue there. 

In general there is 20 kernel modules in i2c/busses in that directory but
only 11 in a corresponding one for 2.6.12-1.1395_FC5.  This should make
lm_sensors to fail in many situations they just worked before.
Comment 10 Dave Jones 2005-06-24 21:55:33 EDT
i2c-amd756 is present in the i686 kernels, but not in the x86-64 kernels.
The reason behind this is that this is a K7 chipset.  What K8 motherboard is
using this ? (lspci output would be useful to see too).

Comment 11 Dave Jones 2005-06-24 22:22:21 EDT
*** Bug 160491 has been marked as a duplicate of this bug. ***
Comment 12 Frank Heldt 2005-06-27 11:04:52 EDT
This is on a Rioworks HDAMA (AMD 8111-Chipset) Dual-Opteron Board.

# lspci
00:06.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8111 PCI (rev 07)
00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-8111 LPC (rev 05)
00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-8111 IDE (rev 03)
00:07.2 SMBus: Advanced Micro Devices [AMD] AMD-8111 SMBus 2.0 (rev 02)
00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-8111 ACPI (rev 05)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8131 PCI-X Bridge (rev 12)
00:0a.1 PIC: Advanced Micro Devices [AMD] AMD-8131 PCI-X IOAPIC (rev 01)
00:0b.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8131 PCI-X Bridge (rev 12)
00:0b.1 PIC: Advanced Micro Devices [AMD] AMD-8131 PCI-X IOAPIC (rev 01)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM 
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Miscellaneous Control
00:19.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
HyperTransport Technology Configuration
00:19.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Address Map
00:19.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM 
Controller
00:19.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Miscellaneous Control
01:00.0 USB Controller: Advanced Micro Devices [AMD] AMD-8111 USB (rev 0b)
01:00.1 USB Controller: Advanced Micro Devices [AMD] AMD-8111 USB (rev 0b)
01:06.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
02:02.0 RAID bus controller: 3ware Inc 3ware Inc 3ware 7xxx/8xxx-series 
PATA/SATA-RAID (rev 01)
02:03.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5702X Gigabit 
Ethernet (rev 02)
02:04.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5702X Gigabit 
Ethernet (rev 02)
Comment 13 Rik Burt 2005-06-27 11:34:09 EDT
The boards I know that require this are the Tyan S2881, S2882, and the Tyan
S4882 requires a special i2c-amd756.

lscpi from an S2881G2NR:

 0:06.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8111 PCI (rev 07)
00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-8111 LPC (rev 05)
00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-8111 IDE (rev 03)
00:07.2 SMBus: Advanced Micro Devices [AMD] AMD-8111 SMBus 2.0 (rev 02)
00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-8111 ACPI (rev 05)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8131 PCI-X Bridge (rev 12)
00:0a.1 PIC: Advanced Micro Devices [AMD] AMD-8131 PCI-X APIC (rev 01)
00:0b.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8131 PCI-X Bridge (rev 12)
00:0b.1 PIC: Advanced Micro Devices [AMD] AMD-8131 PCI-X APIC (rev 01)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] AddressMap
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
00:19.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:19.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] AddressMap
00:19.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:19.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
02:09.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5704 Gigabit
Ethernet (rev 03)
02:09.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5704 Gigabit
Ethernet (rev 03)
03:00.0 USB Controller: Advanced Micro Devices [AMD] AMD-8111 USB (rev 0b)
03:00.1 USB Controller: Advanced Micro Devices [AMD] AMD-8111 USB (rev 0b)
03:05.0 Unknown mass storage controller: Silicon Image, Inc. (formerly CMD
Technology Inc) SiI 3114 [SATALink/SATARaid] Serial ATA Controller (rev 02)
03:06.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)

Here is the output of sensors:
Adapter: ISA adapter
CPU0 Volt: +1.54 V  (min =  +0.00 V, max =  +0.00 V)
CPU1 Volt: +1.54 V  (min =  +0.00 V, max =  +0.00 V)
3.3V:      +3.36 V  (min =  +3.14 V, max =  +3.47 V)
DDR VREF:  +1.31 V  (min =  +1.23 V, max =  +1.36 V)
DDR VCORE: +2.62 V  (min =  +2.38 V, max =  +2.93 V)
HT CORE:   +1.31 V  (min =  +1.14 V, max =  +1.26 V)
CPU0 Fan: 9782 RPM  (min = 2657 RPM, div = 2)
CPU1 Fan: 10074 RPM  (min = 2657 RPM, div = 2)
Fan8:        0 RPM  (min = 2657 RPM, div = 2)
ERROR: Can't get VID data!
alarms:   Chassis intrusion detection                      ALARM
beep_enable:
          Sound alarm disabled

adm1027-i2c-1-2d
Adapter: SMBus AMD756 adapter at 50e0
ERROR: Can't get alarm mask data!
in0:       +2.617 V  (min =  +0.00 V, max =  +3.32 V)
in1:       +1.313 V  (min =  +0.00 V, max =  +2.99 V)
in2:       +3.334 V  (min =  +0.00 V, max =  +4.38 V)
in3:      +5.104 V  (min =  +0.00 V, max =  +6.64 V)
in4:      +12.125 V  (min =  +0.00 V, max = +15.94 V)
fan1:     14634 RPM  (min =    0 RPM)
fan2:     14958 RPM  (min =    0 RPM)
fan3:         0 RPM  (min =    0 RPM)
fan4:         0 RPM  (min =    0 RPM)
temp1:    +44.00°C  (low  =  -127°C, high =  +127°C)
temp2:    +38.00°C  (low  =  -127°C, high =  +127°C)
temp3:    +41.00°C  (low  =  -127°C, high =  +127°C)
pwm1:      255
pwm2:      255
pwm3:      255

Comment 14 Rik Burt 2005-06-27 13:28:21 EDT
I should have listed the modules that are loading for this board.  The
sensors.conf file was downloaded from Tyan's website.  They have a handy section
with various sensors.conf files for all kinds of boards.

The modules listed in the sensors.conf file are:

i2c-amd8111
i2c-amd756
i2c-isa
lm85
w83627hf

eeprom can also be included if you need information for installed memory.

Output from lsmod

i2c_sensor             5057 2 w83627hf,lm85
i2c_isa                3649 0
i2c_amd756             7493 0
i2c_amd8111            7745 0
i2c_dev               13633 0
i2c_core              28481 7
w83627hf,lm85,i2c_sensor,i2c_isa,i2c_amd756,i2c_amd8111,i2c_dev
Comment 15 Dave Jones 2005-06-27 13:55:17 EDT
Added back for the next update. It seems this module is for K8 too.
Thanks for the reports.
Comment 16 Michal Jaegermann 2005-06-27 14:22:25 EDT
'i2c-amd756-s4882' was created by Jean Delvare specifically to support
Tyan S4882 8-way Opteron boards (and maybe some other ones too).  So please
do not forget about it as well.  Thanks!
Comment 17 Dave Jones 2005-06-27 15:42:41 EDT
yep, added that back too.
Comment 18 Dave Jones 2005-06-27 19:15:14 EDT
Mass update for bugs reported against -test:
Updating version field to FC4 final. Please retest with final FC4 release if you
have not already done so. Thanks.
Comment 19 Dave Jones 2005-06-27 19:31:16 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 20 Rik Burt 2005-06-28 17:20:06 EDT
The 2.6.12-1.1385_FC4smp kernel in testing fixes my lm_sensors problem.  It has
been tested on a fresh install updated with this kernel.

Thanks
Comment 21 Laurent Wandrebeck 2005-07-03 05:16:25 EDT
1385 still fails here:
lsmod:
w83627hf               38633  0
i2c_sensor              4033  1 w83627hf
i2c_isa                 3009  0
i2c_dev                14657  0
i2c_core               27329  4 w83627hf,i2c_sensor,i2c_isa,i2c_dev
I still get: "Starting lm_sensors: No sensors found!"
Thx for working on it.
Comment 22 Laurent Wandrebeck 2005-07-03 05:26:38 EDT
don't know why the bug changed from needinfo to assigned...
Comment 23 Dave Jones 2005-09-30 02:39:51 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 24 Dave Jones 2005-11-10 14:42:36 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 25 Laurent Wandrebeck 2005-11-10 16:29:50 EST
I'm afraid I can't help more, as I don't run FC anymore.
Kind regards.

Note You need to log in before you can comment on or make changes to this bug.