Bug 159628 - sm join/leave bug
sm join/leave bug
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Teigland
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-06 05:26 EDT by David Teigland
Modified: 2009-04-16 16:30 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2005-734
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 12:46:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2005-06-06 05:26:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
There's some bug in SM processing of joins/leaves.
A node will send out a request to join or leave a
group and it appears that the replies it gets are
being considered invalid and thus discarded for
some reason.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. we've been running a looping clvmd stop/start script, often for days before
the problem appears
2.
3.
  

Additional info:
Comment 1 David Teigland 2005-06-08 11:52:32 EDT
This is a bug with SM's internal event id's.  The event id is
a uint32, but this is cast to a uint16 when it's passed between
machines in an SM message.  When the id gets past 65535, the
event id in the messages no longer matches the id used within
SM, so things stall.

When SM stalls, all the nodes need to be reset.

This bug takes a while to see because you need to reach 65535
SM events in your cluster.  Everyone will eventually hit
it, though, given enough events in a long running cluster.
(starting/stopping clvmd, mounting/unmounting gfs,
joining/leaving the fence domain are all SM events)

There is a simple fix for this that changes the event id's
in messages to uint32's.  I'll check this in after some
basic tests.
Comment 2 Red Hat Bugzilla 2005-10-07 12:46:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-734.html

Note You need to log in before you can comment on or make changes to this bug.