Bug 159631 - libgs.so.7 is needed by package ImageMagick
libgs.so.7 is needed by package ImageMagick
Status: CLOSED DUPLICATE of bug 159598
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-06 08:30 EDT by Robert Williams
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-06 08:39:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Williams 2005-06-06 08:30:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The new version of ghostscript contains a libgs.so
that replaces the .7 version required by ImageMagic.
So, updates with yum -y update are blocked.

Version-Release number of selected component (if applicable):
ghostscript.i386 0:8.15-0.rc3.1 set to be updated

How reproducible:
Always

Steps to Reproduce:
1.run "yum -y update"
2.
3.
  

Actual Results:  Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package python-urlgrabber.noarch 0:2.9.6-2 set to be updated
---> Package ghostscript.i386 0:8.15-0.rc3.1 set to be updated
---> Package gamin.i386 0:0.1.0-1.1 set to be updated
---> Package metacity.i386 0:2.10.0-2.fc5 set to be updated
---> Package gamin-devel.i386 0:0.1.0-1.1 set to be updated
---> Package at.i386 0:3.1.8-78 set to be updated
--> Running transaction check
--> Processing Dependency: libgs.so.7 for package: ImageMagick
--> Finished Dependency Resolution
Error: Missing Dependency: libgs.so.7 is needed by package ImageMagick


Expected Results:  yum -y update should resolve dependencies and install
these packages.

Additional info:

The workaround is to 
yum -y --exclude=ghostscript update
Comment 1 Tim Waugh 2005-06-06 08:39:03 EDT

*** This bug has been marked as a duplicate of 159598 ***

Note You need to log in before you can comment on or make changes to this bug.