Bug 159656 - Client crashes on any command
Client crashes on any command
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: subversion (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-06 12:51 EDT by Liam Bryan
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-06 17:17:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Liam Bryan 2005-06-06 12:51:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/312.1 (KHTML, like Gecko) Safari/312

Description of problem:
After running:
sudo apt-get install subversion

The program is installed.  The svnadmin program works correctly.  However, any command passed to 
the svn client produces the following error:

:~/ svn checkout
svn: relocation error: /usr/lib/libneon.so.24: undefined symbol: GSS_C_NT_HOSTBASED_SERVICE

Version-Release number of selected component (if applicable):
subversion-0.32.1-1.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. sudo apt-get install subversion
2. svn checkout
  

Actual Results:  svn: relocation error: /usr/lib/libneon.so.24: undefined symbol: GSS_C_NT_HOSTBASED_SERVICE

Expected Results:  checkout (co): Check out a working copy from a repository.
usage: checkout URL... [PATH]

  Note: If PATH is omitted, the basename of the URL will be used as
  the destination. If multiple URLs are given each will be checked
  out into a sub-directory of PATH, with the name of the sub-directory
  being the basename of the URL.

Valid options:
  -r [--revision] arg      : ARG (some commands also take ARG1:ARG2 range)
                             A revision argument can be one of:
                                NUMBER       revision number
                                "{" DATE "}" revision at start of the date
                                "HEAD"       latest in repository
                                "BASE"       base rev of item's working copy
                                "COMMITTED"  last commit at or before BASE
                                "PREV"       revision just before COMMITTED
  -q [--quiet]             : print as little as possible
  -N [--non-recursive]     : operate on single directory only
  --username arg           : specify a username ARG
  --password arg           : specify a password ARG
  --no-auth-cache          : do not cache authentication tokens
  --non-interactive        : do no interactive prompting
  --config-dir arg         : read user configuration files from directory ARG


Additional info:

Have tried reinstalling libneon as well, but it was to no avail.  Building the subversion client from source 
works correctly when passed ./configure --with-ssl, but this means that the build is using its own 
internal sources for neon.
Comment 1 Suzanne Hillman 2005-06-06 16:04:33 EDT
Have you tried installing when logged in directly as root? I don't know if sudo
might have anything to do with the problem, but it's worth checking.
Comment 2 Joe Orton 2005-06-06 17:17:07 EDT
Red Hat Enterprise Linux 3 does not include a subversion package.  I'd suggest
you try a more recent third-party package, for example,
http://dag.wieers.com/packages/subversion/, or upgrade to Red Hat Enterprise
Linux 4, which does include a subversion package.
Comment 3 Liam Bryan 2005-06-07 07:32:29 EDT
(In reply to comment #2)
> Red Hat Enterprise Linux 3 does not include a subversion package.  I'd suggest
> you try a more recent third-party package, for example,
> http://dag.wieers.com/packages/subversion/, or upgrade to Red Hat Enterprise
> Linux 4, which does include a subversion package.

I'm confused.  If Red Hat Enterprise Linux 3 does not have a subversion package, why does it install?  
Further, why would the svnadmin program work, but the svn program fail?
Comment 4 Joe Orton 2005-06-07 08:10:13 EDT
It will install if you have some third-party APT repository in your apt
configuration.  (Note that RHEL3 does not include apt!).  Please contact Red Hat
support if you're having trouble working out which packages are included in RHEL
and which aren't.

(The package you have doesn't work because it was built against MIT libraries
which are newer than those included in RHEL3, FYI)
Comment 5 Liam Bryan 2005-06-07 09:29:58 EDT
(In reply to comment #4)
> It will install if you have some third-party APT repository in your apt
> configuration.  (Note that RHEL3 does not include apt!).  Please contact Red Hat
> support if you're having trouble working out which packages are included in RHEL
> and which aren't.
> 
> (The package you have doesn't work because it was built against MIT libraries
> which are newer than those included in RHEL3, FYI)

Hm.  But apt-cache show subversion shows the following:

Package: subversion
Section: Development/Tools
Installed Size: 3069
Maintainer: Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Version: 0.32.1-5
Architecture: i386
Size: 1074040
MD5Sum: 3e65c8863d12a8290465c34c9cff8c86
Filename: subversion-0.32.1-5.i386.rpm

Package: subversion
Section: Development/Tools
Installed Size: 3068
Maintainer: Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Version: 0.32.1-1
Architecture: i386
Size: 1073582
MD5Sum: dbbfc48903a573554ccb820dccadbf9a
Filename: subversion-0.32.1-1.i386.rpm


Which indicates that Red Hat is the package maintainer for this package.  If Red Hat is not the 
maintainer for this package, then who is?
Comment 6 Joe Orton 2005-06-07 09:36:28 EDT
Oh, this is a package from Fedora Core, then.  All comments above still apply: 
this package will not work on RHEL3; subversion is not included or supported in
RHEL3.  You can either upgrade to RHEL4 or obtain a third-party subversion
package which was built for RHEL3 to get this working.

Note You need to log in before you can comment on or make changes to this bug.