Bug 159661 - 500 error while browsing system list
500 error while browsing system list
Status: CLOSED WONTFIX
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn400
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
https://rhn.redhat.com/network/system...
:
Depends On:
Blocks: 147875
  Show dependency treegraph
 
Reported: 2005-06-06 14:22 EDT by Mike McCune
Modified: 2007-04-18 13:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-17 13:21:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for the issue, for sust-eng uses (662 bytes, patch)
2005-06-17 13:21 EDT, Bret McMillan
no flags Details | Diff

  None (edit)
Description Mike McCune 2005-06-06 14:22:17 EDT
Saw this in the stack of tracebacks.

-------- Original Message --------
Subject: rhn-traceback Digest from 2005-06-02 14:42
Date: Thu, 2 Jun 2005 14:42:00 -0400
From: rhn-traceback <rhn-traceback@redhat.com>
To: rhn-traceback Digest Recipients <rhn-traceback@redhat.com>


Contents of this Digest Volume 2005-06-02 14:42

 WEB TRACEBACK from rhnserver1.app.phx.redhat.com (Thu Jun  2 14:41:42 2005)


Return-Path: <dev-null@rhn.redhat.com>
Received: from mx1.util.phx.redhat.com (mx1.util.phx.redhat.com [10.8.4.92])
    by alertmail.util.phx.redhat.com (8.11.6/8.11.6) with ESMTP id j52IfhM09745
    for <rhn-traceback@rhn.redhat.com>; Thu, 2 Jun 2005 14:41:43 -0400
Received: from rhnserver1.app.phx.redhat.com (nat-pool.util.phx.redhat.com
[10.8.5.200])
    by mx1.util.phx.redhat.com (8.11.6/8.11.6) with ESMTP id j52Ifhk05202
    for <rhn-traceback@rhn.redhat.com>; Thu, 2 Jun 2005 14:41:43 -0400
Received: (from apache@localhost)
    by rhnserver1.app.phx.redhat.com (8.11.6/8.11.6) id j52Ifgg32193;
    Thu, 2 Jun 2005 14:41:42 -0400
Date: Thu, 2 Jun 2005 14:41:42 -0400
Message-Id: <200506021841.j52Ifgg32193@rhnserver1.app.phx.redhat.com>
To: rhn-traceback@rhn.redhat.com
From: Red Hat Network <dev-null@rhn.redhat.com>
Subject: WEB TRACEBACK from rhnserver1.app.phx.redhat.com (Thu Jun  2 14:41:42 2005)
Content-Type: text/plain; charset=US-ASCII
Errors-To: Red Hat Network <dev-null@rhn.redhat.com>
X-RHN-Email: rhn-traceback@rhn.redhat.com
X-RHN-Traceback-Severity: unhandled
Reply-to: rhn-traceback@redhat.com

The following exception occured while executing this request:
 GET
/network/systems/index.pxt?lower=1&filter_string=B000502&alphabar_column=NAME&upper=50
HTTP/1.1 (from browser)
 /network/systems/index.pxt (from Apache)

Date:
  Thu Jun  2 14:41:42 2005

Headers:
  Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Accept-Encoding: gzip,deflate
  Accept-Language: en-us,en;q=0.5
  Connection: close
  Cookie: rh_auth_token=3734691:1117737701xff075e6eb1866832ce3f653e009e431a;
pxt-session-cookie=1650106955x8e117ff593e4b7fd952fc84273ee0871
  Host: rhnapp.vip.phx.redhat.com
  Referer:
https://rhn.redhat.com/network/systems/index.pxt?lower=1&filter_string=b000502&alphabar_column=NAME&upper=50
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512
Red Hat/1.7.8-1.4.1
  Via: 1.1 rhn.redhat.com
  X-ENV-HTTPS: on
  X-Forwarded-For: 38.113.135.196
  X-Host: rhn.redhat.com
  X-Proxy-Forwarded-For: 38.113.135.196
  X-Proxy-Forwarded-Host: rhn.redhat.com
  X-Proxy-Forwarded-Server: rhn.redhat.com
  X-Replace-Content-Active: 1
  X-Server-Hostname: rhn.redhat.com

Form variables:
  alphabar_column => NAME
  filter_string => B000502
  lower => 1
  upper => 50

User Information:
  User ahcusep (id 3734691, org_id 4280623)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  RHN::Exception: No 'sort_by' column for mode 'visible_to_user'

  Sniglets::ListView::List
/usr/lib/perl5/site_perl/5.6.1/i386-linux/Sniglets/ListView/List.pm 510
RHN::Exception::throw
  Sniglets::ListView::List
/usr/lib/perl5/site_perl/5.6.1/i386-linux/Sniglets/ListView/List.pm 908
Sniglets::ListView::List::render_filterbox
  Sniglets::Lists /usr/lib/perl5/site_perl/5.6.1/i386-linux/Sniglets/Lists.pm
117 Sniglets::ListView::List::render
  PXT::Parser /usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/Parser.pm 160
Sniglets::Lists::listview
  PXT::Parser /usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/Parser.pm 72
PXT::Parser::expand_tag
  PXT::ApacheHandler
/usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/ApacheHandler.pm 618
PXT::Parser::expand_tags
  PXT::Request /usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/Request.pm 710
PXT::ApacheHandler::pxt_parse_data
  Sniglets::Users /usr/lib/perl5/site_perl/5.6.1/i386-linux/Sniglets/Users.pm
1960 PXT::Request::include
  PXT::Parser /usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/Parser.pm 141
Sniglets::Users::if_pref
  PXT::Parser /usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/Parser.pm 72
PXT::Parser::expand_tag
  PXT::ApacheHandler
/usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/ApacheHandler.pm 618
PXT::Parser::expand_tags
  PXT::ApacheHandler
/usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/ApacheHandler.pm 110
PXT::ApacheHandler::pxt_parse_data
  PXT::ApacheHandler
/usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/ApacheHandler.pm 110 (eval)
  main /dev/null 0 PXT::ApacheHandler::handler
  main /dev/null 0 (eval)


_______________________________________________
rhn-webdev-list mailing list
rhn-webdev-list@redhat.com
http://post-office.corp.redhat.com/mailman/listinfo/rhn-webdev-list
Comment 1 Mike McCune 2005-06-06 14:53:36 EDT
Haven't reproduced this, just saw the traceback and reported the bug.
Comment 2 Bret McMillan 2005-06-17 13:21:18 EDT
Created attachment 115623 [details]
fix for the issue, for sust-eng uses

This patch should fix it, but since kgnaong's code deprecates any fix for 400,
closing this bug.

Note You need to log in before you can comment on or make changes to this bug.