Bug 15969 - install freezes when loading AIC7xxx driver during CD installation
install freezes when loading AIC7xxx driver during CD installation
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Brock Organ
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-10 21:05 EDT by John Cagle
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-20 16:33:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Cagle 2000-08-10 21:05:40 EDT
Compaq ProLiant ML330
Wide Ultra 2 SCSI PCI Card as "First" controller (boot controller) with external storage attached.
Embedded SCSI as "Second" controller with a single SCSI drive attached.

Boot from RC1 CD#1, press enter.

Installation locks up on screen that says "Loading AIC7xxx..."
Comment 1 John Cagle 2000-08-10 21:14:16 EDT
Add-in card is the "64-Bit/66MHz, Dual Channel, Wide Ultra2 SCSI Controller"
using the Symbios Logic 53C879 (Dual Channel) chipset.
Part Number 348757-B21
Comment 2 Glen Foster 2000-08-13 15:46:07 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 3 Michael Fulbright 2000-08-15 11:09:05 EDT
Brock do we have one of these to reproduce this problem with?
Comment 4 Preston Brown 2000-08-15 11:56:26 EDT
it is not actually loading that driver, of course...
Comment 5 Brock Organ 2000-08-15 12:12:27 EDT
hmmm... I could not reproduce this behavior in our proliant ml330 (lspci output
below)...

% lspci
00:00.0 Host bridge: ServerWorks CNB20HE (rev 05)
00:00.1 Host bridge: ServerWorks CNB20HE (rev 05)
00:01.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
00:0f.0 ISA bridge: ServerWorks OSB4 (rev 4f)
00:0f.1 IDE interface: ServerWorks: Unknown device 0211
01:04.0 SCSI storage controller: Symbios Logic Inc. (formerly NCR) 53c895a (rev
01)
01:05.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 08)
01:06.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
01:07.0 System peripheral: Compaq Computer Corporation Advanced System
Management Controller

% lspci -n
00:00.0 Class 0600: 1166:0009 (rev 05)
00:00.1 Class 0600: 1166:0009 (rev 05)
00:01.0 Class 0604: 1011:0024 (rev 03)
00:0f.0 Class 0601: 1166:0200 (rev 4f)
00:0f.1 Class 0101: 1166:0211
01:04.0 Class 0100: 1000:0012 (rev 01)
01:05.0 Class 0200: 8086:1229 (rev 08)
01:06.0 Class 0300: 1002:4752 (rev 27)
01:07.0 Class 0880: 0e11:a0f0

Comment 6 Brent Fox 2000-08-15 16:41:19 EDT
So there is only the one scsi card in this box ...?
Comment 7 John Cagle 2000-08-16 02:08:54 EDT
To reproduce, add the "64-Bit/66MHz, Dual Channel, Wide Ultra2 SCSI Controller"
to the ML330 and make it the "First" controller.  The standard SCSI control
should
be made "Second".

Then you'll see the lockup when loading "AIC7xxx"...
Comment 8 John Cagle 2000-08-17 12:14:57 EDT
MAJOR APOLOGY -- I was describing the wrong adapter.  Here's the
one that has the problem:

64-Bit, 66MHz, PCI, Dual Channel
Wide Ultra3 SCSI Adapter
Chipset: Adaptec AIC-7899G

We're shipping one of these to Aaron Brown today.  Also, you may
have to use Wide Ultra 3 *drives* as well to reproduce this bug.
Comment 9 Aaron Brown 2000-08-20 16:33:11 EDT
I installed the Wide Ultra-3 SCSI adapter that John sent us, and was unable
to duplicate this bug.  

I performed minimum, full, workstation, and server installs.

I ran 2 of the installs with the SCSI-3 drive connected to the internal SCSI
connection, and 2 of the installs attached to the external SCSI connection.

Here is the lspci info:
00:00.0 Host bridge: ServerWorks CNB20HE (rev 05)
00:00.1 Host bridge: ServerWorks CNB20HE (rev 05)
00:01.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
00:0f.0 ISA bridge: ServerWorks OSB4 (rev 4f)
00:0f.1 IDE interface: ServerWorks: Unknown device 0211
01:04.0 SCSI storage controller: Symbios Logic Inc. (formerly NCR) 53c895a (rev
01)
01:05.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 08)
01:06.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
01:07.0 System peripheral: Compaq Computer Corporation Advanced System
Management Controller
05:02.0 SCSI storage controller: Adaptec 7892A (rev 02)
00:00.0 Class 0600: 1166:0009 (rev 05)
00:00.1 Class 0600: 1166:0009 (rev 05)
00:01.0 Class 0604: 1011:0024 (rev 03)
00:0f.0 Class 0601: 1166:0200 (rev 4f)
00:0f.1 Class 0101: 1166:0211
01:04.0 Class 0100: 1000:0012 (rev 01)
01:05.0 Class 0200: 8086:1229 (rev 08)
01:06.0 Class 0300: 1002:4752 (rev 27)
01:07.0 Class 0880: 0e11:a0f0
05:02.0 Class 0100: 9005:0080 (rev 02)

Note You need to log in before you can comment on or make changes to this bug.