Bug 159696 - kernel rebuild revision naming
Summary: kernel rebuild revision naming
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-07 04:59 UTC by Curtis Doty
Modified: 2016-03-27 14:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-30 01:48:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Curtis Doty 2005-06-07 04:59:14 UTC
Please consider the following patch or something similar that will provide
better granularity for those of us rebuild srpms on various systems who do not
have access to the beehive cluster.

--- kernel-2.6.spec     2005-05-17 16:50:40.000000000 -0700
+++ kernel-2.6gk.spec   2005-05-30 18:58:15.000000000 -0700
@@ -21,7 +21,7 @@
%define sublevel 11
%define kversion 2.6.%{sublevel}
%define rpmversion 2.6.%{sublevel}
-%define rhbsys  %([ -r /etc/beehive-root -o -n "%{?__beehive_build}" ] && echo
|| echo .`whoami`)
+%define rhbsys  %([ -r /etc/beehive-root -o -n "%{?__beehive_build}" ] && echo
|| echo .`whoami`@`hostname -s`)
%if %{FC3}
%define release %(R="$Revision: 1.27 $"; RR="${R##: }"; echo ${RR%%?})_FC3%{rhbsys}
%endif

Comment 1 Dave Jones 2005-07-05 20:03:05 UTC
I'm puzzled as to what this buys you, given this is purely a cosmetic thing, and
isn't used by anything.


Comment 2 Curtis Doty 2005-07-06 20:28:23 UTC
The advantage is for typsically overworked sysads who have to occasionally
rebuid a kernel to identify a bug or test a feature not enabled by Red Hat. This
simple change makes it easier to track what one's done after the fact.

For example, I have a cluster of a few dozen mostly identical hosts who are
manifesting a bizarre bug (I think) and I need to test. So I cook up another
kernel on one host, I get the EXACT SAME FILENAME on a different build on a
different host.

(Of course, we Red Hat devotees out here in the real world don't have the luxury
of a fancy schmancy beehive buildsystem.)

So what I propose, would be a more unique naming scheme for user initiated
kernel rebuilds. I.e.

kernel-2.6.11-1.27_FC3.jake@rasputin.src.rpm
kernel-2.6.11-1.27_FC3.bill@rapunzel.src.rpm

Are clearly *different* builds.

Comment 3 Dave Jones 2005-07-15 19:27:48 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 4 Dave Jones 2005-08-26 05:15:48 UTC
committed to cvs in all trees.


Comment 5 vvs 2005-09-14 07:56:26 UTC
And after this change uname -r reports 2.6.12-1.1447_FC4.vvs, while all file and
directory names has vvs@vvs suffix, so modprobe doesn't find modules :-(


Note You need to log in before you can comment on or make changes to this bug.