Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 159913 - SLPMulticast with comma separated values doesn't work
Summary: SLPMulticast with comma separated values doesn't work
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tom Coughlan
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-09 05:14 UTC by Nitin Chandna
Modified: 2008-04-07 05:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-02 06:02:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
This patch fixes the issue. (2.10 KB, patch)
2005-09-05 13:33 UTC, Smitha Narayanaswamy
no flags Details | Diff

Description Nitin Chandna 2005-06-09 05:14:30 UTC
Description of problem:
SLPMulticast with comma separated values doesn't work.
With value "all", it worked fine and got me two targets on two different portals.
With value for Unicast specified twice - one for each portal, it worked fine as
well.
But when I specified SLPMulticast=<IPAddress_1>, <IPAddress_2>, it didnt return
me any targets.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-11.EL
kernel-smp-devel-2.6.9-11.EL

How reproducible:
Always

Steps to Reproduce:
1. Specify the SLPMulticast=10.1.1.88, 10.1.2.88 in the /etc/iscsi.conf file
2. Start the initiator.
3. No targets are discovered, though I have configured one target each with no
accesslist on each of the IP addresses mentioned above.
  
Actual results:
No targets for discovered for SLPMulticast=10.1.1.88, 10.1.2.88

Expected results:
Two Targets on each of the IPaddresses should have got discovered.

Additional info:
(1) Output of iscsi-ls -l
[root@cnitin-linux-6 linux-iscsi]# iscsi-ls -l
*******************************************************************************
SFNet iSCSI Driver Version ...4:0.1.11(12-Jan-2005)
*******************************************************************************

(2) Entries in /etc/iscsi.conf file
[root@cnitin-linux-6 linux-iscsi]# grep -v "#" /etc/iscsi.conf
SLPMulticast=10.1.1.88, 10.1.2.88

(3) Starting the initiator with debug7 option, here are the messages in the console:
[root@cnitin-linux-6 linux-iscsi]# /etc/init.d/iscsi debug7
Starting iSCSI: iscsi iscsid1118293543.787942 >> iscsid[30984]: iSCSI debug level 7
1118293543.787999 >> iscsid[30984]:
InitiatorName=iqn.1987-05.com.cisco:01.8b75286d2855
1118293543.788015 >> iscsid[30984]: InitiatorAlias=cnitin-linux-6
1118293543.788025 >> iscsid[30984]: version 4:0.1.11 variant (12-Jan-2005)
1118293543.788829 >> iscsid[30985]: pid file fd 0
1118293543.788882 >> iscsid[30985]: locked pid file /var/run/iscsid.pid
 fsck/mount1118293543.824027 >> iscsid[30985]: updating config 0xbff20520 from
/etc/iscsi.conf
1118293543.824391 >> iscsid[30985]: config indent 0, line
SLPMulticast=10.1.1.88, 10.1.2.88
1118293543.824455 >> iscsid[30985]: config entry 0x9b2a0b8 SLPMulticast
0x9b2a308 = 10.1.1.88,
1118293543.824498 >> iscsid[30985]: updated config 0xbff20520 from /etc/iscsi.conf
1118293543.824517 >> iscsid[30985]: starting discovery processes
1118293543.824532 >> iscsid[30985]: start discovery checking config entry
0x9b2a0b8, type 2
1118293543.824546 >> iscsid[30985]: adding discovery 0x9b2a0e0, head (nil), tail
(nil)
1118293543.824932 >> iscsid[30988]: started discovery process 0x9b2a0e0 for
entry 0x9b2a0b8
1118293543.825104 >> iscsid[30988]:
InitiatorName=iqn.1987-05.com.cisco:01.8b75286d2855
1118293543.825136 >> iscsid[30988]: multicast predicate list for discovery
process pid = 30988 is (auth-addr=any)(auth-addr=10.1.1.88)(auth-addr=)
1118293543.825152 >> iscsid[30988]: credential predicate list for discovery
process pid = 30988 is (auth-cred=any)
1118293543.825164 >> iscsid[30988]: name predicate list for discovery process
pid = 30988 is (auth-name=any)(auth-name=iqn.1987-05.com.cisco:01.8b75286d2855)
1118293543.825178 >> iscsid[30988]: name predicate list for discovery process
pid = 30988 is (auth-name=any)(auth-name=iqn.1987-05.com.cisco:01.8b75286d2855)
1118293543.825326 >> iscsid[30988]: SLP predicate list for discover process
30988 is
(&(|(auth-addr=any)(auth-addr=10.1.1.88)(auth-addr=))(|(auth-cred=any))(|(auth-name=any)(auth-name=iqn.1987-05.com.cisco:01.8b75286d2855)))
1118293543.826713 >> iscsid[30985]: forked child 30988 for discovery 0x9b2a0e0,
pipe fd 1
1118293543.838299 >> iscsid[30985]: done starting discovery processes
1118293543.838318 >> iscsid[30985]: need 1 poll fds
1118293543.838337 >> iscsid[30985]: poll_info[0] = fd 1 for discovery 0x9b2a0e0
1118293543.838362 >> iscsid[30985]: main daemon polling 1 pipes

(4) For the step 3, here are the messages in /var/log/messages:
Jun  9 10:35:43 cnitin-linux-6 kernel: iscsi-sfnet: 4:0.1.11 (12-Jan-2005) built
for Linux 2.6.9-11.ELsmp
Jun  9 10:35:43 cnitin-linux-6 kernel: iscsi-sfnet: Control device major number 254
Jun  9 10:35:43 cnitin-linux-6 iscsid[30984]: version 4:0.1.11 variant
(12-Jan-2005) 
Jun  9 10:35:43 cnitin-linux-6 iscsid[30988]: name predicate list for discovery
process pid = 30988 is
(auth-name=any)(auth-name=iqn.1987-05.com.cisco:01.8b75286d2855)

Comment 1 Smitha Narayanaswamy 2005-09-05 13:33:42 UTC
Created attachment 118471 [details]
This patch fixes the issue.

Comment 2 Mike Christie 2005-11-02 06:01:27 UTC
RHEL does not support SLP, so I am closing this bug for now.


Note You need to log in before you can comment on or make changes to this bug.