Bug 159927 - black screen when entering graphics mode during installation
black screen when entering graphics mode during installation
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
: 160621 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-09 08:04 EDT by Seppo Voutilainen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 17:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seppo Voutilainen 2005-06-09 08:04:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
Compaq laptop (Evo N1000v) LCD-display turns black when entering graphics mode.
Everything works fine when using external monitor.
Things do not change after installation is completed.

Graphics chip is ATI Radeon Mobility 7500.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Just start X Window
2.
3.
  

Actual Results:  LCD screen of laptop is black or flickering.


Additional info:

Computer is Compaq Evo N1000v laptop.
Graphics chip if ATI Radeon Mobility 7500
Colleagues told that same bug exists with Core 3.

When xorg.conf is modified, best results are flickering screen.

Fedora Core 2 worked (and still works) just fine in same computer!
Comment 1 Jeremy Katz 2005-06-10 11:55:04 EDT
Does booting with 'linux nofb' help?
Comment 2 Seppo Voutilainen 2005-06-16 02:05:37 EDT
Booting with 'linux nofb' do not help.
Results:
- no probleblems as long as text mode was in use
- wide vertical stripes on laptop LCD screen when "Welcome to Fedora Core" 
graphics should be displayed
- when external monitor was connected at this situation, graphics was seen as 
it shoud
Comment 3 Chris Lumens 2005-06-16 11:43:19 EDT
*** Bug 160621 has been marked as a duplicate of this bug. ***
Comment 4 Seppo Voutilainen 2005-06-20 06:42:00 EDT
Boot option was good idea (thanks Jeremy!).

When checking other boot options,
 
    'linux resolution=1400x1050' 

was what I needed.

That 1400x1050 is 'native resolution' (maximum resolution) of our Compaq Evo 
N1000v laptop LCD-display.
When that option was given, laptop's own display was readable when 
installation program changed to graphics mode.

This option worked with:
  Fedora Core 4 test 3
  Fedora Core 4
  (might work with Fedora Core 3; not tested)

Comment 5 Tarjei Knapstad 2005-10-03 07:34:53 EDT
Struggling with the same laptop here. I've just done a text install thinking I
could fix the X stuff later (I've updated all the packages), but I'm having
problems. 

I just tried booting the install CD with the resolution=1400x1050 option which
works fine, but adding the 'resolution' option when trying to boot from HD does
nothing. I end up with a black screen and can't even switch to a text terminal
so I have to cold reboot the laptop.

Could anyone tell me what should be in the Screen and Monitor sections in
xorg.conf? (I tried adding 1400x1050 as a Mode in the Screen section, but same
result).
Comment 6 Chris Lumens 2006-01-16 15:37:11 EST
Is this better in FC5t2?
Comment 7 John Thacker 2006-05-05 17:08:27 EDT
Closing due to lack of response from reporter.

Note You need to log in before you can comment on or make changes to this bug.