Bug 159948 - qla2200 driver sees disk array as RAID instead of Direct-Access
qla2200 driver sees disk array as RAID instead of Direct-Access
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-09 12:11 EDT by Dustin Little
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: FC 4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 15:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dustin Little 2005-06-09 12:11:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
I have two existing fc2 boxes connected to a hp va7200 disk array. A snippet of the kernel boot messages follows:

...
May 25 07:16:36 mercury kernel: QLogic Fibre Channel HBA Driver (f8821000)
May 25 07:16:36 mercury kernel: ACPI: PCI Interrupt Link [IN26] enabled at IRQ 1
0
May 25 07:16:36 mercury kernel: PCI: setting IRQ 10 as level-triggered
May 25 07:16:36 mercury kernel: ACPI: PCI interrupt 0000:06:02.0[A] -> GSI 10 (level, low) -> IRQ 10
May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0: Found an ISP2200, irq 10,iobase 0xf881c000
May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0: Configuring PCI space...
May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0: Configure NVRAM parameters...
May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0: Verifying loaded RISC code...
May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0: LIP reset occured (0).
May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0: Waiting for LIP to complete...
May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0: LOOP UP detected (1 Gbps).May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0: Topology - (F_Port), HostLoop address 0xffff
May 25 07:16:36 mercury kernel: scsi0 : qla2xxx
May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0:
May 25 07:16:36 mercury kernel:  QLogic Fibre Channel HBA Driver: 8.00.00b21-k
May 25 07:16:36 mercury kernel:   QLogic QLA22xx -
May 25 07:16:36 mercury kernel:   ISP2200: PCI (66 MHz) @ 0000:06:02.0 hdma-, host#=0, fw=2.02.06 TP
May 25 07:16:36 mercury kernel:   Vendor: HP        Model: A6189A            Rev: HP18
May 25 07:16:36 mercury kernel:   Type:   Direct-Access                      ANSI SCSI revision: 03
May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0: scsi(0:0:0:0): Enabled tagged queuing, queue depth 16.
May 25 07:16:36 mercury kernel: SCSI device sda: 20480 512-byte hdwr sectors (10 MB)
May 25 07:16:36 mercury kernel: SCSI device sda: drive cache: write back
May 25 07:16:36 mercury kernel: SCSI device sda: 20480 512-byte hdwr sectors (10 MB)
May 25 07:16:36 mercury kernel: SCSI device sda: drive cache: write back
May 25 07:16:36 mercury kernel:  sda:
May 25 07:16:36 mercury kernel: Attached scsi disk sda at scsi0, channel 0, id 0
, lun 0
May 25 07:16:36 mercury kernel:   Vendor: HP        Model: A6189A            Rev: HP18
May 25 07:16:36 mercury kernel:   Type:   Direct-Access                      ANSI SCSI revision: 03
May 25 07:16:36 mercury kernel: qla2200 0000:06:02.0: scsi(0:0:0:234): Enabled t
agged queuing, queue depth 16.
May 25 07:16:36 mercury kernel: SCSI device sdb: 532676608 512-byte hdwr sectors (272730 MB)
May 25 07:16:36 mercury kernel: SCSI device sdb: drive cache: write back
May 25 07:16:36 mercury kernel: SCSI device sdb: 532676608 512-byte hdwr sectors (272730 MB)
May 25 07:16:36 mercury kernel: SCSI device sdb: drive cache: write back
May 25 07:16:36 mercury kernel:  sdb: unknown partition table
May 25 07:16:36 mercury kernel: Attached scsi disk sdb at scsi0, channel 0, id
0, lun 234
...
followed by the remaining luns
...

While trying to connect a fc3 box to the same disk array I receive the following:

...
Jun  9 08:44:38 silver kernel: QLogic Fibre Channel HBA Driver (428c1000)
Jun  9 08:44:38 silver kernel: ACPI: PCI interrupt 0000:06:02.0[A] -> GSI 26 (level, low) -> IRQ 209
Jun  9 08:44:38 silver kernel: qla2200 0000:06:02.0: Found an ISP2200, irq 209,
iobase 0x42820000
Jun  9 08:44:38 silver kernel: qla2200 0000:06:02.0: Configuring PCI space...
Jun  9 08:44:38 silver kernel: qla2200 0000:06:02.0: Configure NVRAM parameters...
Jun  9 08:44:38 silver kernel: qla2200 0000:06:02.0: Verifying loaded RISC code...
Jun  9 08:44:38 silver kernel: qla2200 0000:06:02.0: LIP reset occured (0).
Jun  9 08:44:38 silver kernel: qla2200 0000:06:02.0: Waiting for LIP to complete...
Jun  9 08:44:38 silver kernel: qla2200 0000:06:02.0: LOOP UP detected (1 Gbps).
Jun  9 08:44:38 silver kernel: qla2200 0000:06:02.0: Topology - (F_Port), Host Loop address 0xffff
Jun  9 08:44:38 silver kernel: scsi0 : qla2xxx
Jun  9 08:44:38 silver kernel: qla2200 0000:06:02.0:
Jun  9 08:44:38 silver kernel:  QLogic Fibre Channel HBA Driver: 8.00.00b15-k
Jun  9 08:44:38 silver kernel:   QLogic QLA22xx -
Jun  9 08:44:38 silver kernel:   ISP2200: PCI (66 MHz) @ 0000:06:02.0 hdma+, host#=0, fw=2.02.06 TP
Jun  9 08:44:38 silver kernel: scsi: unknown device type 12
Jun  9 08:44:38 silver kernel:   Vendor: HP        Model: A6189A            Rev: HP18
Jun  9 08:44:38 silver kernel:   Type:   RAID                               ANSI SCSI revision: 03
Jun  9 08:44:38 silver kernel: qla2200 0000:06:02.0: scsi(0:0:0:0): Enabled tagged queuing, queue depth 16.
Jun  9 08:44:38 silver kernel: scsi: host 0 channel 0 id 0 lun16384 has a LUN larger than allowed by the host adapter
Jun  9 08:44:38 silver kernel: scsi: host 0 channel 0 id 0 lun16618 has a LUN larger than allowed by the host adapter
Jun  9 08:44:38 silver kernel: scsi: host 0 channel 0 id 0 lun16619 has a LUN larger than allowed by the host adapter
Jun  9 08:44:38 silver kernel: scsi: host 0 channel 0 id 0 lun16628 has a LUN larger than allowed by the host adapter
...
followed by the identical number of entries with strange lun numbers as actual luns
...

I'm not sure if it is pertinent but notice the device type in both snippets. The device type in the first (working) output displays as "Direct-Access". While the device type in the second (broken) output displays as "RAID". Notice also the "scsi: unknown device type 12" message. What would cause the kernel driver to see a device as Direct-Access on one box and RAID on another? Additionally, I tried to install fc2 on the third box with the same result as fc3.

Thanks for any help possible. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. reintall
2. reboot
3. reread /var/log/messages
  

Additional info:
Comment 1 Tom Coughlan 2005-07-05 17:09:18 EDT
There were some error reports like this one that were fixed by this patch:

http://marc.theaimsgroup.com/?l=linux-scsi&m=111836291000433&w=2

Does that fix it?
Comment 2 Dave Jones 2005-07-15 15:12:36 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Tom Coughlan 2005-09-19 15:17:39 EDT
This BZ has been in NEEDINFO for two months. Since we have not received the
feedback we requested, we will assume the problem was not reproducible or has
been fixed in a later update for this product.

Note You need to log in before you can comment on or make changes to this bug.