Bug 15998 - installing the latest rpm-build package didn't work
Summary: installing the latest rpm-build package didn't work
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-11 14:55 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-15 17:07:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-11 14:55:01 UTC
When I installed the rpm-*-3.0.5-* set I got this error message
    /usr/lib/rpm not empty

When I do 
    rpm -Fvvh rpm-build-3.0.5-9.5x.i386.rpm
it does nothing and prints

# rpm -Fvvh rpm-b*
D: counting packages to install
D: found 1 packages
D: looking for packages to download
D: retrieved 0 packages
D: New Header signature
D: Signature size: 149
D: Signature pad : 3
D: sigsize         : 152
D: Header + Archive: 98014
D: expected size   : 98014
D: opening database mode 0x42 in /var/lib/rpm

I've still got lots of old stuff in /usr/lib/rpm.  rpm can still
list all of my packages.

Is  something now broken which will give me trouble in the
future?
D: found 0 source and 0 binary packages

Comment 1 Jeff Johnson 2000-08-15 17:07:10 UTC
Can you do
	strace -o /tmp/xxx rpm -Fvv rpm-build*
and look at /tmp/xxx? If rpm looks like it is looping repeatedly, then try doing
	rpm --rebuilddb
and repeat the install. 

If the rpm-build still does not install, please mail me <jbj@redhat.com> a copy
of the strace
output.

Thanks.

Comment 2 Jeff Johnson 2000-08-24 16:35:45 UTC
Please reopen this bug if your problem is still an issue.


Note You need to log in before you can comment on or make changes to this bug.