Bug 160048 - Disk /dev/sdah doesn't contain a valid partition table
Disk /dev/sdah doesn't contain a valid partition table
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lvm (Show other bugs)
3.0
sparc Linux
medium Severity low
: ---
: ---
Assigned To: Heinz Mauelshagen
Brian Brock
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-10 10:09 EDT by Kieran Foley
Modified: 2008-03-17 12:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 12:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kieran Foley 2005-06-10 10:09:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
I created a new LVM volume and it is now mounted and in production. It is only now that I see that the new disks that contain the LVM's were never partitioned/labeled. Is it ok for me to "write current table" to these disks after the fact? And is there a way to get the Kernel to re-read the partition tables without rebooting?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fdisk -l
2.
3.
  

Actual Results:  Disk /dev/sdag doesn't contain a valid partition table
Disk /dev/sdah doesn't contain a valid partition table
Disk /dev/sdai doesn't contain a valid partition table
Disk /dev/sdaj doesn't contain a valid partition table
Disk /dev/sdak doesn't contain a valid partition table
Disk /dev/sdal doesn't contain a valid partition table
Disk /dev/sdaa doesn't contain a valid partition table
Disk /dev/sdab doesn't contain a valid partition table
Disk /dev/sdac doesn't contain a valid partition table
Disk /dev/sdad doesn't contain a valid partition table
Disk /dev/sdae doesn't contain a valid partition table
Disk /dev/sdaf doesn't contain a valid partition table


Additional info:
Comment 1 Heinz Mauelshagen 2005-06-10 10:24:25 EDT
No, you can't write a partiton table onto the PVs created on the new disks.
If you do so, you overwrite LVM metadata there.
LVM supports creating PVs on whole devices without any partions on them.

If you want them partioned, you need to remove the LVs allocated to those PVs+
and remove the PVs from the VG(s) they belong to. Then you should zeor the first
sector of each drive (dd if=/dev/zero of=/dev/sda bs=512 count=1), setup
partitions, recreate PVs, add them to VG(s) and recreate LVs.
Comment 2 Kieran Foley 2005-06-10 10:36:31 EDT
Thanks but I do not want to partition the drives. I am already using the whole 
device. I do not want to change the partition table, all I want to do is get 
rid of the messages "doesn't contain a valid partition table" each time I 
execute fdisk. Is it safe for me to just do fdisk and option w given that I 
created the PVs on whole devices? O are you telling me I need to recreate the 
PVs?
Thanks
Comment 3 Heinz Mauelshagen 2005-06-10 12:14:45 EDT
Writing a partition table with fdisk is not recomended, because it will destroy
LVM metadata (comparable to overwriting a partition table *while* partitions are
in use). You either ignore the fdisk messages or need to follow the above
procedure (remove LVs, remove PVs from VG(s), write (empty) partition table,
(re)create PVs, extend VG(s), create LVs).
Comment 4 Red Hat Bugzilla 2007-02-05 14:18:23 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 5 RHEL Product and Program Management 2007-10-19 15:00:50 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.