Bug 160087 - 2.6.9-11 uses old (broken) 3ware 9500 driver (3w-9xxx.ko)
2.6.9-11 uses old (broken) 3ware 9500 driver (3w-9xxx.ko)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-10 14:10 EDT by David Johnston
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEL 4 U4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 15:10:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Johnston 2005-06-10 14:10:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
I saw errors similar to this in /var/log/messages:
 kernel: 3w-9xxx: scsi0: ERROR: (0x03:0x0104): SGL entry has illegal length:address=0x68F3B000, length=0xFF, cmd=X.

3ware support states that this is a known bug older versions of their driver.  The bug is corrected in version 9.2 of the driver, available from their website.

There is also an updated Makefile for this driver available from the 3ware website; the updated Makefile builds the driver for the running kernel.  The updated Makefile simplifies building the driver you need, probably not much use the the kernel developers.

The updated driver includes a firmware upgrade that will be installed automatically at the next boot.

This driver builds fine on my system.  After copying 3w-9xxx.ko to /lib/modules/`unmae -r`/kernel/drivers/scsi, I remade the initrd (cd /boot; mkinitrd initrd-2.6.9-11.ELsmp 2.6.9-11.ELsmp) and rebooted.  This almost doubles the size of the initrd; I assume this is because of the embedded firmware upgrade.  After reboot, the firmware was updated and the errors stopped.

I also built the driver for the UP kernel.  Without the updated driver, I got errors during boot; after rebooting with the updated initrd and kernel, the firmware was not reflashed, and there were no errors.

Version-Release number of selected component (if applicable):
kernel-2.6.9-11

How reproducible:
Always

Steps to Reproduce:
Boot a kernel built with <9.2 3w-9xxx driver

Actual Results:  An error similar to the following occurs sometime after the pivot_root:
 kernel: 3w-9xxx: scsi0: ERROR: (0x03:0x0104): SGL entry has illegal length:address=0x68F3B000, length=0xFF, cmd=X.


Expected Results:  No error

Additional info:
Comment 1 Tom Coughlan 2006-10-18 15:10:28 EDT
In RHEL 4 U4 we updated the 3w-9xxx driver to the latest version available from
3ware:

3w-9xxx.c:#define TW_DRIVER_VERSION "2.26.04.010"

I am not sure how this version number relates to what you mentioned, but it is
the latest, so it should solve your problem. Re-open this if it does not. 

Note You need to log in before you can comment on or make changes to this bug.