Bug 160179 - kernel panic in via_rhine
kernel panic in via_rhine
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-12 19:45 EDT by Stephen Clouse
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 14:39:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Clouse 2005-06-12 19:45:01 EDT
Keep encountering this kernel panic at random intervals.  Not clued enough to
determine if this is in hardware or software.  Can someone decipher?

Unable to handle kernel paging request at virtual address 026016af
 printing eip:
d005c9e1
*pde = 00000000
Oops: 0000 [#1]
SMP
Modules linked in: md5 ipv6 ip_conntrack_ftp ipt_TOS iptable_mangle iptable_nat
ipt_LOG ipt_state ip_conntrack iptable_filter ip_tables microcode xfs exportfs
dm_mod video button battery ac uhci_hcd ehci_hcd via_rhine mii floppy ext3 jbd
CPU:    0
EIP:    0060:[<d005c9e1>]    Not tainted VLI
EFLAGS: 00010293   (2.6.11-1.27_FC3smp)
EIP is at rhine_tx+0xea/0x25e [via_rhine]
eax: 00000070   ebx: d001c000   ecx: 00000002   edx: 0260163f
esi: cedc7a40   edi: 00000007   ebp: cedc7800   esp: c0413f74
ds: 007b   es: 007b   ss: 0068
Process search.cgi (pid: 2678, threadinfo=c0413000 task=c1d97560)
Stack: 0000003c 000003e0 c1d97560 d001c000 00000002 00000014 d001c008 d005c7af
       c11f4c60 c1d97560 046b3102 c11f5060 00000000 cedc7a40 00000001 d001c000
       cedc7800 cf518180 00000000 cec6bf4c 0000000f c013e2b0 00000000 0000000f
Call Trace:
 [<d005c7af>] rhine_interrupt+0x10a/0x252 [via_rhine]
 [<c013e2b0>] handle_IRQ_event+0x31/0x62
 [<c013e3ad>] __do_IRQ+0xcc/0x13f
 [<c0106180>] do_IRQ+0x50/0x89
 =======================
 [<c01048f6>] common_interrupt+0x1a/0x20
 [<c018ac20>] dnotify_parent+0x25/0x75
 [<c015caf2>] vfs_write+0xc2/0x10a
 [<c015cbe5>] sys_write+0x41/0x6a
 [<c0103f0f>] syscall_call+0x7/0xb
Code: 83 c0 01 89 c7 89 86 64 02 00 00 83 e7 0f 8b 96 60 02 00 00 39 d0 0f 84 87
00 00 00 89 f8 8b 56 04 c1 e0 04 83 3d a0 07 06 d0 06 <8b> 1c 10 7f 4f 85 db 78
63 66 85 db 0f 88 32 ff ff ff f6 86 51
 <0>Kernel panic - not syncing: Fatal exception in interrupt
 [<c0120fa5>] panic+0x42/0x1ca
 [<c0105156>] die+0x184/0x18e
 [<c011977f>] do_page_fault+0x0/0x605
 [<c0119b31>] do_page_fault+0x3b2/0x605
 [<c011d501>] __wake_up_common+0x35/0x57
 [<c011d27f>] scheduler_tick+0xbc/0x2fd
 [<c01088b2>] timer_interrupt+0xa5/0xfd
 [<c011c82a>] find_busiest_group+0xbf/0x30b
 [<c011977f>] do_page_fault+0x0/0x605
 [<c0104a2b>] error_code+0x2b/0x30
 [<d005c9e1>] rhine_tx+0xea/0x25e [via_rhine]
 [<d005c7af>] rhine_interrupt+0x10a/0x252 [via_rhine]
 [<c013e2b0>] handle_IRQ_event+0x31/0x62
 [<c013e3ad>] __do_IRQ+0xcc/0x13f
 [<c0106180>] do_IRQ+0x50/0x89
 =======================
 [<c01048f6>] common_interrupt+0x1a/0x20
 [<c018ac20>] dnotify_parent+0x25/0x75
 [<c015caf2>] vfs_write+0xc2/0x10a
 [<c015cbe5>] sys_write+0x41/0x6a
 [<c0103f0f>] syscall_call+0x7/0xb
 Badness in panic at kernel/panic.c:120 (Not tainted)
 [<c01210d1>] panic+0x16e/0x1ca
 [<c0105156>] die+0x184/0x18e
 [<c011977f>] do_page_fault+0x0/0x605
 [<c0119b31>] do_page_fault+0x3b2/0x605
 [<c011d501>] __wake_up_common+0x35/0x57
 [<c011d27f>] scheduler_tick+0xbc/0x2fd
 [<c01088b2>] timer_interrupt+0xa5/0xfd
 [<c011c82a>] find_busiest_group+0xbf/0x30b
 [<c011977f>] do_page_fault+0x0/0x605
 [<c0104a2b>] error_code+0x2b/0x30
 [<d005c9e1>] rhine_tx+0xea/0x25e [via_rhine]
 [<d005c7af>] rhine_interrupt+0x10a/0x252 [via_rhine]
 [<c013e2b0>] handle_IRQ_event+0x31/0x62
 [<c013e3ad>] __do_IRQ+0xcc/0x13f
 [<c0106180>] do_IRQ+0x50/0x89
 =======================
 [<c01048f6>] common_interrupt+0x1a/0x20
 [<c018ac20>] dnotify_parent+0x25/0x75
 [<c015caf2>] vfs_write+0xc2/0x10a
 [<c015cbe5>] sys_write+0x41/0x6a
 [<c0103f0f>] syscall_call+0x7/0xb
Comment 1 Stephen Clouse 2005-06-27 13:52:20 EDT
Here is what appears to be the same lockup under FC4:

Unable to handle kernel paging request at virtual address 2e5dc4c4
 printing eip:
d0034ca0
*pde = 00000000
Oops: 0002 [#1]
Modules linked in: md5 ipv6 ip_conntrack_ftp ipt_TOS iptable_mangle iptable_nat
ipt_state ip_conntrack ipt_LOG iptable_filter ip_tables xfs exportfs dm_mod
video button battery ac uhci_hcd ehci_hcd i2c_prosavage i2c_algo_bit shpchp
i2c_viapro i2c_core via_rhine mii floppy ext3 jbd
CPU:    0
EIP:    0060:[<d0034ca0>]    Not tainted VLI
EFLAGS: 00010293   (2.6.11-1.1369_FC4)
EIP is at rhine_tx+0x12d/0x3d9 [via_rhine]
eax: 0007e078   ebx: d002a000   ecx: 00000002   edx: 0007e076
esi: ced5fa80   edi: 00000014   ebp: 00000006   esp: c0457f44
ds: 007b   es: 007b   ss: 0068
Process swapper (pid: 0, threadinfo=c0457000 task=c03c4ca0)
Stack: 00000050 00000001 00000086 82c27b00 000f8037 0000000a 3b9aca00 c6411aa0
       ced5f800 d002a000 00000002 00000014 d002a008 d0034a01 00000000 c5890cfc
       c5890cfc c0108c4a 00000000 ced5f800 ced5fa80 d002a000 00000000 ce33aac0
Call Trace:
 [<d0034a01>] rhine_interrupt+0xee/0x260 [via_rhine]
 [<c0108c4a>] timer_interrupt+0x7c/0x1b5
 [<c015085d>] handle_IRQ_event+0x2e/0x5a
 [<c015093c>] __do_IRQ+0xb3/0x367
 [<c0105b1d>] do_IRQ+0x4a/0x82
 =======================
 [<c0103c0e>] common_interrupt+0x1a/0x20
 [<c024a338>] acpi_processor_idle+0x0/0x24c
 [<c024a428>] acpi_processor_idle+0xf0/0x24c
 [<c01010a6>] cpu_idle+0x34/0x4c
 [<c042472a>] start_kernel+0x15f/0x1b9
 [<c04242fe>] unknown_bootoption+0x0/0x1cd
Code: ae 90 00 00 00 00 00 00 00 8b 96 e8 01 00 00 83 c2 01 89 96 e8 01 00 00 89
d5 83 e5 0f 8b 86 e4 01 00 00 39 d0 0f 84 dd 00 00 00 <89> ef c1 e7 04 89 f8 03
46 04 8b 18 83 3d 20 99 03 d0 06 7f 4d
 <0>Kernel panic - not syncing: Fatal exception in interrupt
 [<c0120908>] panic+0x45/0x1e2
 [<c0104614>] die+0x222/0x2c4
 [<c0118df5>] do_page_fault+0x1d9/0x59f
 [<c01811bb>] end_bio_bh_io_sync+0x0/0x4d
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c0212dbd>] __delay+0x9/0xa
 [<c018190e>] bio_destructor+0x1e/0x33
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c029a781>] cfq_put_request+0x71/0xa8
 [<c0118c1c>] do_page_fault+0x0/0x59f
 [<c0103c6b>] error_code+0x4f/0x54
 [<c011007b>] centrino_cpu_init_acpi+0x279/0x577
 [<d0034ca0>] rhine_tx+0x12d/0x3d9 [via_rhine]
 [<d0034a01>] rhine_interrupt+0xee/0x260 [via_rhine]
 [<c0108c4a>] timer_interrupt+0x7c/0x1b5
 [<c015085d>] handle_IRQ_event+0x2e/0x5a
 [<c015093c>] __do_IRQ+0xb3/0x367
 [<c0105b1d>] do_IRQ+0x4a/0x82
 =======================
 [<c0103c0e>] common_interrupt+0x1a/0x20
 [<c024a338>] acpi_processor_idle+0x0/0x24c
 [<c024a428>] acpi_processor_idle+0xf0/0x24c
 [<c01010a6>] cpu_idle+0x34/0x4c
 [<c042472a>] start_kernel+0x15f/0x1b9
 [<c04242fe>] unknown_bootoption+0x0/0x1cd
 Badness in panic at kernel/panic.c:119 (Not tainted)
 [<c0120a8d>] panic+0x1ca/0x1e2
 [<c0104614>] die+0x222/0x2c4
 [<c0118df5>] do_page_fault+0x1d9/0x59f
 [<c01811bb>] end_bio_bh_io_sync+0x0/0x4d
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c0212dbd>] __delay+0x9/0xa
 [<c018190e>] bio_destructor+0x1e/0x33
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c029a781>] cfq_put_request+0x71/0xa8
 [<c0118c1c>] do_page_fault+0x0/0x59f
 [<c0103c6b>] error_code+0x4f/0x54
 [<c011007b>] centrino_cpu_init_acpi+0x279/0x577
 [<d0034ca0>] rhine_tx+0x12d/0x3d9 [via_rhine]
 [<d0034a01>] rhine_interrupt+0xee/0x260 [via_rhine]
 [<c0108c4a>] timer_interrupt+0x7c/0x1b5
 [<c015085d>] handle_IRQ_event+0x2e/0x5a
 [<c015093c>] __do_IRQ+0xb3/0x367
 [<c0105b1d>] do_IRQ+0x4a/0x82
 =======================
 [<c0103c0e>] common_interrupt+0x1a/0x20
 [<c024a338>] acpi_processor_idle+0x0/0x24c
 [<c024a428>] acpi_processor_idle+0xf0/0x24c
 [<c01010a6>] cpu_idle+0x34/0x4c
 [<c042472a>] start_kernel+0x15f/0x1b9
 [<c04242fe>] unknown_bootoption+0x0/0x1cd
BUG: soft lockup detected on CPU#0!

Pid: 0, comm:              swapper
EIP: 0060:[<c011295b>] CPU: 0
EIP is at delay_pmtmr+0xb/0x13
 EFLAGS: 00000287    Not tainted  (2.6.11-1.1369_FC4)
EAX: c1dff0f2 EBX: 001e4010 ECX: c1d7d282 EDX: 00007cbd
ESI: 00000002 EDI: c0386d2a EBP: 000000b9 DS: 007b ES: 007b
CR0: 8005003b CR2: 2e5dc4c4 CR3: 02742000 CR4: 000006d0
 [<c0212dbd>] __delay+0x9/0xa
 [<c0120a2c>] panic+0x169/0x1e2
 [<c0104614>] die+0x222/0x2c4
 [<c0118df5>] do_page_fault+0x1d9/0x59f
 [<c01811bb>] end_bio_bh_io_sync+0x0/0x4d
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c0212dbd>] __delay+0x9/0xa
 [<c018190e>] bio_destructor+0x1e/0x33
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c029a781>] cfq_put_request+0x71/0xa8
 [<c0118c1c>] do_page_fault+0x0/0x59f
 [<c0103c6b>] error_code+0x4f/0x54
 [<c011007b>] centrino_cpu_init_acpi+0x279/0x577
 [<d0034ca0>] rhine_tx+0x12d/0x3d9 [via_rhine]
 [<d0034a01>] rhine_interrupt+0xee/0x260 [via_rhine]
 [<c0108c4a>] timer_interrupt+0x7c/0x1b5
 [<c015085d>] handle_IRQ_event+0x2e/0x5a
 [<c015093c>] __do_IRQ+0xb3/0x367
 [<c0105b1d>] do_IRQ+0x4a/0x82
 =======================
 [<c0103c0e>] common_interrupt+0x1a/0x20
 [<c024a338>] acpi_processor_idle+0x0/0x24c
 [<c024a428>] acpi_processor_idle+0xf0/0x24c
 [<c01010a6>] cpu_idle+0x34/0x4c
 [<c042472a>] start_kernel+0x15f/0x1b9
 [<c04242fe>] unknown_bootoption+0x0/0x1cd
 [<c01505e1>] softlockup_tick+0x95/0x1b8
 [<c012cd3d>] update_wall_time+0x14/0x40
 [<c012d331>] do_timer+0x4d/0xfb
 [<c0108c2e>] timer_interrupt+0x60/0x1b5
 [<c01219a2>] vprintk+0x256/0x518
 [<c015085d>] handle_IRQ_event+0x2e/0x5a
 [<c015093c>] __do_IRQ+0xb3/0x367
 [<c0105b39>] do_IRQ+0x66/0x82
 [<c0103c0e>] common_interrupt+0x1a/0x20
 [<c011295b>] delay_pmtmr+0xb/0x13
 [<c0212dbd>] __delay+0x9/0xa
 [<c0120a2c>] panic+0x169/0x1e2
 [<c0104614>] die+0x222/0x2c4
 [<c0118df5>] do_page_fault+0x1d9/0x59f
 [<c01811bb>] end_bio_bh_io_sync+0x0/0x4d
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c0212dbd>] __delay+0x9/0xa
 [<c018190e>] bio_destructor+0x1e/0x33
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c0155eac>] mempool_free+0x67/0x1ca
 [<c029a781>] cfq_put_request+0x71/0xa8
 [<c0118c1c>] do_page_fault+0x0/0x59f
 [<c0103c6b>] error_code+0x4f/0x54
 [<c011007b>] centrino_cpu_init_acpi+0x279/0x577
 [<d0034ca0>] rhine_tx+0x12d/0x3d9 [via_rhine]
 [<d0034a01>] rhine_interrupt+0xee/0x260 [via_rhine]
 [<c0108c4a>] timer_interrupt+0x7c/0x1b5
 [<c015085d>] handle_IRQ_event+0x2e/0x5a
 [<c015093c>] __do_IRQ+0xb3/0x367
 [<c0105b1d>] do_IRQ+0x4a/0x82
 =======================
 [<c0103c0e>] common_interrupt+0x1a/0x20
 [<c024a338>] acpi_processor_idle+0x0/0x24c
 [<c024a428>] acpi_processor_idle+0xf0/0x24c
 [<c01010a6>] cpu_idle+0x34/0x4c
 [<c042472a>] start_kernel+0x15f/0x1b9
 [<c04242fe>] unknown_bootoption+0x0/0x1cd
Comment 2 John W. Linville 2005-07-12 16:35:12 EDT
Have you tried booting w/ "acpi=off" on the kernel command line?  Please do so 
and post the results here...thanks! 
Comment 3 Dave Jones 2005-07-15 16:04:53 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 John W. Linville 2005-09-16 14:39:52 EDT
Closed due to lack of response.  Please re-open when the requested test 
results become available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.