Bug 160262 - Release notes not showing in installer
Release notes not showing in installer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-13 17:55 EDT by Brian Wheeler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-17 10:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Log (7.06 KB, text/plain)
2005-06-16 16:45 EDT, Brian Wheeler
no flags Details

  None (edit)
Description Brian Wheeler 2005-06-13 17:55:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I tried hitting the 'release notes' during install but only a blank window appeared.  This was over an FTP installation.  Installation proceeded normally.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:


Additional info:
Comment 1 Chris Lumens 2005-06-14 09:50:58 EDT
What language are you using for installation?  Does the directory you're
installing from have any RELEASE-NOTES* files?
Comment 2 Brian Wheeler 2005-06-14 10:08:43 EDT
I'm using english & installing from
ftp://ftp.ussg.indiana.edu/linux/fedora/linux/core/4/i386/os and there's a
RELEASE-NOTES file present.

I tried the upgrade on another machine this morning with the same settings and
got the same results.

Doing an upgrade via http (just replace ftp: with http: above) works as expected.

There are no error messages on the other text consoles.

A file with the current time named "/tmp/RELEASE-NOTES-en_US.UTF-8.html" is on
the installation root, but it is empty.
Comment 3 Jeremy Katz 2005-06-16 16:09:04 EDT
Can you grab /tmp/anaconda.log and attach it here?
Comment 4 Brian Wheeler 2005-06-16 16:36:46 EDT
There doesn't seem to be anything about the release notes in here, but I've
attached it anyway.

I'm booting off of boot.iso in case that makes any difference...
Comment 5 Chris Lumens 2005-06-16 16:43:55 EDT
Looking into a bug in how we're handling urlgrabber FTP return values or a bug
in urlgrabber itself.  It's trying to get the first possibility for a
RELEASE-NOTES, somehow ending up with a 0-length file, and interpreting that as
success so no other possibilities are tried.  Hence, the blank window.
Comment 6 Brian Wheeler 2005-06-16 16:45:24 EDT
Created attachment 115574 [details]
Anaconda Log 

I checked the release notes window several times...but they were empty and it
didn't make a difference in the log.
Comment 7 Chris Lumens 2005-06-17 10:49:48 EDT
Argh, the problem here is that we're not guaranteed to get an exception if we
try to pull down a file that doesn't exist using FTP.  In some cases, urllib
doesn't know what to do and gives us back an empty file instead.  Fixed on rawhide.

Note You need to log in before you can comment on or make changes to this bug.