Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 160293 - Openoffice.org (OO.o) crashes when pulling down the file menu
Openoffice.org (OO.o) crashes when pulling down the file menu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 03:49 EDT by ryuhei yokokawa
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.9.114-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-07 08:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 50745 None None None Never

  None (edit)
Description ryuhei yokokawa 2005-06-14 03:49:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
OO.o crashes when I click the "File" menu.  This happens when if you do that right after OO.o finishes loading.  The program reports "sh: crash_report: command not found" after the crash.  This happens everytime if you pull down the "File" menu too quickly after OO.o loads.  This specific system was just updated to FC4 from FC2 using CDs.

Version-Release number of selected component (if applicable):
openoffice.org-writer-1.9.104-2

How reproducible:
Always

Steps to Reproduce:
1.(preferably use the terminal) start oowriter.
2.Just as soon as OO.o loads, click on the "File" menu and drag your mouse down to "Save" or "Open" or something.
3.Bam, OO.o crashes (and give the report if you're using the terminal)
  

Actual Results:  OO.o crashes after the above steps.

Expected Results:  OO.o should let me open files, save files, or do whatever needs to be done.

Additional info:

The computer is an older dell system, P3 866Mhz, and 256ram.  It was working fine with FC2's OO.o until OO.o got updated along w/ FC.
Comment 1 Caolan McNamara 2005-06-14 04:12:27 EDT
Can you
gdb /usr/lib/openoffice.org1.9.104/program/soffice.bin
(gdb) run
(gdb) bt
and paste the results in here.
Comment 2 ryuhei yokokawa 2005-06-15 02:52:47 EDT
[ryuhei@localhost ~]$ gdb /usr/lib/openoffice.org1.9.104/program/soffice.bin
GNU gdb Red Hat Linux (6.3.0.0-1.21rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) bt
No stack.
(gdb) run
Starting program: /usr/lib/openoffice.org1.9.104/program/soffice.bin
Reading symbols from shared object read from target memory...(no debugging
symbols found)...done.
Loaded system supplied DSO at 0x724000
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1209124032 (LWP 2742)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---

Comment 3 ryuhei yokokawa 2005-06-15 03:07:28 EDT
I'm sorry, I just realized that I was doing it wrong so here's the result:
[ryuhei@localhost ~]$ gdb '/usr/lib/openoffice.org1.9.104/program/soffice.bin'
GNU gdb Red Hat Linux (6.3.0.0-1.21rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) run
Starting program: /usr/lib/openoffice.org1.9.104/program/soffice.bin
Reading symbols from shared object read from target memory...(no debugging
symbols found)...done.
Loaded system supplied DSO at 0xe29000
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208612032 (LWP 3610)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread -1222390864 (LWP 3613)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread -1232880720 (LWP 3614)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread -1243878480 (LWP 3615)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread -1262535760 (LWP 3616)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread -1281074256 (LWP 3617)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread -1281074256 (LWP 3617) exited]
[Thread -1232880720 (LWP 3614) exited]
[Thread -1243878480 (LWP 3615) exited]
---Type <return> to continue, or q <return> to quit---

Program exited normally.
(gdb) bt
No stack.
(gdb)
Comment 4 Caolan McNamara 2005-06-29 05:01:30 EDT
can you try again with 1.9.112 update and see does it persist ?
Comment 5 Roland Weiss 2005-06-30 07:54:31 EDT
Hi, I had the same problem. It seems to be related to the Crux theme. It does
not happen to me with the default and ClearCurve theme.

I get the error with impress and writer whenever I hit a grayed menu item.

greetings,
Roland
Comment 6 Caolan McNamara 2005-07-05 03:59:14 EDT
I see it in the crux theme. Good stuff roland for the vital piece of info.

0x1681ea: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xf1ea
0x16c2d2: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x132d2
0x5bb8a7e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x150a7e
(SalGraphics::DrawNativeControl(unsigned long, unsigned long, Region const&,
unsigned long, ImplControlValue const&, SalControlHandle&, rtl::OUString,
OutputDevice const*) + 0xba)
0x5c3b1cc: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d31cc
(Window::DrawNativeControl(unsigned long, unsigned long, Region const&, unsigned
long, ImplControlValue const&, rtl::OUString) + 0x11e)
Comment 7 Caolan McNamara 2005-07-05 04:29:12 EDT
http://qa.openoffice.org/issues/show_bug.cgi?id=50745

I'll patch for >= 1.9.114-2
Comment 8 Caolan McNamara 2005-07-07 08:38:59 EDT
fixed i rawhide 1.9.114-2, will update for fc4 soon
Comment 9 wheelbarr 2005-07-11 18:36:27 EDT
dmarj1@eq.edu.au
Comment 10 wheelbarr 2005-07-11 18:49:48 EDT
Having the same problem with 1.9.104-2 and openoffice.org-1.9.112-1.1.0.fc4 is
similar except a bug report window comes up and locks up the screen.
Comment 11 wheelbarr 2005-07-12 01:36:14 EDT
changed the theme from Crux to Smokey Blue and oo works well now.

Note You need to log in before you can comment on or make changes to this bug.