Bug 160321 - Alsa doesn't work after an upgrade from FC3 to FC4
Alsa doesn't work after an upgrade from FC3 to FC4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 09:38 EDT by Christian Jodar
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-14 17:44:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Jodar 2005-06-14 09:38:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I have an SB Live 5.1 sound card. Alsa worked correclty in Fedora Core 3 with this card.

After an upgrade to FC4 (using installation CD-ROMs), it doesn't work anymore. I can cat a sound file on /dev/dsp and it produces a sound, but all applications using Alsa fail.

I have errors about *Invalid CTL default* or *Unknown PCM default* depending on applications. Here is the output of alsamixer:

> alsamixer
ALSA lib control.c:654:(snd_ctl_open_noupdate) Invalid CTL default

alsamixer: function snd_ctl_open failed for default: No such file or directory


system-config-soundcard correctly detects this card, but the sound test leads to an error :

ALSA lib control.c:654:(snd_ctl_open_noupdate) Invalid CTL hw:0
amixer: Mixer attach hw:0 error: No such file or directory
ALSA lib control.c:654:(snd_ctl_open_noupdate) Invalid CTL hw:0
amixer: Mixer attach hw:0 error: No such file or directory
ALSA lib control.c:654:(snd_ctl_open_noupdate) Invalid CTL hw:0
amixer: Mixer attach hw:0 error: No such file or directory
ALSA lib control.c:654:(snd_ctl_open_noupdate) Invalid CTL hw:0
amixer: Mixer attach hw:0 error: No such file or directory
ALSA lib pcm.c:1975:(snd_pcm_open_noupdate) Unknown PCM plughw:0,0
aplay: main:508: audio open error: No such file or directory


Version-Release number of selected component (if applicable):
alsa-lib-1.0.9rc4-2

How reproducible:
Always

Steps to Reproduce:
1. Upgrade from FC3 to FC4
2. Launch alsamixer
  

Actual Results:  Output in console:

ALSA lib control.c:654:(snd_ctl_open_noupdate) Invalid CTL default

alsamixer: function snd_ctl_open failed for default: No such file or directory


Expected Results:  alsamixer should launch and displays volumes settings

Additional info:
Comment 1 Christian Jodar 2005-06-14 17:44:33 EDT
It was my fault. I had in my FC3 installation a package from atrpms, libasound2
which provides the same feature as the official one, alsa-lib.

I removed alsa-lib with yum, force remove of libasound2 ( rpm -e --nodeps
libasound2 ) and re-install alsa-lib. And now everything works.

Sorry for the inconvenience.

Note You need to log in before you can comment on or make changes to this bug.