Bug 160364 - vpnc does not change the routing tables properly
vpnc does not change the routing tables properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
http://lists.unix-ag.uni-kl.de/piperm...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 14:58 EDT by Jeff Orcutt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-15 14:21:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Orcutt 2005-06-14 14:58:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
From Mailing list:

Hi,

when i updated to vpnc 0.3.3 and tried to launch i got the following error:

Error: either "to" is duplicate, or "64" is a garbage.

To resolve this i had to change

sed 's/cache//;s/metric[0-9]\+ [0-9]\+//g'

to

sed 's/cache//;s/metric [0-9]\+ [0-9]\+//g'

within the  fix_ip_get_output function.

Bye
Sumedha


This change in /etc/vpnc/vpnc-script was necessary for me to connect to my campus VPN.  Before it would make the connection just hang.  It works now after this change.

Version-Release number of selected component (if applicable):
vpnc-0.3.3-2

How reproducible:
Always

Steps to Reproduce:
1.Install vpnc and configure it
2.sudo vpnc; get error message
3.open firefox


Actual Results:  no web page displayed

Expected Results:  should be connected

Additional info:
Comment 1 Tomas Mraz 2005-06-15 08:01:40 EDT
Your solution would break on other machines.

More correct would be: sed 's/cache//;s/metric[ 0-9]\+//g'
Comment 2 Tomas Mraz 2005-06-15 14:21:08 EDT
Should be fixed in the next vpnc builds for devel and FC4 extras.

Note You need to log in before you can comment on or make changes to this bug.