Bug 160373 - Yum crashes after update from FC3 to FC4. yum - python libraries.
Yum crashes after update from FC3 to FC4. yum - python libraries.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 15:45 EDT by Austin Harkins
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-20 18:09:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of the crash (142.18 KB, application/octet-stream)
2005-06-14 16:03 EDT, Austin Harkins
no flags Details
anaconda.log (15.51 KB, text/x-log)
2005-07-05 18:39 EDT, Easton Royce
no flags Details
anaconda.syslog (41.10 KB, application/octet-stream)
2005-07-05 18:41 EDT, Easton Royce
no flags Details

  None (edit)
Description Austin Harkins 2005-06-14 15:45:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
[root@austinh ~]# yum list updates
The yum libraries do not seem to be availableon your system for this version of python  2.4.1 (#1, May 16 2005, 15:19:29)
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)]
Please make sure the package you used to installyum was built for your install of python.



After update from FC3 to FC4, yum will not function, and gives error message shown above.

List of python packages installed on system:
gnome-python2-gtkhtml2-2.10.0-2.1
libxml2-python-2.6.19-1
gnome-python2-bonobo-2.10.0-1
rpm-python-4.4.1-21
gnome-python2-canvas-2.10.0-1
python-elementtree-1.2.6-4
python-sqlite-1.1.6-1
gnome-python2-gnomevfs-2.10.0-1
gnome-python2-extras-2.10.0-2.1
python-urlgrabber-2.9.6-1
gnome-python2-2.10.0-1
python-2.4.1-2
python-elementtree-debuginfo-1.2.6-4
dbus-python-0.33-3
python-devel-2.4.1-2



Version-Release number of selected component (if applicable):
yum-2.3.2-7

How reproducible:
Always

Steps to Reproduce:
1. Upgrade from FC3 to FC4 with CD's
2. type 'yum list updates' at command prompt as root.
3.
  

Actual Results:  See error message in Description

Expected Results:  Yum should have shown any updates available for my system.

Additional info:

P3 450MHz
385712k RAM
Comment 1 Seth Vidal 2005-06-14 15:50:39 EDT
rpm -q yum
rpm -V yum

send the outputs of those, please.

Comment 2 Austin Harkins 2005-06-14 16:03:39 EDT
Created attachment 115423 [details]
strace of the crash
Comment 3 Seth Vidal 2005-06-14 16:12:25 EDT
do an rpm -V python-elementtree and see if that package is corrupted. I bet it is.
Comment 4 Austin Harkins 2005-06-14 16:25:24 EDT
[root@austinh ~]# rpm -q yum
yum-2.3.2-7

[root@austinh ~]# rpm -V yum
..?.....    /usr/lib/python2.4/site-packages/repomd/__init__.py

[root@austinh ~]# rpm -V python-elementtree
Unsatisfied dependencies for python-elementtree-1.2.6-4.i686: python-abi = 2.3


here is the information you requested.
Comment 5 Seth Vidal 2005-06-14 16:29:51 EDT
python-elementtee-1.2.6-4.i686??
where did you get that from?

rpm -qi python-elementtree

anyway - the problem is your python-elementtree is for the wrong ver of python.

download the python-elementtree package from FC4 and run:
rpm -Uvh --replacepkgs --replacefiles name-of-python-elementtree-rpm
Comment 6 Austin Harkins 2005-06-14 16:56:08 EDT
I have replaced the python-elementtree package from the FC4 distribution.  Now,
when you do a rpm -V on python-elementtree there is no report, however, yum is
still giving the same message.
Comment 7 Seth Vidal 2005-06-15 11:50:27 EDT
If you could - go to /usr/share/yum-cli

type:
python ./yummain.py list updates


and send me the output, please

thanks
Comment 8 Austin Harkins 2005-06-15 12:02:17 EDT
Here is the information you requested:

[root@austinh yum-cli]# pwd
/usr/share/yum-cli
[root@austinh yum-cli]# python ./yummain.py list updates
Traceback (most recent call last):
  File "./yummain.py", line 23, in ?
    import yum
  File "__init__.py", line 35, in ?
  File "config.py", line 32, in ?
ImportError: No module named urlgrabber

I hope this helps identify what is wrong.
Comment 9 Seth Vidal 2005-06-15 12:03:54 EDT
install python-urlgrabber from FC4

something went wrong with your update.
did you update via anaconda?
Comment 10 Austin Harkins 2005-06-15 14:06:38 EDT
yes, I updated with anaconda off of the CD's.

I took your advice and replaced python-urlgrabber from the cd. This fixed the
problem.  Thank you for your help.  I have no idea what caused the issue in the
first place, evidently anaconda didnt do everything it was supposed to.  

It is working now, and thank you for your help.  I hope working through this
issue with me will help make yum or anaconda better.
Comment 11 Rahul Sundaram 2005-06-20 18:09:30 EDT
This seems to be an issue with anaconda rather than yum. Reassigning
Comment 12 Easton Royce 2005-07-05 08:51:33 EDT
Hi, I'm a little new to bugzilla, so I appologise if I have posted this in the
wrong place. I am having the same issues as above, except I didn't upgrade from
FC3 to FC4. Rather I installed FC4 from the download media. After installing, I
deiced to install Video Lan. Which has worked without causing problems on
previous versions of Fedora. I think that this problem occurred after I finished
installing the many various codecs and other things that are required for VLC. I
have followed through with as many things as I can above, but I am still getting
the same error. Here are my output messages below:

#rpm -q yum:
yum-2.3.2-7

#rpm -V yum:
..?.....    /usr/lib/python2.4/site-packages/repomd/__init__.py

#rpm -V python-elementtree:
(nothing)

#rpm -qi python-elementtree
Name        : python-elementtree           Relocations: (not relocatable)
Version     : 1.2.6                             Vendor: Red Hat, Inc.
Release     : 4                             Build Date: Tue 05 Apr 2005 01:10:08
AM EST
Install Date: Tue 05 Jul 2005 10:31:20 PM EST      Build Host:
tweety.build.redhat.com
Group       : Development/Libraries         Source RPM:
python-elementtree-1.2.6-4.src.rpm
Size        : 303730                           License: PSF
Signature   : DSA/SHA1, Sat 21 May 2005 05:32:45 AM EST, Key ID
b44269d04f2a6fd2Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://effbot.org/zone/element-index.htm
Summary     : Fast XML parser and writer
Description :
The Element type is a simple but flexible container object, designed
to store hierarchical data structures, such as simplified XML
infosets, in memory. The element type can be described as a cross
between a Python list and a Python dictionary.

This package also includes the C implementation, cElementTree-1.0.2-20050302.

#python ./yummain.py list updates:
Traceback (most recent call last):
  File "./yummain.py", line 23, in ?
    import yum
  File "__init__.py", line 35, in ?
  File "config.py", line 34, in ?
  File "repos.py", line 30, in ?
  File "repoMDObject.py", line 18, in ?
  File "/usr/lib/python2.4/site-packages/libxml2.py", line 1, in ?
    import libxml2mod
ImportError: /usr/lib/python2.4/site-packages/libxml2mod.so: undefined symbol:
xmlTextReaderGetParserColumnNumber

I have tried re-installing the various packages listed above and the libxml* and
libxml2* packages with no change at all. The only way around this I can think
of, is to format and re-install, and dont install VLC, or one of its dependencies.
Comment 13 Paul Nasrat 2005-07-05 10:13:16 EDT
Please can you attach the following as individual uncompressed attachments.

/root/upgrade.log
/var/log/anaconda.log
/var/log/anaconda.syslog
Comment 14 Easton Royce 2005-07-05 18:39:18 EDT
Created attachment 116390 [details]
anaconda.log
Comment 15 Easton Royce 2005-07-05 18:41:08 EDT
Created attachment 116391 [details]
anaconda.syslog
Comment 16 Easton Royce 2005-07-05 18:43:21 EDT
there was no /root/upgrade.log as I performed a clean install of FC4.
Comment 17 Paul Nasrat 2005-07-06 01:58:29 EDT
Please describe the full path to get to current machine state. Based on the bug
subject I assumed an FC3->FC4 upgrade, which is what the comments in the bug
indicate also.
Comment 18 Easton Royce 2005-07-06 03:03:24 EDT
I downloaded VideoLan from www.videolan.org - I downloaded the source version,
and all of its required codecs etc. I then compiled and installed all the
required codecs etc. I never got to installing the VLC player, because I
installed Amarok from the Fedora Core extras, and wanted to get mp3 support for
g-streamer to play mp3s in Amarok. So I found out how to do this by using yum.
And when I tried to use yum, the errors started. Prior to all this, I had
successfully used yum to download all updates (800mb+).
Comment 19 David A Thompson 2005-09-08 12:59:33 EDT
After upgrading from FC3 to FC4, yum dies w/similar error messages to Bugzilla
Bug 160373 ("Yum crashes after update from FC3 to FC4. yum - python libraries").

How reproducible: unknown -- is it possible to revert back to FC3 and try the
whole ball game all over again?

Steps to reproduce:
1. Upgrade from FC3 to FC4
2. Execute yum

Actual results: See below

Expected results: I'd figured yum would still work...



So...I tried reinstalling any packages that seemed like they possibly might be
the culprits using the Fedora Core 4 packages.

[root@localhost yum]# ls -al
total 12268
drwxr-xr-x   2 root root    4096 Sep  8 09:18 .
drwxr-xr-x  50 1000 1000    4096 Sep  7 16:11 ..
-rw-r--r--   1 root root 2871108 May 20 10:18 gcc-4.0.0-8.i386.rpm
-rw-r--r--   1 root root   43904 May 20 10:18 libgcc-4.0.0-8.i386.rpm
-rw-r--r--   1 root root  302476 May 20 10:18 libstdc++-4.0.0-8.i386.rpm
-rw-r--r--   1 root root  704872 May 20 11:53 libxml2-2.6.19-1.i386.rpm
-rw-r--r--   1 root root  494616 May 20 11:53 libxml2-python-2.6.19-1.i386.rpm
-rw-r--r--   1 root root 5836392 May 20 10:34 python-2.4.1-2.i386.rpm
-rw-r--r--   1 root root   79980 May 20 12:32 python-elementtree-1.2.6-4.i386.rpm
-rw-r--r--   1 root root   37690 May 20 12:31 python-sqlite-1.1.6-1.i386.rpm
-rw-r--r--   1 root root   93700 May 20 12:31 python-urlgrabber-2.9.6-1.noarch.rpm
-rw-r--r--   1 root root  594738 May 24 15:02 rpm-4.4.1-21.i386.rpm
-rw-r--r--   1 root root  935357 May 24 15:02 rpm-libs-4.4.1-21.i386.rpm
-rw-r--r--   1 root root   97698 May 24 15:02 rpm-python-4.4.1-21.i386.rpm
-rw-r--r--   1 root root    5909 Sep  7 16:14 xml-common-0.6.3-17.noarch.rpm
-rw-r--r--   1 root root  379636 Sep  7 16:11 yum-2.3.2-7.noarch.rpm
[root@localhost yum]# 
[root@localhost yum]# rpm -Uvh --replacepkgs --replacefiles *rpm
Preparing...                ########################################### [100%]
   1:python                 ########################################### [  7%]
   2:libgcc                 ########################################### [ 14%]
   3:rpm-libs               ########################################### [ 21%]
   4:rpm                    ########################################### [ 29%]
   5:rpm-python             ########################################### [ 36%]
   6:python-elementtree     ########################################### [ 43%]
   7:python-sqlite          ########################################### [ 50%]
   8:python-urlgrabber      ########################################### [ 57%]
   9:libxml2                ########################################### [ 64%]
  10:libxml2-python         ########################################### [ 71%]
  11:gcc                    ########################################### [ 79%]
  12:libstdc++              ########################################### [ 86%]
  13:xml-common             ########################################### [ 93%]
  14:yum                    ########################################### [100%]
[root@localhost yum]# 
[root@localhost yum]# yum
The yum libraries do not seem to be availableon your system for this version of
python  2.4.1 (#1, May 16 2005, 15:19:29) 
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)]
Please make sure the package you used to installyum was built for your install
of python.
[root@localhost yum]# 
[root@localhost yum]# python
Python 2.4.1 (#1, May 16 2005, 15:19:29) 
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import yum
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "__init__.py", line 35, in ?
  File "config.py", line 34, in ?
  File "repos.py", line 30, in ?
  File "repoMDObject.py", line 18, in ?
  File "/usr/lib/python2.4/site-packages/libxml2.py", line 1, in ?
    import libxml2mod
ImportError: /usr/lib/python2.4/site-packages/libxml2mod.so: undefined symbol:
xmlDictCleanup
>>> 

At this point, all I've concluded is that this is definitely a bummer... I've
attached 
/root/upgrade.log
/var/log/anaconda.log
/var/log/anaconda.syslog
on the off-chance that they might be of some help in figuring out where things
went awry...

Thanks for any assistance :)
Comment 20 David A Thompson 2005-09-08 14:08:43 EDT
Tried to upload the above files but redhat seemed pretty reluctant to upload
them so instead I put them at http://biology.fresno.edu/logs.tar.bz2
Comment 21 David A Thompson 2005-09-09 13:56:30 EDT
Issue resolved - should have checked before even posting anything: when I
checked /etc/ld.so.conf and started tracking down libraries, I found a
non-Fedora libxml2.so tucked away... (...a reminder of the dangers of straying
from the glorious Fedora Core to (1) 3rd-party RPM repositories and (2) mixing
in compiling from source...). Apologies for consuming time/attention
unnecessarily...

Note You need to log in before you can comment on or make changes to this bug.