Bug 160381 - "Upgrade on next boot" rpm
"Upgrade on next boot" rpm
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda-images (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 16:04 EDT by John
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-16 16:15:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John 2005-06-14 16:04:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
It would be great to see an rpm package which would
upgrade a computer, and then be uninstalled afterward by
anaconda.

It would be installed through

yum install update-bootloader,

say, and would install both a boot image in /boot or some
other appropriate location, and would place an appropriate
boot entry in the grub menu.

Upon reboot, you would have the option to do an network
upgrade over ftp, nfs, etc.  Again, post install the
package would be automatically removed.

Upgrades can currently be performed by putting a boot
image on disk and editing yum by hand...  providing a
package to do the same should be relatively straightfoward
(Famous last words, I know. :) and very helpful.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1..
2.
3.
  

Additional info:
Comment 1 Jeremy Katz 2005-06-16 16:15:25 EDT
The problem is that this can't be done, eg, on FC3 for the upgrade to FC4 and
it's entirely possible that a package built for FC4 won't work with FC3
Comment 2 John 2005-06-16 20:20:44 EDT
Sorry, I don't get why it won't work...  why would you need
to install an FC4 package under FC3?

The idea would be, once FC5, say, becomes available, push an
FC4 package to the FC4 mirrors which only contains a boot image
for the FC5 installer.  Package installation installs the
appropriate grub menu entry, too.  Upon booting using that
menu entry, an FC5 network boot proceeds as usual.

It has worked previously by hand...  is there some problem I
don't get which precludes the packaging?

Note You need to log in before you can comment on or make changes to this bug.