Bug 16040 - RFE: Add fsck to ftp install boot rescue instimage
RFE: Add fsck to ftp install boot rescue instimage
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-11 18:27 EDT by Steve Dum
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-15 10:32:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dum 2000-08-11 18:27:12 EDT
If I boot the rescue image from cd, I get fsck and e2fsck
in the boot images.  Booting with the ftp install disk
and booting to the rescue image I don't.  That seems 
real unfriendly.

Basically, my ftp install installed 90% of the system,
and crashed. After trying a few things, install refused to
do anything because the disk needed to be fsck'ed.  Unfortunately
the ftp install disk rescue image didn't contain the tools
needed to fsck the disk.  At this point I was basically 
out of luck - couldn't boot, since lilo didn't like the
partial system, couldn't boot the rescue disk and fsck the sytem.
There shouldn't be a space problem, since this is a ftp
image.  Why isn't it there?  Even if it was a space 
image, I thought fsck (or at least e2fsck) would be an
important program on the rescue disk.
Comment 1 Michael Fulbright 2000-08-14 14:33:17 EDT
Added to future feature request list.
Comment 2 Michael Fulbright 2000-09-26 12:10:36 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 3 Michael Fulbright 2000-09-26 12:56:18 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 4 Michael Fulbright 2000-12-04 16:09:57 EST
Committed to rawhide CVS.
Comment 5 Brock Organ 2000-12-08 15:17:35 EST
fsck & e2fsck are STILL not present in rescue mode from the bootnet.img ...
Comment 6 Brock Organ 2000-12-12 17:18:33 EST
fsck & e2fsck are not present in rescue mode from the bootnet.img (using test
tree qa1212.1) ...
Comment 7 Michael Fulbright 2000-12-15 10:32:46 EST
They dont fit in the image, so we cant do this at this time.

Note You need to log in before you can comment on or make changes to this bug.