Bug 160426 - DVD of FC4 won't load from Secondary IDE Slave
DVD of FC4 won't load from Secondary IDE Slave
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 21:42 EDT by Rory Gleeson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-22 04:22:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt from DVD failure to copy install image to hard drive (910.02 KB, text/plain)
2005-06-17 15:03 EDT, Frank Swasey
no flags Details

  None (edit)
Description Rory Gleeson 2005-06-14 21:42:52 EDT
Description of problem:
Installing FC3 from DVD image walks you through first few steps of Fedora
install (choosing language, location, etc).  

BUT, when it gets to selecting media to install from, it only has four options:
CDROM
NSF
HTTP
FTP

I'm loading from the DVD I burned (which has gotten me this far) but there's no
option for this.  I choose CDROM.  It says no media found and pops the DVD from
my DVD burner.

My CDROM is on my Secondary IDE Master
DVD burner is on Secondary IDE Slave

Don't know if this is the root of the issue or not.  But, I've used other DVD
distros (Ubuntu, SuSE and Mandrake) with this set-up and have never encountered
this.

* please note that the component I chose to file this bug is wrong.  Didn't know
what to choose.
Comment 1 Neil Aspinall 2005-06-15 19:25:46 EDT
I have exactly the same problem as described, however my DVD drive is the
secondary master - so I think the "secondary slave" part is a red herring and
the problem lies elsewhere. I installed all the test versions of FC4 from DVD
with no problems.

Here's a thread full of people with the same problem on FedoraForum:
http://forums.fedoraforum.org/showthread.php?t=43831
Comment 2 Kelvin 2005-06-15 22:25:35 EDT
I have exactly the same problem as described by Rory, exactly the same steps 
and exactly the same place where the problem occur.

However, mine is a laptop computer, and my DVD rom drive is the only drive i 
have and I have installed FC3 before without any problem.

I have read some post that others have successfully install it with the DVD 
image, but I have tried it many times, no luck for me.
Comment 3 Jeremy Katz 2005-06-16 16:31:06 EDT
Does booting with 'linux ide=nodma' help?  What messages are there on tty3 and tty4?
Comment 4 Neil Aspinall 2005-06-17 05:09:27 EDT
I was having this problem when I was burning to DVD+RW media, but now I've 
tried it on DVD+R and it installed without a hitch. So it seems the installer 
has a problem with DVD+RW media? I tried burning to two different DVD+RW discs 
and got the same problem - and all test versions of FC4 have installed from 
DVD+RW - so I don't think it's the burning process at fault.
Comment 5 Rory Gleeson 2005-06-17 09:20:26 EDT
Hmm... you may be on to something.  I, too, am burning on DVD-RW media via k3b.
 My DVD-RW, by the way, has always been full-proof until now.
Rory
Comment 6 Frank Swasey 2005-06-17 15:03:33 EDT
Created attachment 115634 [details]
anacdump.txt from DVD failure to copy install image to hard drive
Comment 7 Frank Swasey 2005-06-17 15:07:46 EDT
I had a similar problem with a DVD+RW image I burned on a macintosh running Tiger.

I attempted to do an upgrade of my FC3 install on a Dell GX260, where the DVD
drive is the secondary master (hdc).  It failed three times generating the
anacdump.txt file I attached in comment #6.  It indicated that I might be out of
disk space in the error message that popped up.  The failure happened repeatedly
when it had finished asking questions about the upgrade and was attempting to
copy the install image to the hard disk.

After the third attempt to clean up the disk (believing the error message), I
gave up and performed the upgrade flawlessly from CDRW media.
Comment 8 Peter Smith 2005-06-21 00:54:12 EDT
I am curious.  Has anyone tried the Mediacheck yet?

"To use this test, type linux mediacheck at the boot: prompt."

http://fedora.redhat.com/docs/release-notes/fc4/#id2501928
Comment 9 Neil Aspinall 2005-06-21 12:16:47 EDT
When I was having the problem with the DVD+RW, I tried "linux mediacheck" and 
exactly the same thing happened as when I tried to install - I was taken 
through the blue text mode menus to select language, keyboard type and then 
install media but selecting CDROM didn't work!

Once I burned to DVD+R both the mediacheck and the install went flawlessly.
Comment 10 Frank Swasey 2005-06-21 12:40:50 EDT
I have tried the mediacheck and in my case the mediacheck passed.  Perhaps, my
issue is different than that of the original problem.
Comment 11 Hesty 2005-06-21 19:20:05 EDT
Same problem here with DVD+RW, I will try DVD-RW next and then DVD+R if nothing
else works. My setup is DVD+/-RW as /dev/hdc and CDRW as /dev/hdd. Everytime I
select CDROM, it pops out my CDRW drive as if it's asking for a CDROM. I have
tried disabling /dev/hdd through BIOS setup, but FC4 installation keeps popping
out the CDRW drive. How could this happen?
Comment 12 Chris Law 2005-06-26 06:38:22 EDT
Burned FC-4 to Dvd-R, dvd drive is master on the secondary ide, mediacheck 
done 3 times with various boot options as detailed under the function keys at 
the start.  Anaconda crashes the pc and the only way to reboot is to do the 
power switch hold for 5 secs.  Fc-1 installed without trouble from cd but 
trashed this in case of some conflict.  Am installing to hda3, slice 3 on 
master drive using default partitioning in the freespace.  Get the following 
error message:  Kernel Panic - not syncing drives/ide/pci/atiipx. c:129, 
spin_lock (drivers/id idec:c03de668) already locked by drivers/ide/ide-10ps. 
c/1235. (not tainted).  I think i will try the cd-rom downloads for fc-4 
next.  Have also reinstalled minimal fc-1 to see if i could upgrade to fc-4 
from there somehow.
Comment 13 Julius Roberts 2005-06-28 01:34:37 EDT
same problem here.  the install goes past keyboard and language options then
asks me where to install from; there is no DVD option.  install won't work, even
if i choose the hdd option and then select hdb (the dvd drive).

downloaded FC4 under suse 9.2 with wget.  downloaded ok and the sa1sum was OK. 
burned iso using kb3 ok.  i've a 80gb ata5 drive as master and a pioneer DVR109
DVD drive.  secondary slave is a LG 52x cdrw drive.
Comment 14 Christian Iseli 2007-01-19 19:19:38 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 15 Christian Iseli 2007-01-22 04:22:31 EST
Closed on behalf of Chris Law.

Note You need to log in before you can comment on or make changes to this bug.