Bug 160433 - Switchdesk has the wrong path for fluxbox
Switchdesk has the wrong path for fluxbox
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: switchdesk (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 00:21 EDT by Peter Smith
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-19 12:30:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Smith 2005-06-15 00:21:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
If you run switchdesk and select Fluxbox for your desktop WM, you will be given the following error dialog.

"[Information]
Your desktop configuration cannot be updated, please make sure that the package switchdesk has correctly been installed on the machine. [OK]"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run switchdesk, either from a WM menu, or at a commandline ("switchdesk")
2. Select "F&luxbox" from the radio-buttons under "Available Desktops"
3. Click the "OK" button
  

Actual Results:  You will be given the following error dialog.

"[Information]
Your desktop configuration cannot be updated, please make sure that the package switchdesk has correctly been installed on the machine. [OK]"

Expected Results:  I should have received the following dialog.

"[Information]
Your desktop configuration has successfully been updated, but you must restart the X Window System for the changes to take effect. [OK]"

Additional info:

switchdesk-helper has the wrong path for fluxbox and is failling to find the main fluxbox binary.  The following patch should fix it.

--- /usr/bin/switchdesk-helper  2004-10-01 14:48:09.000000000 -0500
+++ /usr/bin/switchdesk-helper  2005-06-14 23:17:16.000000000 -0500
@@ -76,7 +76,7 @@
         NEW_XCLIENTS="$DATADIR/Xclients.xfce"
         ;;
     FLUXBOX)
-        [ ! -x /usr/bin/fluxbox ] && NotFound FLUXBOX
+        [ ! -x /usr/X11R6/bin/fluxbox ] && NotFound FLUXBOX
         DNAME="fluxbox"
         NEW_XCLIENTS="$DATADIR/Xclients.fluxbox"
         ;;
Comment 1 Ngo Than 2005-07-19 12:30:33 EDT
it's now fixed in 4.0.7-1, which will be available in rawhide soon. Thanks for
your report.

Note You need to log in before you can comment on or make changes to this bug.