Bug 160439 - invisible bottom_panel (after screen resizing?)
invisible bottom_panel (after screen resizing?)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
: 160067 160900 161100 161416 161510 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 02:54 EDT by Thomas L. Shinnick
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version: gnome-panel-2.10.1-10.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-28 09:35:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Metacity debug log for reference (220.19 KB, text/plain)
2005-06-22 12:39 EDT, Mark McLoughlin
no flags Details
my panel setup (24.92 KB, image/png)
2005-06-23 15:22 EDT, Marek Stanczyk
no flags Details
how the panels actually look after logging in (16.24 KB, image/png)
2005-06-23 15:24 EDT, Marek Stanczyk
no flags Details

  None (edit)
Description Thomas L. Shinnick 2005-06-15 02:54:46 EDT
Description of problem:
After resizing screen and relogging into X, the bottom panel disappeared 
(background showing through) - no reaction to right-clicks or other mouse 
actions.  At this same time the top panel was blank (no icons showing).

Moving top panel to the left edge brought back the icons, and moving back to 
top edge made it "okay again". 

Attempting to move another panel (top or newly created) to bottom of screen 
showed bottom panel was "still present" as no other panel could be moved into 
that space (would come to rest above a bar-sized space).

Logging out from user and logging in as root found both panels present but 
blank, with the bottom panel positioned about one-third up the screen from the 
bottom.  Moving each panel to the sides and back to top and bottom again 
restored goodness.

Further screen resizing along with re-logons didn't correct the user screen. 

Finally tracked down gconf-editor (not mentioned in marketing blurb produced 
by "man gnome-panel").  Wandered down 
into /apps/panel/toplevels/bottom_panel/.  Manually changing y location and 
other gefingerpokung had no effect, until clicking on 'auto_hide' which made 
the 6 pixel 'hidden' panel appear.  After verifying hidden panel would 
interact with mouse, cleared the auto_hide checkbox and bottom panel was 
restored fully.


Version-Release number of selected component (if applicable):
gnome-panel-2.10.1-10


How reproducible:
I've tried to reproduce but can't force the blank bar symptom.  When resizing 
to a smaller vertical height the bottom bar doesn't show up immediately.  
Moving the top panel to bottom forces the bottom panel to reappear above it 
(both panels at bottom with "top panel" bottommost!)


Expected results:
After resizing screen to smaller vertical height, I expected bottom_panel 
would be automatically adjusted to new bottom 'y' value.


Additional info:
Note this setup is unusual in that FC4 release is running as guest under 
VMWare 5.0.0 on Windows XP, with vmware-tools installed (so that video card 
is 'vmware')
Comment 1 Mark McLoughlin 2005-06-22 12:30:31 EDT
*** Bug 160900 has been marked as a duplicate of this bug. ***
Comment 2 Mark McLoughlin 2005-06-22 12:36:27 EDT
Reproducer is:

  1) Change resolution in system-config-display
  2) Logout, saving session
  3) Log back in again

Metacity seems to be apply the saved window size to the panel. If I change it 
in ~/.metacity/sessions to:

      <geometry x="0" y="0" width="32" height="25" gravity="NorthWestGravity"/>

then I see this in the metacity log:

SM: Restoring saved window 0x1400004 (Top Panel) to workspace 0
SM: Restoring pos 0,0 size 32 x 25 for 0x1400004 (Top Panel)

Something new and odd happening here ... needs more debugging
Comment 3 Mark McLoughlin 2005-06-22 12:39:03 EDT
Created attachment 115818 [details]
Metacity debug log for reference
Comment 4 Robert Maessen 2005-06-22 12:40:10 EDT
I can rezise the screen resolution to whatever I want the result is alawys the
same the panels are in place but no icons in it.
I even tried to duplicate the other errors, I couldn't do that maybe x86_64 related.
 
Comment 5 Jens Lautenbacher 2005-06-22 15:58:08 EDT
this is not x86_64, happens for me too occasionally for _some_ panels, only when
I set the background. I solved it for one eventually by destroying the panel,
creating a new one - did this more than once, finally ended up with a panel
where I can set the background without it being broken after logout. Note that I
did no resize at all! everything was in 1400x1050.

The "No reaction to right click" only happens once in a while though - most of
the time I can cure the main problem (only background visible, but no icons) by
clicking right, going into properties and doning something that changes the
size, e.g. going from height 24 to 25 and back -> everything works till the next
round.

Removing the background customization makes it work again without any hickup.

Now only my top panel still has the problems, unfortunately I can't tell what
exactly to do to create a new panel that doesn't exhibit that behavior.
Comment 6 Ray Strode [halfline] 2005-06-23 09:56:27 EDT
*** Bug 161416 has been marked as a duplicate of this bug. ***
Comment 7 Marek Stanczyk 2005-06-23 15:22:50 EDT
Created attachment 115893 [details]
my panel setup

I made some screenshots of my panel problem.
panels2.png is how I want to have my panels (I had them like this in FC3
without a problem).
Comment 8 Marek Stanczyk 2005-06-23 15:24:19 EDT
Created attachment 115894 [details]
how the panels actually look after logging in

After logging in, the panels appear like this (the left one doesn't show icons
until panel moved, the right one doesn't stick to the right corner).
Comment 9 Ray Strode [halfline] 2005-06-23 15:58:39 EDT
*** Bug 161510 has been marked as a duplicate of this bug. ***
Comment 10 Robert Maessen 2005-06-24 08:43:41 EDT
Strange thing, after saving the current setup a few times with not changing
anything, the icons and everything in the panels where on it after logging out
and even after a reboot..
Even when I did a log out whitout saving the current setup everything was fine.
Comment 11 Michael Lee Yohe 2005-06-24 11:57:43 EDT
Severity needs to be changed to high.  For people using a FC4 box for remote X -
it's unpredictable what resolution the user will be using depending on the
client he's sitting upon.  Having an inoperable X session is simply bad.
Comment 12 Mark McLoughlin 2005-06-27 09:11:10 EDT
Could everyone confirm whether removing ~/.gnome2/session, logging out and back
in again fixes the problem?
Comment 13 Robert Maessen 2005-06-27 09:40:45 EDT
Although everything started up it had a strange hickup before everything was in
the panelbar, after removing ~/.gnome2/session it had no more hickup and started
up a lot faster.
Comment 14 Mark McLoughlin 2005-06-27 11:31:49 EDT
Okay, this is fixed in rawhide and upstream now:

* Mon Jun 27 2005 Mark McLoughlin <markmc@redhat.com> 2.10.1-11
- Fix "panel doesn't notice new screen size" issue (bug #160439)

I'm leaving the bug open until I do an FC4 update. If people can test out
gnome-panel-2.10.1-11 from rawhide, that would be helpful.
Comment 15 Mark McLoughlin 2005-06-27 12:32:25 EDT
*** Bug 161100 has been marked as a duplicate of this bug. ***
Comment 16 Mark McLoughlin 2005-06-27 12:40:48 EDT
*** Bug 160067 has been marked as a duplicate of this bug. ***
Comment 17 Mark McLoughlin 2005-06-27 12:46:48 EDT
Oh, you'll need to remove ~/.gnome2/session after updating in order to get rid
of the problem fully.
Comment 18 Marek Stanczyk 2005-06-28 03:24:56 EDT
Yes, removing ~/.gnome2/session fixes the problem, until the session is saved again.
However, nothing changed with the right corner panel. Is it a completely
different problem?
Comment 19 Jens Lautenbacher 2005-06-28 04:05:49 EDT
Removing .gnome2/session helps a bit, but as the previous poster said, only
until it's saved again. Orientation is off again after that. I'm not sure if it
also helps with the "no applets visible" thing - I tried a lot of stuff until
finally none of my two panels reacted any more and I could only help by removing
the whole gconf subtree for the panel (and the session file).
Comment 20 Mark McLoughlin 2005-06-28 04:26:59 EDT
You'll need to try the fixed package (gnome-panel-2.10.1-11) from rawhide *and*
remove ~/.gnome2/session after installing it
Comment 21 Jens Lautenbacher 2005-06-28 04:34:06 EDT
2.10.1-11 doesn't seem to be at the fedora development tree :-(
Comment 22 Mark McLoughlin 2005-06-28 05:04:46 EDT
It'll be there in a few hours - the tree gets pushed once a day
Comment 23 Mark McLoughlin 2005-06-28 09:35:54 EDT
Here's the FC4 update:

---------------------------------------------------------------------
Fedora Update Notification
FEDORA-2005-490
2005-06-28
---------------------------------------------------------------------

Product     : Fedora Core 4
Name        : gnome-panel
Version     : 2.10.1                      
Release     : 10.1                  
Summary     : GNOME panel
Description :

The GNOME panel provides the window list, workspace switcher, menus, and other
features for the GNOME desktop.

---------------------------------------------------------------------

* Mon Jun 27 2005 Mark McLoughlin <markmc@redhat.com> 2.10.1-10.1

- Fix "panel doesn't notice new screen size" issue (bug #160439)

---------------------------------------------------------------------
This update can be downloaded from:
  http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/

dc4716f9dbe3fd0977260d3208a4f3a6  SRPMS/gnome-panel-2.10.1-10.1.src.rpm
e670669ba65e3185c19ae93887fda09b  ppc/gnome-panel-2.10.1-10.1.ppc.rpm
6b607d036ee286f5acc621d6f630a279  ppc/gnome-panel-devel-2.10.1-10.1.ppc.rpm
5599ecd393b0f8b5cb9f88908d17b35e 
ppc/debug/gnome-panel-debuginfo-2.10.1-10.1.ppc.rpm
46a93a30b4eabca52ad3db1dd1bd0e17  x86_64/gnome-panel-2.10.1-10.1.x86_64.rpm
d3ee0233e6b7ef0bb34a568545115826  x86_64/gnome-panel-devel-2.10.1-10.1.x86_64.rpm
5f2a516706370ff84252fed1b9fd2675 
x86_64/debug/gnome-panel-debuginfo-2.10.1-10.1.x86_64.rpm
db6cf2837b89346f1959362965ad0a73  i386/gnome-panel-2.10.1-10.1.i386.rpm
3e33ff3eac141ca1f3713647cd504056  i386/gnome-panel-devel-2.10.1-10.1.i386.rpm
65c6a433a65770826a6a8470c7a8f0d9 
i386/debug/gnome-panel-debuginfo-2.10.1-10.1.i386.rpm

This update can also be installed with the Update Agent; you can
launch the Update Agent with the 'up2date' command.  
---------------------------------------------------------------------
Comment 24 Kyle R Maxwell 2005-06-28 11:04:41 EDT
With patch, WFM now.

Note You need to log in before you can comment on or make changes to this bug.