Bug 160466 - cannot manually configure network card
cannot manually configure network card
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 06:21 EDT by grautu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-28 16:21:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description grautu 2005-06-15 06:21:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Here are the results to different typing attempts. 
1) When attempting to type "8" at "IP Address" (no matter which one of the four boxes) then the "IP Address" field disactivates while the field "Activate on boot" highlights instead. 
2) When trying to type "2" at anyone of the four "IP Address" boxes, then the cursor leaves that box and jumps downward to the corresponding "Netmask" box. 
3) When trying to type "8" at "Netmask", then the cursor lifts to the corresponding box of "IP Address" field. 
4) When trying to type "2" at the last box (i.e. the 4th box) of "Netmask", then the "OK" button activates instead of the "Netmask" field. 
5) When trying to type "2" at anyone of the first three boxes of "Netmask", then the "Cancel" button activates instead of the "Netmask" field. 
6) Any other digit-field attempt yields no effect at all.    

Version-Release number of selected component (if applicable):
fedora core 4 (my experience, on June 14-15, 2005)  

How reproducible:
Always

Steps to Reproduce:
The above description is already comprehensive
1.
2.
3.
  

Actual Results:  There is no way to manually configure the ethernet connection

Additional info:

Fedora Core 3 does not produce these strange effects and does allow instead the manual configuration of my ethernet connection.
Comment 1 Chris Lumens 2005-06-15 12:04:21 EDT
When you install, are you getting an IP address via a DHCP server or are you
specifying one manually?  What is the initial state of the "Network Devices"
section and the edit dialog for your network interface?
Comment 2 grautu 2005-06-16 07:33:41 EDT
(In reply to comment #1)
> When you install, are you getting an IP address via a DHCP server or are you
> specifying one manually?  What is the initial state of the "Network Devices"
> section and the edit dialog for your network interface?

I always configure manually my connection. The initial
state looks as follows
___________________________________
 -------------- ------ ----------  |
|Active on Boot|Device|IP/Netmask| |
 -------------- ------ ----------  |
   [checked]     eth0    DHCP      |
                                   |
Hostname                           |
(.) automatically via DHCP         |
( ) manually                       |
                                   |            
IP Address (not active)            |
Netmak     (not active)            |
___________________________________|

Then I proceed as follows
STEP 1: Check (.) manually and uncheck "automatically"
STEP 2: Click on the "Edit" button of the "Network
Devices" section.
Then the "Edit Interface eth0" table opens as follows
_______________________________
[checked] Configure using DHCP |
[checked] Activate on boot     |
_______________________________|
with highlight on "Configure using DHCP" and still
innactive fields for IP and Netmask.
STEP 3: Uncheck "Configure using DHCP"
to the effect that "Configure using DHCP" is still
highlighted (though its box is unchecked) and the
number boxes associated with "IP Address" and
"Netmask" open (white) so as to expect numbers inside.
However, no one of these 6 number boxes is currently
active since the field "Configure using DHCP" is still
highlighted.
STEP 4: Put the mouse arrow inside anyone of the 6
number boxes (of IP and Netmask fields) and then
leftclick there.
The effect is that the field "Configure using DHCP"
disactivates while the chosen number box activates
instead.
STEP 5: Try (with no success) to type any digit inside
the number box, as I have described in the bug report
etc.
Comment 3 Jack Aboutboul 2005-06-27 10:56:38 EDT
Hey, one quick question.  Are you using the keypad to try and enter the numbers
or the numbers over the letter keys?
Comment 4 grautu 2005-06-28 13:11:09 EDT
(In reply to comment #3)
> Hey, one quick question.  Are you using the keypad to try and enter the numbers
> or the numbers over the letter keys?

You posted a kick question, in fact: I was using the number pad!!
Grateful thanks!
Comment 5 Jack Aboutboul 2005-06-28 16:21:00 EDT
Changing status to closed.  Problem is Num Lock was not on.  Thats a different
buy though, depending on user's setup.

Note You need to log in before you can comment on or make changes to this bug.