Bug 160541 - segmentation fault when I run: yum update or rpm
segmentation fault when I run: yum update or rpm
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 13:52 EDT by R. Scott Baer
Modified: 2015-01-04 17:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 09:53:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R. Scott Baer 2005-06-15 13:52:40 EDT
Description of problem:
I get a segmentation fault when I run:  yum update or rpm

Version-Release number of selected component (if applicable):
FC4 (no updates, fresh install

How reproducible:
Every time

Steps to Reproduce:
1. run "yum update" or "rpm -qa"

  
Actual results:
segmentation fault

Expected results:
Should update the box

Additional info:
This is running on a Dell 6300, quad Xeon 550Mhz box, I booted with the single 
and smp kernel
Comment 1 Rahul Sundaram 2005-06-20 16:53:13 EDT

Did you do an upgrade of the distribution through yum? . If so this is not a
supported option. 


Comment 2 R. Scott Baer 2005-06-21 11:19:02 EDT
No, this is a fresh install.  I copied the files from the DVD to a http server,
and did a network based install.  
Comment 3 Seth Vidal 2005-06-21 11:26:52 EDT
run a memory check on the machine.
Comment 4 R. Scott Baer 2005-06-21 22:54:33 EDT
I started the memtest86, I started with the one included, wich is V1.55, though
I am currently running v3.2 that I downloaded from the web.  If there is a
reason to run the one that is inculded with FC4, I will.  

One more data point, I can run FC3 fine on this box, with know know issues.  
Comment 5 Seth Vidal 2005-06-21 22:56:41 EDT
so if you were to install FC3 right now it would run fine?

Could you try that?
Comment 6 R. Scott Baer 2005-06-23 20:18:50 EDT
I have done both, I let the memtest86 test run for about 32 hr, no errors
I have now instaled FC3, and have updated using yum.  No problems.  

As a data point, I have 2 more 6300 dells, both with 4 processors, but they only
have 1 GB of memeory insead of 3.5GB.  I will post an update when I try the
install on these boxes.
Comment 7 Mark A. Schwenk 2005-06-25 08:53:43 EDT
I have this same problem on my VIA EPIA 5000-based system with the VIA Eden
processor. The hardware runs fine under FC3 but I have the segmentation fault
when running rpm or yum under FC4.
Comment 8 R. Scott Baer 2005-06-25 18:34:34 EDT
I have tested this on three different Dell 6300, all with quad PIII Xeon 550Mhz
processors.  All boxes show same symptoms, though of course there is a twist.

If I load a min system install(last selection in package list), the systems
seems to run fine, and yum and rpm will work no problems.
If I do a default install (Workstation), then rpm and yum both seg fault.  

Could someone post a list of rpm's that are installed via a workstation install,
 I'll diff this with what the Custome/min install, and then start installing the
rpms.  
Comment 9 Seth Vidal 2005-06-27 01:44:15 EDT
I think this problem lies deeper than yum or rpm.

Moving it up to kernel - see if it is there.
Comment 10 R. Scott Baer 2005-06-27 09:39:46 EDT
An update, I have two boxes loaded with fc4, both exhibiting the same 
problems.  I have ran the memtest86 test for 48 hours again(still running on 
one box), no failures.

I have noticed that things seemed to be getting worse the longer it runs..  
I could run perl scripts before, now the seg fault as well.
On a mim install, were yum worked right after install.. no longer works.. 
complains that it can't open logfile //var/log/yum.log

When trying to manually read this file will less, I get the following error:
/bin/bash: /usr/bin/lesspinpe.sh: Input/output error

I can read other files fine with less


As a side note, I could not run FC4test1 or test2, because of a kernel problem 
with the megaraid driver (I believe that was the problem...).   you can refer 
to bugzilla # 152293  (  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?
id=152293 )
Comment 11 Dave Jones 2005-06-27 13:53:14 EDT
is there a kernel oops or any other messages in dmesg after a segfault occurs ?
Comment 12 R. Scott Baer 2005-06-29 21:59:26 EDT
No, there are not kernal opps or other related messages that i can find in the
log files, dmesg has no relevent message...
Comment 13 Warren Togami 2005-06-29 22:31:57 EDT
"It segfaults" is not enough information to possibly diagnose this problem,
especially given that it seems not to be a widespread problem.  I ran into this
kind of problem in the past when there was subtle hardware problems.

You can get more information by installing debuginfo and supplying gdb
backtraces of when it crashes.  If it crashes in different places in an
unpredictable way, then it is most likely a hardware problem.  If it crashes in
the same place every time, then it is likely software.

Also keep in mind that memtest86 v3.2 is *older* than memtest86+ v1.55.
Comment 14 Mark A. Schwenk 2005-06-30 08:41:39 EDT
After grabbing the rpm for gdb and the debuginfo rpms for rpm, glibc(i386), and
glibc-common and then installing them with rpm2cpio and cpio, I ran rpm under
gdb to install the sudo package update and received the following:

[root@michigan packages]# gdb rpm
GNU gdb Red Hat Linux (6.3.0.0-1.21rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".

(gdb) run -Fvh sudo*
Starting program: /bin/rpm -Fvh sudo*
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0x2e6000
[Thread debugging using libthread_db enabled]
[New Thread -1208554688 (LWP 16506)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208554688 (LWP 16506)]
0x00423afc in __statvfs_getflags (name=0x8efc418 "/", fstype=61267,
    st=0xbfb80b40) at ../sysdeps/unix/sysv/linux/internal_statvfs.c:115
warning: Source file is more recent than executable.

115                   while ((opt = strsep (&cp, ",")) != NULL)
(gdb) list -
105               /* Find out about the device the current entry is for.  */
106               struct stat64 fsst;
107               if (stat64 (mntbuf.mnt_dir, &fsst) >= 0
108                   && st->st_dev == fsst.st_dev)
109                 {
110                   /* Bingo, we found the entry for the device FD is on.
111                      Now interpret the option string.  */
112                   char *cp = mntbuf.mnt_opts;
113                   char *opt;
114
(gdb) print cp
$1 = 0xbfb80685 "rw"
(gdb) bt
#0  0x00423afc in __statvfs_getflags (name=0x8efc418 "/", fstype=61267,
    st=0xbfb80b40) at ../sysdeps/unix/sysv/linux/internal_statvfs.c:115
#1  0x00424015 in __internal_statvfs64 (name=0x8efc418 "/", buf=0xbfb80c98,
    fsbuf=0xbfb80ba0, st=0xbfb80b40)
    at ../sysdeps/unix/sysv/linux/internal_statvfs.c:211
#2  0x0041dec7 in __statvfs64 (file=0x8efc418 "/", buf=0xbfb80c98)
    at ../sysdeps/unix/sysv/linux/statvfs64.c:68
#3  0x0087165c in rpmtsInitDSI (ts=0x8ef01e8) at rpmts.c:1241
#4  0x008770f2 in rpmtsRun (ts=0x8ef01e8, okProbs=0x0, ignoreSet=3216508549)
    at transaction.c:1474
#5  0x00865b66 in rpmInstall (ts=0x8ef01e8, ia=0x89c4e0, fileArgv=0x8ed9c70)
    at rpminstall.c:691
#6  0x0804bb83 in main (argc=3, argv=0xbfb81284) at ./rpmqv.c:786
#7  0x00380dfb in __libc_start_main (main=0x804aa9c <main>, argc=3,
    ubp_av=0xbfb81284, init=0x8057b04 <__libc_csu_init>,
    fini=0x8057b54 <__libc_csu_fini>, rtld_fini=0x35ccd0 <_dl_fini>,
    stack_end=0xbfb8127c) at ../sysdeps/generic/libc-start.c:228
#8  0x0804a9a1 in _start ()
(gdb)

I don't have time to poke around with this at the moment, but will be back to
debugging it later today. Let me know if anyone has suggestions.
Comment 15 R. Scott Baer 2005-06-30 14:45:47 EDT
I'm not experianced with gdb, or debugging at this level for that matter... 
thoguh I'm willing to do anything that is requested of me.  
I currently have fc4 installed as a server with min packages selected during 
install, I have now added gdb.

With this type of install, the onlything that is currently failling is perl..  
though I have not done a lot of digging with this install yet.  yum and rpm 
seem to work fine.

On the same box, if I reinstall, and select a Workstation type of install...  
then the rpm and yum result in segmentation faults as well.  

In ether case, there is no message in /var/log/messages or dmesg.   

If you can give spicific commands for me to run, and what install type you 
want.. I will get the resualts that you are looking for.  If someone on the CC 
list would like access to this box, I can make that happen as well.  Just 
contact me outside of bugzilla.
Comment 16 Warren Togami 2005-06-30 15:34:02 EDT
Mark does it crash at the same place every time?
Comment 17 R. Scott Baer 2005-07-05 08:18:36 EDT
Here is the output of:

strace -o output.txt perl

execve("/usr/bin/perl", ["perl"], [/* 21 vars */]) = 0
brk(0)                                  = 0x81c7000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/i686/libperl.so",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/libperl.so",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/i686/libperl.so",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\240W5\000"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1349760, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7f86000
old_mmap(0x334000, 1359360, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3,
0) = 0x334000
old_mmap(0x473000, 45056, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x13e000) = 0x473000
old_mmap(0x47e000, 7680, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x47e000
close(3)                                = 0
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/i686/libresolv.so.2",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/libresolv.so.2",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/i686/libresolv.so.2",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libresolv.so.2",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=45886, ...}) = 0
old_mmap(NULL, 45886, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb7f7a000
close(3)                                = 0
open("/lib/libresolv.so.2", O_RDONLY)   = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\320S\21"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=76248, ...}) = 0
old_mmap(0x113000, 75880, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0)
= 0x113000
old_mmap(0x122000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0xe000) = 0x122000
old_mmap(0x124000, 6248, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x124000
close(3)                                = 0
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/i686/libnsl.so.1",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/libnsl.so.1",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/i686/libnsl.so.1",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libnsl.so.1", O_RDONLY)
= -1 ENOENT (No such file or directory)
open("/lib/libnsl.so.1", O_RDONLY)      = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0p5+\003"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=96960, ...}) = 0
old_mmap(0x32b0000, 88064, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0)
= 0x32b0000
old_mmap(0x32c2000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x11000) = 0x32c2000
old_mmap(0x32c4000, 6144, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x32c4000
close(3)                                = 0
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/i686/libdl.so.2",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/libdl.so.2",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/i686/libdl.so.2",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libdl.so.2", O_RDONLY) =
-1 ENOENT (No such file or directory)
open("/lib/libdl.so.2", O_RDONLY)       = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0\374o"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=16244, ...}) = 0
old_mmap(0x6ff000, 12404, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0)
= 0x6ff000
old_mmap(0x701000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1000) = 0x701000
close(3)                                = 0
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/i686/libm.so.6",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/libm.so.6",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/i686/libm.so.6",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libm.so.6", O_RDONLY) =
-1 ENOENT (No such file or directory)
open("/lib/libm.so.6", O_RDONLY)        = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20\303"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=196676, ...}) = 0
old_mmap(0x6d9000, 143520, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0)
= 0x6d9000
old_mmap(0x6fb000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x21000) = 0x6fb000
close(3)                                = 0
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/i686/libcrypt.so.1",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/libcrypt.so.1",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/i686/libcrypt.so.1",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libcrypt.so.1",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/libcrypt.so.1", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\360\207"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=27660, ...}) = 0
old_mmap(0x32c8000, 184604, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3,
0) = 0x32c8000
old_mmap(0x32cd000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x4000) = 0x32cd000
old_mmap(0x32cf000, 155932, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x32cf000
close(3)                                = 0
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/i686/libutil.so.1",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/libutil.so.1",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/i686/libutil.so.1",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libutil.so.1", O_RDONLY)
= -1 ENOENT (No such file or directory)
open("/lib/libutil.so.1", O_RDONLY)     = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\260\354"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=15080, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7f79000
old_mmap(0x32e000, 12432, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0)
= 0x32e000
old_mmap(0x330000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1000) = 0x330000
close(3)                                = 0
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/i686/libpthread.so.0",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/libpthread.so.0",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/i686/libpthread.so.0",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libpthread.so.0",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/libpthread.so.0", O_RDONLY)  = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\204\367"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=101600, ...}) = 0
old_mmap(0x95b000, 70084, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0)
= 0x95b000
old_mmap(0x969000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0xd000) = 0x969000
old_mmap(0x96b000, 4548, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x96b000
close(3)                                = 0
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/i686/libc.so.6",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/tls/libc.so.6",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/i686/libc.so.6",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libc.so.6", O_RDONLY) =
-1 ENOENT (No such file or directory)
open("/lib/libc.so.6", O_RDONLY)        = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\n\37\\"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1489572, ...}) = 0
old_mmap(0x5ad000, 1219548, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3,
0) = 0x5ad000
old_mmap(0x6d1000, 16384, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x124000) = 0x6d1000
old_mmap(0x6d5000, 7132, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x6d5000
close(3)                                = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7f78000
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb7f77000
set_thread_area({entry_number:-1 -> 6, base_addr:0xb7f78ba0, limit:1048575,
seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0,
useable:1}) = 0
mprotect(0x122000, 4096, PROT_READ)     = 0
mprotect(0x32c2000, 4096, PROT_READ)    = 0
mprotect(0x701000, 4096, PROT_READ)     = 0
mprotect(0x6fb000, 4096, PROT_READ)     = 0
mprotect(0x32cd000, 4096, PROT_READ)    = 0
mprotect(0x330000, 4096, PROT_READ)     = 0
mprotect(0x969000, 4096, PROT_READ)     = 0
mprotect(0x6d1000, 8192, PROT_READ)     = 0
mprotect(0x5a9000, 4096, PROT_READ)     = 0
munmap(0xb7f7a000, 45886)               = 0
set_tid_address(0xb7f78be8)             = 4936
rt_sigaction(SIGRTMIN, {0x95f340, [], SA_SIGINFO}, NULL, 8) = 0
rt_sigaction(SIGRT_1, {0x95f3a8, [], SA_RESTART|SA_SIGINFO}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [RTMIN RT_1], NULL, 8) = 0
getrlimit(RLIMIT_STACK, {rlim_cur=10240*1024, rlim_max=RLIM_INFINITY}) = 0
_sysctl({{CTL_KERN, KERN_VERSION}, 2, 0xbfe84180, 34, (nil), 0}) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

And the out put of:

ldd /usr/bin/perl

	linux-gate.so.1 =>  (0x0027e000)
	libperl.so => /usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE/libperl.so
(0x00334000)
	libresolv.so.2 => /lib/libresolv.so.2 (0x00113000)
	libnsl.so.1 => /lib/libnsl.so.1 (0x032b0000)
	libdl.so.2 => /lib/libdl.so.2 (0x006ff000)
	libm.so.6 => /lib/libm.so.6 (0x006d9000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x032c8000)
	libutil.so.1 => /lib/libutil.so.1 (0x0032e000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x0095b000)
	libc.so.6 => /lib/libc.so.6 (0x005ad000)
	/lib/ld-linux.so.2 (0x0058f000)

Comment 18 R. Scott Baer 2005-07-05 11:28:27 EDT
Over the weekend, while looking at the sytem, I did notice the following error 
messgae that I must have missed before in the dmesg output:

mtrr: Intel 450NX MMC detected. Write-combining disabled.
mtrr: your processor doen't support wirte-combining
mtrr: Intel 450NX MMC detected. Write-combining disabled.
mtrr: your processor doen't support wirte-combining
Comment 19 Dave Jones 2005-07-07 16:59:49 EDT
the mtrr message is nothing to worry about, its just complaining about a
particular defect on that chipset that means we can't use write-combining.

reiterating comment #16 - do things crash in the same place every time ?
Comment 20 R. Scott Baer 2005-07-07 22:22:53 EDT
sorry, didn't reply to that one. I thought you wanted info from Mark.   
To answer your question yes.. kind of.. it depends on what type of install I do.

I currently have a "Server" style install with "min" package selection, and it
crashes every time I try to run perl.

If I have it installed as "Workstation" with the default packages, it crashes
every time I try to run yum, rpm and perl.

To address an earlier comment about the memtest86 3.6 test I ran.. I have now
ran the memtest86+ 1.6 ver for 24hrs, no issues.(only on 1 of the three boxes)
Comment 21 Dave Jones 2005-07-07 22:47:26 EDT
some things to try..

boot with exec-shield=0 if that makes no difference, also try vdso=0
also try echo 0 > /proc/sys/kernel/randomize_va_space
Comment 22 R. Scott Baer 2005-07-07 23:34:00 EDT
I tried both boot options, independently and together
It still crahes

I also tried the echo 0 > /proc/sys/kernel/randomize_va_space
It also, still crahes

I did verify that randomize_va_space was set to 0 after I ran the above 
command, it was set to 1 before.
Comment 23 Dave Jones 2005-07-15 17:44:09 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 24 R. Scott Baer 2005-07-15 18:32:05 EDT
This has been duplicated on 2.6.12-1.1398_FC4
Comment 25 R. Scott Baer 2005-07-25 22:05:14 EDT
Is there anything else I can provied to help troble shoot this issue ?  I can
provied access to my box if needed.

Scott
Comment 26 Dave Jones 2005-09-30 03:16:32 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 27 Dave Jones 2005-11-10 15:25:13 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 28 Dave Jones 2006-02-03 02:24:35 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 29 John Thacker 2006-05-04 09:53:47 EDT
Closing per previous comment.

Note You need to log in before you can comment on or make changes to this bug.