Bug 160558 - No easy way to install xfce from extras using yum?
No easy way to install xfce from extras using yum?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xfdesktop (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 15:53 EDT by Basil L. Copeland Jr
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-30 19:26:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Basil L. Copeland Jr 2005-06-15 15:53:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
With the move of xfce out of base to extras, how is one supposed to install it with yum?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  See "Additional Information" below
2.
3.
  

Additional info:

Copied from a post to the fedora mail list:

Well, I don't want to be submitting bug reports if the problem is me!

I actually just finished getting it installed -- finally -- but in
such an ad hoc fashion that I'm loath to try it again unless there is
really no better way.  And if there is no better way, there should be
one!

To the extent that I remember what I did, it went something like this
(ignoring false starts and detours that led nowhere):

1) "yum install xfce-mcs-manager-devel" found 14 packages (including
those needed for dependencies) and installed them.

2) "yum install xfce*" then found 17 packages to install, but kept
failing because many of the packages were unsigned.  I tried
"gpgcheck=0" in all the .repos but that made no difference.

3) went to http://fedoraproject.org/extras/4/i386/repodata/repoview/X.group.html
and started installing the unsigned rpms one by one using the package
manager.

4) installed some others that way from the same source.

5) at some point decided to try "yum install xfce*" again and was at
that point down to 9 packages (I think, maybe less) and yum went all
the way.
Comment 1 Kevin Fenzi 2005-06-15 17:12:47 EDT
Yeah, I have run into this issue myself. 
There are 23 Xfce packages out there. They don't even all have '*xfce*' in the
package names, so doing 'yum install '*xfce*'' won't get them all. 

What we probibly need to do is see about adding a "Xfce" group to comps with all
the packages in it, so then it would be possible to do: 'yum groupinstall Xfce'
and have yum install them all. 

I will look at making a comps.xml patch and see about creating a new bug against
comps to add that group. (Unless someone has a better solution). 
Comment 2 Michael Schwendt 2005-06-16 09:12:38 EDT
One can argue whether it would be "better", but one day I'd really like to see
us picking up the notion of a "meta package". Xfce is a scenario in which "yum
install xfce" would make sense and install an "xfce" package which just pulls in
the required dependencies. It's not a concept which competes with "comps" and
groupinstall. It can be more fine-grained, e.g. "yum install anjuta-full" to
install the full set of _optional_ dependencies for the Anjuta IDE.
Comment 3 Joshua Jensen 2005-06-21 15:11:00 EDT
That is too much re-invention IMHO.

yum -y groupinstall xfce

It is simple, and is already well-defined.
Comment 4 Kevin Fenzi 2005-06-21 15:27:43 EDT
Re Comment #3: 

well, that would be fine, except the fedora-extras repository isn't setup to use
the comps.xml file, so groupinstall doesn't work. 

yum groupinstall xfce-desktop
Setting up Group Process
Setting up repositories
updates-released          100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
freshrpms                 100% |=========================|  951 B    00:00
Error: failure: repodata/comps.xml from extras: [Errno 256] No more mirrors to try.

See: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160715

If that gets fixed that would solve this issue. :) 
Comment 5 Kevin Fenzi 2005-06-22 14:17:00 EDT
It looks like as of today, the fedora-extras groups are working...

Can the orig reporter (or anyone else) try: 

yum -y groupinstall xfce-desktop 
or
yum -y groupinstall XFCE

and report if it works to pull in and install all the needed Xfce packages?
Comment 6 Patrick Jordan 2005-06-26 22:27:53 EDT
I'll confirm it works. yum groupinstall XFCE pulled in 15 packages, and I seem
to have a full xfce desktop.
Comment 7 Kevin Fenzi 2005-06-30 19:26:29 EDT
I have also tested on several systems here and 'yum groupinstall XFCE' works
fine to install all the needed non-devel rpms for a Xfce desktop. 

I am going to close this bug, if the orig reporter still sees the issue, or
doesn't like this fix, please re-open the bug. 


Note You need to log in before you can comment on or make changes to this bug.