Bug 160571 - allow use of consolehelper
allow use of consolehelper
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 16:40 EDT by Rob Kooper
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: vpnc-0.3.3-14.fc7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 17:27:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
allow use of consolehelper (2.44 KB, patch)
2005-06-15 16:40 EDT, Rob Kooper
no flags Details | Diff
patch to fix the new iptable format (from vpnc mailinglist) (461 bytes, patch)
2005-06-15 16:43 EDT, Rob Kooper
no flags Details | Diff

  None (edit)
Description Rob Kooper 2005-06-15 16:40:33 EDT
Description of problem:
use consolehelper to allow non-root people to execute vpnc(-disconnect)

Version-Release number of selected component (if applicable):
 0.3.3-2

Actual results:
could not bind to port 500

Expected results:
ask for root password since we know it wants to bind to port 500

Additional info:
attached files also contains a patch that will fix the problem reported in 160364
Comment 1 Rob Kooper 2005-06-15 16:40:33 EDT
Created attachment 115508 [details]
allow use of consolehelper
Comment 2 Rob Kooper 2005-06-15 16:43:13 EDT
Created attachment 115509 [details]
patch to fix the new iptable format (from vpnc mailinglist)

This patch was on the VPNC mailing list:
http://lists.unix-ag.uni-kl.de/pipermail/vpnc-devel/2005-May/000658.html
Comment 3 Tomas Mraz 2007-01-17 17:27:12 EST
Implemented consolehelper support as a subpackage vpnc-consoleuser.

Also modified pam config so no root password is needed for running vpnc when the
user is on console.

Note You need to log in before you can comment on or make changes to this bug.