Bug 160584 - Installer crashed when setting up partitions "pvcreate failed"
Installer crashed when setting up partitions "pvcreate failed"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 18:03 EDT by Michael Leuty
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-24 15:02:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump produced when anaconda crashed. (764.48 KB, text/plain)
2005-06-15 18:06 EDT, Michael Leuty
no flags Details

  None (edit)
Description Michael Leuty 2005-06-15 18:03:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I have two Maxtor 40Gb hard drives on IDE-0. I was trying to install FC4 on /dev/hdb. When I did a fresh install on top of an FC3 installation on /dev/hdb (using the default Logical Volume set up by FC3) there was no problem. I then found that when /dev/hdb contains a default setup of SUSE 9.3 or Ubuntu 5.04 using normal partions (one ext3 partition for / and one swap partition), anaconda crashes at the point where it tries to write the new partition information to /dev/hdb. Dump file attached. This happened in both graphical and text setup. The workround was to reinstall FC3 on /dev/hdb and then install FC4 on top of it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install SUSE 9.3 or Ubuntu 5.04 using all of /dev/hdb.
2. Run FC4 install, instructing anaconda to use all of /dev/hdb for the installation. Accept default proposal involving Logical Volumes.
3. (I also told it to mount /dev/hda1 as /mirror.)
4. Reach end of user-input part of anaconda, note warning that all information on /dev/hdb partitions will be lost, tell anaconda to proceed.
  

Actual Results:  Anaconda crashed (dump file attached).

Expected Results:  Partitions and Logical Volumes should be set up.

Additional info:

Two Maxtor 40Gb hard drives on first IDE channel.
Comment 1 Michael Leuty 2005-06-15 18:06:33 EDT
Created attachment 115513 [details]
Dump produced when anaconda crashed.
Comment 2 pinter 2005-06-16 11:29:40 EDT
Same on a Dell C600 with 20GB Toshiba drive, installed overtop Ubuntu 5.04 with
Custom settings and taking most all defaults excepting goddam SELINUX (selected
disabled).

Tail of Exception Occurred dialog reads:
.
.
.
File "/usr/lib/anaconda/packages.py", line 582, in turnOnFilesystems
 thefsset.creatLogicalVolumes(instPath)
File "/usr/lib/anaconda/fsset.py", line 1472, in createLogicalVolumes
 entry.device.setupDevice(chroot)
File "/usr/lib/anaconda/fsset.py", line 2066, in setupDevice
 raise SystemError, "pvcreate failed for %s" % (volume,)
SystemError: pvcreate failed for <fsset.PartitionDevice instance at 0xb7b2396c>

Is there any suggested workaround? I'm totally hosed here now (natch).
Comment 3 Michael Leuty 2005-06-16 11:36:31 EDT
(In reply to comment #2)
> Is there any suggested workaround? I'm totally hosed here now (natch).

Install FC3 on the hard disk (select "minimum" install to save time). Then you
should be able to install FC4 on top (clean install).
Comment 4 pinter 2005-06-16 11:57:08 EDT
Yeah, FC3 was punted last year and most releases of FC4Tx won't boot on C600
laptops due to maximum bogosity being achieved in ISOLINUX (see archives).

Installing in 'linux text' mode seems to be working happily enuf.

Onward!
Comment 5 Jeremy Katz 2005-06-16 16:22:43 EDT
How was hdb previously partitioned?
Comment 6 Michael Leuty 2005-06-16 17:04:35 EDT
(In reply to comment #5)
> How was hdb previously partitioned?

I can't remember the exact details, I'm afraid. I accepted the defaults from
SUSE and Ubuntu to use the whole of /dev/hdb. In each case there were just two
partitions, a swap of about 1Gb and a large "/" occupying the rest of the drive.
(Formatted as Reiser with SUSE and ext3 with Ubuntu.)
Comment 7 Chris Lumens 2005-06-24 15:02:50 EDT
Should be fixed in Rawhide by patch from bug 160693.

Note You need to log in before you can comment on or make changes to this bug.