Bug 160639 - Installer aborts with AttributeError: 'module' object has no attribute 'formatdate'
Installer aborts with AttributeError: 'module' object has no attribute 'forma...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-16 04:49 EDT by Terrence Sue-Ako
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-16 18:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terrence Sue-Ako 2005-06-16 04:49:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
An unhandled exception occurred during an installation update.  The following message appears after the 'Reading package information...' screen:

AttributeError: 'module' object has no attribute 'formatdate'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot with FC4 install DVD and enter 'linux text' to start install.
2. Skip mediacheck (dvd was already media checked on this laptop and
another PC)
3. Select English then US for language, keyboard.
4. Select to install by upgrading current FC3 system on laptop (Fedora
Core 3  (/dev/VolGroup00/LogVol01))
5. Select 'Update boot loader configuration'
6. 'Reading package information...' appears
7. Generic blue screen with 'Welcome to Fedora Core' on line 1 and
'<Tab>/<Alt-Tab>...' on bottom line appears.  dvd drive makes
chuckling (head movement) sounds for a minute then above message
appears.

Actual Results:  Error message appeared and installation aborted.

Expected Results:  No message and installation update continued

Additional info:

notes:
1. both 'linux text' and 'linux text acpi=off' were tried.
2. both graphical and text (hit enter or enter 'linux text') tried.

error message:
An unhandled exception has occurred.  This is most likely a bug.
Please copy the full text of this exception and file a detailed bug
report against anaconda at http://bugzilla.redhat.com/bugzilla/

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1160, in ?
    intf.run(id,dispatch)
  File "/usr/lib/anaconda/text.py", line 496, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc=apply(func,self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 172, in readPackages
    grpset=method.readComps(hdrlist)
  File "/usr/lib/anaconda/installmethod.py", line 65, in readComps
    return self.readCompsViaMethod(hdlist)
  File "/usr/lib/anaconda/image.py", line 106, in readCompsViaMethod
    return groupSetFromCompsFile(fname,hdlist)
  File "/usr/lib/anaconda/hdrlist.py", line 923, in
  groupSetFromCompsFile
    file=grabber.urlopen(filename,retry=5)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
  444, in urlopen
    return default_grabber.urlopen(url,**kwargs)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
  575, in urlopen
    return self._retry(opts,retryfunc,url)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
  547, in _retry
    return apply(func,(opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
  574, in retryfunc
    return URLGrabbberFileObject(url, filename=None, opts=opts)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
  727, in __init__
    self._do_open()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
  794, in _do_open
    fo,hdr=self._make_request(req,opener)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
  885, in _make_request
    fo=opener.open(req)
  File "/usr/lib/python2.4/urllib2.py", line 358, in open
    response=self._open(req,data)
  File "/usr/lib/python2.4/urllib2.py", line 376, in _open
    '_open',req)
  File "/usr/lib/python2.4/urllib2.py", line 337, in _call_chain
    result=-func(*args)
  File "/usr/lib/python2.4/urllib2.py", line 1119, in file_open
    return self.open_local_file(req)
  File "/usr/lib/python2.4/urllib2.py", line 1137, in open_local_file
    modified=email.Utils.formatdate(stats.st_mtime,usegmt=True)
AttributeError: 'module' object has no attribute 'formatdate'
Comment 1 Terrence Sue-Ako 2005-06-16 04:51:53 EDT
Install was attempted on a Dell Latitude CPiR with:
 Pentium II-400 MHz
 256mb memory
 NeoMagic 2360 video/audio controller
 60064 mb hard drive
 dual boot with
  Windows 2000 on first partition
  FC3 /boot using GRUB on second partition
  linux lvm on third partition
Comment 2 Jeremy Katz 2005-06-16 16:26:43 EDT
Can you provide the complete traceback you received?
Comment 3 Terrence Sue-Ako 2005-06-16 16:56:47 EDT
The error message above is the complete text of what was displayed.  It may
contain typos, as I copied it by reading the message and typing it into my other
computer.

I have to confess that I am a bit perplexed now.  Although I was able to
duplicate the error literally 5 times running last night, I cannot do that now.
 I get a similar but different message.

Unless you have any other comment, I would like to close the bug for now and
await further investigation.  I suspect that there may be some hardware related
problem because I have not changed anything as far as I can tell.
Comment 4 Terrence Sue-Ako 2005-06-16 18:40:48 EDT
I am closing the bug report.  Error warning has now changed (3 straight times)
to 'OSError: [Errno 8] Exec format error'.  <alt-f4> shows several entries
indicating medium error.  I believe I have a hardware problem.

Note You need to log in before you can comment on or make changes to this bug.