Bug 1606839 - snownews: FTBFS in Fedora ≥ 29: conversions.c:621:13: error: storage size of 'mdctx' isn't known
Summary: snownews: FTBFS in Fedora ≥ 29: conversions.c:621:13: error: storage size of ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: snownews
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1676013 (view as bug list)
Depends On:
Blocks: F29FTBFS F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-07-20 21:52 UTC by Mohan Boddu
Modified: 2019-07-18 20:32 UTC (History)
3 users (show)

Fixed In Version: snownews-1.5.12-21.fc31 snownews-1.5.12-21.fc30 snownews-1.5.12-20.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-18 17:56:00 UTC


Attachments (Terms of Use)
build.log (10.43 KB, text/plain)
2018-07-20 21:52 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 21:53 UTC, Mohan Boddu
no flags Details
state.log (631 bytes, text/plain)
2018-07-20 21:53 UTC, Mohan Boddu
no flags Details


Links
System ID Priority Status Summary Last Updated
Github kouya snownews issues 4 None None None 2019-07-09 13:07:52 UTC

Description Mohan Boddu 2018-07-20 21:52:50 UTC
snownews failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28397711


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix snownews at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
snownews will be orphaned. Before branching of Fedora 30,
snownews will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 21:52:58 UTC
Created attachment 1469391 [details]
build.log

Comment 2 Mohan Boddu 2018-07-20 21:53:02 UTC
Created attachment 1469392 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 21:53:05 UTC
Created attachment 1469393 [details]
state.log

Comment 4 Jan Kurik 2018-08-14 08:45:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Petr Pisar 2019-07-09 12:36:17 UTC
gcc -Wall -Wno-format-y2k -O2 -DLOCALEPATH="\"/usr/share/locale\"" -DOS=\"Linux\" -I/usr/i
nclude/libxml2 -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_G
LIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/
lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -fas
ynchronous-unwind-tables -fstack-clash-protection -fPIE -DUTF_8    -c -o conversions.o con
versions.c
[...]
conversions.c: In function 'genItemHash':
conversions.c:621:13: error: storage size of 'mdctx' isn't known
  EVP_MD_CTX mdctx;
             ^~~~~

The code seems in need of porting to OpenSSL 1.1.1.

Comment 6 Petr Pisar 2019-07-09 12:38:51 UTC
*** Bug 1676013 has been marked as a duplicate of this bug. ***

Comment 7 Petr Pisar 2019-07-09 12:44:07 UTC
Upstream moved to <https://github.com/kouya/snownews>. 1.5.13 release changed license to GPLv3 and 1.6.10 removed a dependency on OpenSSL.

Comment 8 Petr Pisar 2019-07-09 13:16:44 UTC
I "fixed" by build-required old OpenSSL. I recommend upgrading this package in Rawhide to fix this issue properly. I could back port to upstream fix due to a change in the license.

Comment 9 Fedora Update System 2019-07-09 13:23:57 UTC
FEDORA-2019-575260aad9 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-575260aad9

Comment 10 Fedora Update System 2019-07-09 13:30:35 UTC
FEDORA-2019-b6db528251 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b6db528251

Comment 11 Fedora Update System 2019-07-10 00:37:34 UTC
snownews-1.5.12-21.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-575260aad9

Comment 12 Fedora Update System 2019-07-10 02:41:27 UTC
snownews-1.5.12-20.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b6db528251

Comment 13 Fedora Update System 2019-07-18 17:56:00 UTC
snownews-1.5.12-21.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-07-18 20:32:43 UTC
snownews-1.5.12-20.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.