Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 160690 - I'm not able to change MAC address
I'm not able to change MAC address
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 160684 160685 160686 160688 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-16 13:32 EDT by Dawid Gajownik
Modified: 2014-03-16 22:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-17 03:34:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifcfg-eth0 file (164 bytes, text/plain)
2005-06-17 02:40 EDT, Dawid Gajownik
no flags Details

  None (edit)
Description Bill Nottingham 2005-06-16 15:19:00 EDT
*** Bug 160684 has been marked as a duplicate of this bug. ***
Comment 1 Bill Nottingham 2005-06-16 15:19:06 EDT
*** Bug 160685 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2005-06-16 15:19:22 EDT
*** Bug 160686 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2005-06-16 15:19:24 EDT
*** Bug 160688 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2005-06-16 15:20:14 EDT
Closing, no info in bug report.
Comment 5 Dawid Gajownik 2005-06-16 16:51:50 EDT
I'm really sorry for that spam :( When I was trying to send bugzilla report, I
always got page with bugzilla internal error 500 or something like this (I can
make a screenshot if you like).

Here's the proper bug report:
I'm not able to change MAC address

initscripts-8.11.1-1

I'm not able to change MAC addres of my ethernet card via
/etc/sysconfig/network-scripts/ifcfg-eth0 file.

I've changed:

MACADDR=00:40:F4:31:84:93

to

HWADDR=00:40:F4:31:84:94

and then typed:

[root@X audit]# LANG=C ifdown eth0
Urządzenie eth0 posiada adres MAC inny niż spodziewany, ignoruję.
[root@X audit]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:40:F4:31:84:93
          inet addr:192.168.0.7  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8597 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6930 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:8219521 (7.8 MiB)  TX bytes:764360 (746.4 KiB)
          Interrupt:11 Base address:0xd000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1329 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1329 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:39290 (38.3 KiB)  TX bytes:39290 (38.3 KiB)

[root@X audit]#

which means "Device eth0 has different MAC address than expected, ignoring."

BTW I don't know why, but LANG=C does not work. It still shows messages using
system locale.

As you can see, eth0 is up :/ I also tried to modifying ifcfg-eth0 after "ifdown
eth0". "ifup eth0" works, but network card still have the same MAC addres.

Above steps worked without a glitch in FC3.
Comment 6 Bill Nottingham 2005-06-16 16:58:47 EDT
Please attach your ifcfg file.
Comment 7 Dawid Gajownik 2005-06-17 02:40:33 EDT
Created attachment 115594 [details]
ifcfg-eth0 file
Comment 8 Dawid Gajownik 2005-06-17 03:34:11 EDT
Oh, don't bother. In previous Fedora's versions there was always HWADDR entry
and I had to change it to MACADDR.In FC4 there is MACADDR by default. I didn't
remember which one is correct, so I replaced it with HWADDR.

I'm really sorry that I waste your precious time.

Note You need to log in before you can comment on or make changes to this bug.