Bug 16070 - firewalld doesn't respond to transient interfaces
Summary: firewalld doesn't respond to transient interfaces
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-12 16:29 UTC by John William
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John William 2000-08-12 16:29:30 UTC
I am running RH6.2, with linuxconf 1.19r2. The machine has two ethernet 
interfaces, eth0 on the local network and eth1 connected to the Internet. 
I am using the "firewalld" firewall daemon to manage the connection 
through eth1. The machine also has a modem and can use ppp0 to connect to 
the Internet.

When the firewall daemon was started, eth1 was up and ppp0 was down. 
firewalld created a reasonable set of rules (verified with /sbin/ipchains -
L -v). After some time, eth1 went down. I shut down eth1 (/sbin/ifconfig 
eth1 down) and started ppp0 (/sbin/ifconfig ppp0 up). The linuxconf 
firewall daemon was still running, but never changed the rules. When I 
went into linuxconf, to the properties page for the firewall daemon, 
everything looked ok, and when linuxconf restarted the daemon, it created 
a good set of rules for that configuration. However, after switching 
interfaces back, firewalld again didn't recognize the change.

Comment 1 Brent Fox 2002-06-05 16:11:12 UTC
Closing because we don't ship linuxconf anymore

Comment 2 Red Hat Bugzilla 2006-02-21 18:47:44 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.