Bug 160822 - SiS900 based network card does not function on SiS M650 based laptop.
SiS900 based network card does not function on SiS M650 based laptop.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-17 12:14 EDT by Sven Groot
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 11:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport from my laptop with the sis900 card. (283.24 KB, application/octet-stream)
2005-07-15 19:46 EDT, Robert Middleswarth
no flags Details

  None (edit)
Description Sven Groot 2005-06-17 12:14:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The network card in my Asus A2500H laptop does not function correctly. The card is recognised, mii-tool and mii-diag correctly recognise if there is a link and report no errors, but no data is received. When it attempts to get an IP address, this fails. Ethereal shows the DHCP packets being sent, but there is no incoming traffic whatsoever.

This problem first appeared in FC3 with kernel release 2.6.10, and still exists in FC4. In FC3 with kernel 2.6.9, the network works as expected. Other network interfaces such as my wireless USB stick do work, the problem is limited to this interface.

The laptop uses a SiSM650 chipset, and the network card is based a SiS900.

I tried running Knoppix 3.9, which also uses the 2.6.11 kernel version, and the network card operates properly there, confirming that this is a bug in Fedora Core, and not in the core Linux kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.11

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 on an Asus A2500H laptop.
2. Attempt to connect to a network using the integrated network card.
  

Actual Results:  Link was detected, but no packets were received.

Expected Results:  I expected the network to function normally.

Additional info:
Comment 1 John W. Linville 2005-07-08 10:27:40 EDT
Very strange...hard to say why Knoppix wouldn't have similar problems...I'll 
have to research... 
 
In the meantime, please attach the output of running "sysreport"...thanks! 
Comment 2 Robert Middleswarth 2005-07-14 16:38:26 EDT
I want to add a me to this.  I have a acer aspire laptop with a sis900 onboard
nic and it does the what he is reporting.  I confirmed it works fine under
Debian Stabel with the 2.6 Kernel.  Kubuntv 5.04, knoppix 3.9(kernel 2.6.11). 
Alought I saw it was a fresh install of FC3 with includes kernel 2.6.9 as well
as 2.6.11 thought 2.6.12 1390.  It sees a Nic gets a Mac address.  Not sure what
I can do to help.

Thanks
Robert
Comment 3 Dave Jones 2005-07-15 17:17:24 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 4 Robert Middleswarth 2005-07-15 19:46:16 EDT
Created attachment 116829 [details]
sysreport from my laptop with the sis900 card.

sysreport as requested but the bug report.
Comment 5 Robert Middleswarth 2005-07-16 08:38:02 EDT
Were did my post go?  I upgraded to 1398 and confirmed the problem is still
there.  The above attachement id=116829 was done after the upgrade.

Robert
Comment 6 Ignacio Toledo Carcamo 2005-07-16 18:31:29 EDT
I am using an Aspire 3000, with FC4. I have the same problem when traying to
connect to my cable modem. DHCP times out.
Just something that may help: if you add acpi=ht to the load kernel parameters
in the boot, then you can get connected trough dhcp.
Comment 7 Robert Middleswarth 2005-07-17 18:05:15 EDT
Strange I had tried acpi=off and didn't work at all but acpi=ht worked.  Nic
Working now only thing left it the broadcom 4318 Wireless card but less import
as only my work has wireless at this time.

Robert
Comment 8 Ignacio Toledo Carcamo 2005-07-17 19:42:30 EDT
But the thing is that the bug is still there. I dont think that the final
solution is to use the acpi=ht option for ever. Some people said it could mess
up the computer... whatever that means
Ignacio
Comment 9 Doncho N. Gunchev 2005-07-29 07:44:39 EDT
    I have Acer Aspire 3002NLC with sis900 and the card has the same symptoms
with FC4 and kernel 2.6.12-1.1398_FC4. acpi=ht works, but the machine will not
poweroff so I tried acpi=noirq and this time it powered off fine and the NIC is
working.
    I think the problem is maybe their broken ACPI code in the BIOS - see
http://www.whoopy.it/linux/ACPI_problem_linux_resolved.html ,
http://www.whoopy.it/linux/ACPI_problem_linux.html or search google for "aspire
acpi fix".
    I also want to note that removing sis900 (rmmod) without acpi=whatever
generates kernel oops, mii.ko remains loaded and reports that is being used by
sis900(which is not shown by lsmod).
Comment 10 John W. Linville 2005-08-03 11:23:56 EDT
Does "acpi=noirq" (or "acpi=ht") work for everyone?  If not, please reopen 
with an explanation. 
 
Otherwise, I'm going to close this as WONTFIX due to the cause apparently 
being bad BIOS code.  I wish I could do more, but RH can't be in the business 
of fixing HW vendor's BIOS code. 
Comment 11 John W. Linville 2005-08-03 11:27:30 EDT
FWIW, I do have kernels patch to allow for replacing the ACPI DSDT available 
here: 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
If someone wants to experiment w/ fixing the DSDT so that maybe they can get 
rid of the "acpi=noirq" stuff, they can play with those kernels.  Directions 
for use are available here: 
 
   https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=158865#c26 
 
Best of luck!  Let me know if you get something working! 
Comment 12 Doncho N. Gunchev 2005-08-07 15:30:58 EDT
(In reply to comment #11)
> FWIW, I do have kernels patch to allow for replacing the ACPI DSDT available 
> here: 
...
> Best of luck!  Let me know if you get something working! 

    I got 2.6.12-1.1398_FC4's src.rpm, turned CONFIG_STANDALONE off,
CONFIG_ACPI_CUSTOM_DSDT on and pointed CONFIG_ACPI_CUSTOM_DSDT_FILE to my custom
DSDT file. This way I got my batery status back, but still need pci=noacpi or
acpi=noirq (maybe acpi=ht works also, but no battery). I guess I messed up
something in the DSDT for the NIC, so I'll try again with your patches which
make loading new DSDT much easier and report back. Thanks a lot.
Comment 13 Doncho N. Gunchev 2005-08-07 20:42:21 EDT
    kernel-2.6.12-1.1390.4.1_FC4.jwltest.13.i686.rpm crashed while booting, but
I applied jwltest-acpi-dsdt-initrd.patch to 2.6.12-1.1398_FC4 and with the help
of the modified mkinitrd everything worked (the kernel loaded my DSDT). The only
strange thing is that I'm getting two AVC messages for restorecon trying to {
read  } DSDT.aml and kmodule trying to { use } it after SELinux finishes
'Setting up existing superblocks'. Thanks a lot!

Note You need to log in before you can comment on or make changes to this bug.